Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-17-04, 11:24 AM   #1
sam_mtl
Registered User
 
Join Date: Mar 2004
Location: Montreal, Canada
Posts: 2
Default Segmentation Fault with no semaphore set

I hope someone can help with this problem.

Apps that I compile for LINUX REDHAT 7.2 give a segmentation fault on the first try then they run properly.

It seems they crash when a semaphore is not set. When I run the application initially with the semaphore not set, it crashes. When I run ipcs, I see there is a semaphore which is setfor some reason. When I run a second time, the application launches no problem.

If I remove the semaphore, the app will crash again and the semaphore will again be set.

This only occurs on my new system with a Quadro FX1000 grahics card and the 1.0-5336 drivers from NVidia.

The other systems I have with REDHAT 7.2 and less powerful graphics cards do not exibit this behavior.

The semaphore being set is always the same "0x17021519"

I have checked the driver installation as per the readme file supplied with the drivers and it seems correct.

Any help would be appreciated.

BTW - Upgrading the OS is not an option.

Cheers,

JB
sam_mtl is offline   Reply With Quote
Old 03-17-04, 12:02 PM   #2
ringfan
Registered User
 
Join Date: Mar 2004
Posts: 1
Default

Quote:
BTW - Upgrading the OS is not an option.
Well, you've put yourself in an awkward situation - you are using an ancient, unsupported and obsolete release, and saying you can't or won't upgrade.

Honestly, I've got nvidia cards in 4 different linux desktop machines, all running fedora core 1, and I've never seen the problem you're describing. It will be difficult to find support for your dinosaur I'm afraid.
ringfan is offline   Reply With Quote
Old 03-17-04, 12:34 PM   #3
sam_mtl
Registered User
 
Join Date: Mar 2004
Location: Montreal, Canada
Posts: 2
Default

Thanks for the reply.

I know I am up the creek on this one.

This is actually for a customer of mine who is breathing down my neck to get it to work. The problem is our compiled libs are only currently supported by 7.2.

We had warned this may happen, but they did not listen.

Would you know where or who I may be able to find info concerning a driver issue such as this?

Thanx
sam_mtl is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Union - Post-Apocalyptic RPG Shooter set in Russia dikinher Gaming Central 5 06-08-12 10:01 AM
Hitman: Absolution release date set, Sniper Challenge pre-order game in August News Latest Tech And Game Headlines 0 05-10-12 09:28 AM
Stubborn screen res problem Alpsoandso NVIDIA Linux 6 05-03-12 06:00 PM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
Segmentation Fault on RH 7.3 Lawrence DeLeon NVIDIA Linux 4 09-16-02 11:42 AM

All times are GMT -5. The time now is 11:34 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.