Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-17-02, 10:10 PM   #1
lucianpoe
Registered User
 
Join Date: Oct 2002
Location: Detroit area
Posts: 13
Send a message via Yahoo to lucianpoe
Post RedHat 8.0 I686 arch and nVidia GeForce4

I'm using a P4 (i686 arch). Redhat 8.0 with a brand new kernel 2.4.18-17.8.0(debug) released just yesterday (10-16-02). Video card is Gainward 700XP with a NVidia GeForce4 Ti4600 chipset and 128 Mb memory on it.

NVidia drivers for my GeForce4 Ti4600 will no longer work, whether I use the ready-built GLX and kernel releases or I rebuild on my own both .src.rpm files. I'm getting a GDM exception (execution error, or EE): " NVIDIA(0): Failed to initialize the NVdriver kernel module!".

The GDM complains in the log file that the NVidia chipset is unknown, and the BrookTree chipset is also unknown.

I have to use my old "vesa" driver instead.

Note that the GDM & drivers DO work when I boot using the i386 redhat kernel, but not when using either one of the i686 kernels.

Any help would be appreciated.
Attached Files
File Type: txt xfree86.0.log.txt (50.5 KB, 170 views)

Last edited by lucianpoe; 10-18-02 at 02:29 AM.
lucianpoe is offline   Reply With Quote
Old 10-18-02, 01:14 AM   #2
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Did you download and install the kernel-source package for your new kernel? Unless you have the matching kernel source package installed, you won't be able to correctly compile and install the NVIDIA driver.

Can you post an X log using the "nvidia" driver instead of vesa?

Thanks!

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 10-18-02, 02:25 AM   #3
lucianpoe
Registered User
 
Join Date: Oct 2002
Location: Detroit area
Posts: 13
Send a message via Yahoo to lucianpoe
Talking ANY RedHat8.0 release works

I figured it out.

I have ALL the headers / RPMS/ everything else you ever need. Untill I tried this, everything else was to no avail.

#0) make sure you boot using the RedHat kernel you intend to boot from in the future using the new NVIDIA drivers; if you only have 1 kernel to choose from at boot time, don't worry about this step;

- i.e., I have both the 2.4.17 kernel (for i386 architecture) and the 2.4.18-17.8.0 kernel (for i686 architecture); I'd have to boot using the 2.4.18-17.8.0 kernel (for i686) if this is where I want to use my NVIDIA drivers.

#1) run this command (and all the subsequent commands) in a terminal window (prefferably Gnome, although KDE has been reported to work also):
rpm -qa | grep NV
- this will find any previously installed NVidia drivers;
- if there are none, good; Skip to step#2;
- if there are, then run this:
rpm -e NVIDIA_GLX-1.0-3123
rpm -e NVIDIA_kernel-1.0-3123
- this will remove any existing NVIDIA drivers; this way you will have no problems later on;

#2) cd /usr/src/redhat/RPMS/ , then
cd /i386 (where i386 is the architecture of your CPU as recognized by RedHat8.0)
- make sure there are no files starting with "NVIDIA" ; if there are, erase all of them using rm -f NVIDIA*;

#3) download the SOURCE rpms of both GLX and kernel NVidia files (NVIDIA_GLX-1.0-3123.src.rpm, and NVIDIA_kernel-1.0-3123.src.rpm) off NVidia's web site (you will find the GLX source file at the top of the page, and the kernel source at the bottom); make sure you know where the files where saved on your PC.

#4) move into the directory where you saved the source files (using the cd myDownloads command, where myDownloads is the name of the directory you saved the source files);

#5) build the rpm packages for your specific kernel; this is done by using
rpmbuild --rebuild NVIDIA_kernel-1.0-3123.src.rpm;
rpmbuild --rebuild NVIDIA_GLX-1.0-3123.src.rpm
commands;
- the freshly built rpms will be automatically saved under /usr/src/redhat/RPMS/ix86/, where ix86 is the architecture recognized by your rpm package;

HINT:
- if you read carefully the output on the screen generated by the last rpmbuild command, towards the end you will see a line saying something like "saved in /usr/src/redhat/RPMS/i386" - this is where your generated rpms have been saved ;


#6) cd to the directory where the rpms have been saved; you should only have two (2) NVIDIA rpm files; once there, run these commands, in this order:
rpm -ivh NVIDIA_kernel-1.0-3123.*
rpm -ivh NVIDIA_GLX-1.0-3123.*

- at this point, you should get no errors;

#7) cd /etc/X11/ ;
- use the ls -l command to have the contents of the directory listed; the display settings file name should look like this: XF86Config or XF86Config-4;

-backup the existing file first:
cp XF86Config XF86Config.backup

- use pico XF86Config to either remove or comment out (add # at the beginning of each line) the entire "dri" section (typically found at the bottom of the file);

- in the "Display" section, replace the existing driver (tipically vesa) with "nvidia";

- Don't forget to SAVE the changes.

This is what my XF86Config file looks like at the end:

#====================================
# XFree86 4 configuration modified by me on 10-17-2002
#
# The following section has been removed from the bottom of the file;
# uncomment it and reboot to have the Xserver reconfigure
# using a default "safe" video driver;
#
#Section "DRI"
# Group 0
# Mode 0666
#EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "KDS"
ModelName "Radius 5x"
HorizSync 31.5 - 48.5
VertRefresh 40.0 - 70.0
ModeLine "1400x1050" 129.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
ModeLine "1400x1050" 151.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
ModeLine "1400x1050" 162.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
ModeLine "1400x1050" 184.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia" # this replaced 'Driver "vesa"' in my case;
VendorName "Gainward"
BoardName "Gainward nVidia GeForce 4 Ti4600"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

=============================

#8) reboot.

After all servers have been started, you should see the nVidia logo prior to the Xserver start-up.

Happy gaming!

Last edited by lucianpoe; 10-18-02 at 09:46 PM.
lucianpoe is offline   Reply With Quote
Old 10-18-02, 02:41 AM   #4
lucianpoe
Registered User
 
Join Date: Oct 2002
Location: Detroit area
Posts: 13
Send a message via Yahoo to lucianpoe
Default

I'm sorry, Andy, but when I reinstalled everything using the "vesa" driver, the initial log file generated while using the "nvidia" driver was overwritten. I never thought of saving it. I can try to reproduce the errors, but it will probably never be the same, now that it works correctly. All I had to do was to "clean up" and then rebuild both the GLX and the kernel rpm's for the NVIDIA files. See above posting.

--Lucian

Quote:
Originally posted by Andy Mecham
Did you download and install the kernel-source package for your new kernel? Unless you have the matching kernel source package installed, you won't be able to correctly compile and install the NVIDIA driver.

Can you post an X log using the "nvidia" driver instead of vesa?

Thanks!

--andy
lucianpoe is offline   Reply With Quote
Old 10-18-02, 03:02 AM   #5
lucianpoe
Registered User
 
Join Date: Oct 2002
Location: Detroit area
Posts: 13
Send a message via Yahoo to lucianpoe
Default

Here you go, Andy. I was able to reproduce the exact problem using the RedHat8.0's 2.4.18-17.8.0(debug) kernel version. Log file attached. The /etc/X11/XF86Config file is the exact same one posted above.

--Lucian

Quote:
Originally posted by Andy Mecham
Did you download and install the kernel-source package for your new kernel? Unless you have the matching kernel source package installed, you won't be able to correctly compile and install the NVIDIA driver.

Can you post an X log using the "nvidia" driver instead of vesa?

Thanks!

--andy
Attached Files
File Type: txt xfree86.0.log.txt (16.9 KB, 168 views)

Last edited by lucianpoe; 10-18-02 at 03:05 AM.
lucianpoe is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:13 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.