Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-14-04, 06:17 AM   #1
]3uRn
Registered User
 
Join Date: Mar 2004
Posts: 4
Angry HELP ME: GF2 drivers on MDK9.2

Hi vry'1 !

I've been trying to get 3D acceleration or my GeForce2 for 3 days now, and I everytime I think it's gonna be over with it...

So my comp is:
- driver version: NVIDIA-Linux-x86-1.0-5336-pkg1.run
- distribution: Mandrake 9.2
- kernel: 2.4.22-28mdk
(And I have the correct kernel sources installed).
- What's in /proc/driver/nvidia/cards/0:
----------
Model: GeForce2 MX/MX 400
IRQ: 0
Video BIOS: ??.??.??.??.??
Card Type: AGP
-----------
- processor: AMD athlon 1G

How I tried to install the whole stuff:
- 1. Getting NVIDIA-Linux-x86-1.0-5336-pkg1.run
- 2. Shutting down KDE
- 3. Going into root
- 4. telinit 3
- 5. sh NVIDIA-Linux-x86-1.0-5336-pkg1.run
- 6. telinit 5
- 7. Goin out of root
- 8. Startin KDE again

Then I get this Error:
NVIDIA(0): Failed to initialize the NVIDIA graphics device!

I've checked that:
1. I had the correct kernel sources.
2. /usr/src/linux stands for /usr/src/linux-2.4.22-28mdk
3. /lib/modules/2.4.22-28mdk/build also stands for /usr/src/linux-2.4.22-28mdk/

Please help me ! I don't want to have to re-install ooendoz to get 3D acceleration !!! PLEASE !!!

(while writin this, I'm starting to think that I might have one last thing to try since it says GeForce2 DDR in my XF86Config-4 file and MMX in /proc/driver/nvidia/cards/0...)

]3uRn

PS: Here's my XF86Config-4 coz i'm not smart enough to figure out how to attach a second file to this post:

XF86Config-4
------------
# File generated by XFdrake.

# ************************************************** ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# ************************************************** ********************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
#DontZap # disable <Crtl><Alt><BS> (server abort)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "/usr/X11R6/lib/modules/extensions/libglx.so"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbCompat" ""
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "HP D5259A Pavilion M70 Monitor"
HorizSync 30-70
VertRefresh 50-120

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce2 DDR (generic)"
Driver "nvidia"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 15
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 16
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 24
Virtual 1024 768
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection
------------
Attached Files
File Type: log xfree86.0.log (13.2 KB, 197 views)
]3uRn is offline   Reply With Quote
Old 03-14-04, 08:25 AM   #2
Xyphus
Computer Junkie
 
Xyphus's Avatar
 
Join Date: Aug 2002
Posts: 25
Default

sometimes, after the install of the drivers and editing of the XF86Config-4 file, you need to run ldconfig to clean up dependencies, etc.
Xyphus is offline   Reply With Quote
Old 03-14-04, 12:22 PM   #3
]3uRn
Registered User
 
Join Date: Mar 2004
Posts: 4
Default

Quote:
Xyphus saiz:
sometimes, after the install of the drivers and editing of the XF86Config-4 file, you need to run ldconfig to clean up dependencies, etc.
Thx, I hadn't thought about that, but I just tried:
ldconfig
ldconfig -n /lib/modules/2.4.22-28mdk/kernel/drivers/video/
and it still doesn't work...

I'm starting to wonder what I did in a prior life to have such a baaaaaaad karma.
]3uRn is offline   Reply With Quote
Old 03-16-04, 07:35 PM   #4
haroldinct
Registered User
 
Join Date: Mar 2004
Location: Connecticut
Posts: 2
Unhappy

I am wondering if our problem isn´t that Mandrake doesn´t use the XFree font server after 9.0. Nvidia may be having a problem with that. I hope to see if I can change to the default font server and see if that fixes our problem.

However, I haven´t been able to figure out how to do that yet.

Harold
haroldinct is offline   Reply With Quote
Old 03-17-04, 01:19 AM   #5
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default

Does the nvidia kernel module load properly when you modprobe it? (Don't worry about tainting)
whig is offline   Reply With Quote
Old 03-17-04, 06:35 AM   #6
]3uRn
Registered User
 
Join Date: Mar 2004
Posts: 4
Cool

yeah the module does load indeed. i even modified my /etc/modules to have it automatikely load on boot.
]3uRn is offline   Reply With Quote
Old 03-28-04, 11:18 PM   #7
dysfirkin
Registered User
 
Join Date: Mar 2004
Posts: 1
Default Re: HELP ME: GF2 drivers on MDK9.2

Hi,

I have an almost identical setup. Mandrake 9.2 with a Geforce2MX 400. I spent the better part of five hours working on this today and finally got it running. What I did is edit the standard XF86Config-4 settings that XFdrake was providing to a lower setting in the "screen" section.

Specifically I changed the defaultdepth setting to 16 from 24 and used lower settingfor the subsection "Display". I also upgrade to the latest kernel 2.6.3.7 from Mandrake along with the Kernel source and installed the Nvidia 5336 drivers using the Nvidia installer.

HEre is a copy of my XF86Config Config file so you can see what I did.
Attached Files
File Type: txt XF86Config-4.txt (2.6 KB, 178 views)
dysfirkin is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Drivers Receive Windows 8 Certification News Archived News Items 0 06-01-12 05:30 AM
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 06:30 PM
Creative drivers ? SparrowHawk General Hardware 39 11-18-02 08:03 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
Nvidia Stereo Drivers Soudontsay NVIDIA Windows Graphics Drivers 2 08-26-02 10:48 AM

All times are GMT -5. The time now is 08:30 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.