Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-29-04, 02:42 AM   #1
the_ball
Linux User
 
the_ball's Avatar
 
Join Date: Mar 2004
Posts: 2
Exclamation GeForce4 420 Go TwinView problem

Hi there, I am having trouble getting TwinView to work when I want to treat the two displays as seperate devices. TwinView with metamodes work fine, but I want to use Xinerama to make KDE aware of the two displays and place new windows smarter and also maximize only inside one screen.

When I use the attached XF86config-4 file to use both devices the computer freezes with 4496 while with 5336 the lcd does something veird that looks self destructive but it has not harmed it.

The machine is a Compal ACL-10

Nvidia version: 4496 (Hangs)
Nvidia version: 5336 (Veird lcd)
Distro: Gentoo linux

# uname -a
Linux berbara 2.6.5-rc2 #15 Sun Mar 28 17:30:22 EST 2004 i686 Mobile Intel(R) Pentium(R) 4 - M CPU 1.80GHz GenuineIntel GNU/Linux

# cat /proc/driver/nvidia/cards/0
Model: GeForce4 420 Go
IRQ: 10
Video BIOS: 04.17.00.40.a2
Card Type: AGP

# cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 15
model : 2
model name : Mobile Intel(R) Pentium(R) 4 - M CPU 1.80GHz
stepping : 7
cpu MHz : 1794.821
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid
bogomips : 3555.32
Attached Files
File Type: txt xinerama.txt (2.9 KB, 139 views)
the_ball is offline   Reply With Quote
Old 03-29-04, 04:17 AM   #2
rednuht
GeForce FX5600 (1.0-5336)
 
rednuht's Avatar
 
Join Date: Sep 2003
Location: uk
Posts: 164
Default Re: GeForce4 420 Go TwinView problem

nvidia alread has xinerama extensions (see readme).
rednuht is offline   Reply With Quote
Old 03-29-04, 06:27 PM   #3
the_ball
Linux User
 
the_ball's Avatar
 
Join Date: Mar 2004
Posts: 2
Exclamation Re: GeForce4 420 Go TwinView problem

Quote:
Originally Posted by rednuht
nvidia alread has xinerama extensions (see readme).
Yes I know but what I want to do is in
APPENDIX R: CONFIGURING MULTIPLE X SCREENS ON ONE CARD
That setup is what screws the lcd display.

I can't explain what happens to the lcd, but I have uploaded a video to my website that shows the two screens when starting x with the attatched XF86Config

http://wigen.net/veird-lcd.xvid.mpeg (3,2MB)

I have seen the same behaviour once when I was playing with suspend/hibernate, after that I disabled it.

Cheers
Alex

Last edited by the_ball; 03-29-04 at 07:30 PM.
the_ball is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GeForce4 Ti 4400 problem with RAID motherboard hydr0 NVIDIA GeForce 7, 8, And 9 Series 10 10-26-02 01:06 AM
Sony SDM-S51 monitor and GeForce4 problem hassasin NVIDIA GeForce 7, 8, And 9 Series 4 10-12-02 04:10 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM
nVidia Geforce4 440 Go 1400x1050 problem moreinf NVIDIA Linux 10 09-16-02 12:25 PM
Driver support for GeForce4 420 Go and Windows 98? h_happy NVIDIA Windows Graphics Drivers 12 08-25-02 11:19 PM

All times are GMT -5. The time now is 12:26 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.