Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-14-04, 10:30 AM   #1
texray
Registered User
 
Join Date: Apr 2004
Posts: 2
Default Bad performance - what to do?

Hi everybody.
I run a Slackware 9.1 System with Kernel 2.6.5 using my NVidia Gforce FX 5700.
I installed the latest NVidia Linux drivers (5336) and everything seems running fine, but not at optimum speed.
The kernel module built fine, and I modprobed it using the appropriate parameters.
/proc/driver/nvidia/agp/status tells me:
Status: Enabled
Driver: AGPGART
AGP Rate: 8x
Fast Writes: Enabled
SBA: Enabled

So far, so good. But when running glxgears, I only get around 2500 fps. This should be at least 6000, I don't know what could be the cause of this low rate.

Some more information:
Mainboard: Asus k8v Deluxe (I compiled the chipset drivers into the kernel)
Video Bios: 04.36.20.21.00
Processor: Athlon 64 3000+ (Note: I'm not running a 64bit Linux System for several reasons at the moment (I tried, tough). So I also Use the IA32 Nvidia drivers.)
I also attached my current XF86Config. (XFree 4.3.0)

-- texray
Attached Files
File Type: txt XF86Config.txt (2.5 KB, 125 views)
texray is offline   Reply With Quote
Old 04-14-04, 10:49 AM   #2
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: Bad performance - what to do?

You could try playing with the AGP support.

Best thing is to compile kernel AGP support as a module and follow the directions in the NVIDIA documentation to switch between NVIDIA and kernel AGP support.

I'll get back to you. Have to re-compile my kernel first.; -)
hppnq is offline   Reply With Quote
Old 04-14-04, 10:52 AM   #3
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default Re: Bad performance - what to do?

Try using a different nvagp mode other than 2.
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Old 04-14-04, 03:03 PM   #4
texray
Registered User
 
Join Date: Apr 2004
Posts: 2
Default Re: Bad performance - what to do?

Yes I tried that already. I get even less FPS in glxgears when using NvAGP (around 2300). I'll try compiling APG support as a module.
texray is offline   Reply With Quote
Old 04-14-04, 03:39 PM   #5
Phorem
Registered User
 
Join Date: Dec 2003
Location: Toronto
Posts: 34
Default Re: Bad performance - what to do?

You can't compile the agpgart or the amd64-agp as modules (in 32 or 64). The make menuconfig won't even give you (and obviously me) the option. I could be wrong, but i'm pretty sure you can't. And if you can, it won't work probably.

Edit** - i'm refering to the 2.6 kernels. The 2.4's still have modular support i think.
__________________
Gentoo Linux-64, AMD64 Athlon 3200, Asus K8V Deluxe, 1 gig(3200 400mhz) ram, GeForce FX5200 128, HP 400i DVD+R+RW, HP ScanJet 2200c, Epson Stylus C84, JVC DRV3000U (firewire - usb), Kodak CX6330
Phorem is offline   Reply With Quote
Old 04-14-04, 05:13 PM   #6
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: Bad performance - what to do?

Don't know about AMD64, but vanilla ia32 2.6.5 certainly allows for a modular AGP driver.
You can't have both native NvAGP and kernel AGP support.

Anyway, for me NvAGP and agpgart result in more or less equal FPS rates, running glxgears.
hppnq is offline   Reply With Quote
Old 04-14-04, 07:13 PM   #7
how
Registered User
 
Join Date: Dec 2002
Location: Australia
Posts: 142
Default Re: Bad performance - what to do?

HI texray,

I got exactly the same thing. glxgears 2600fps fx 5700. kernel 2.6.5. Athlon-XP. Fedora 1. There must be a bug somewhere. I thought it was Redhat/Fedora problem, but it seems not, you are using Slackware. I tried PCI mode and is the same. I think it should be at least 5000-6000fps as well. I hope they fix it in the next release.
how is offline   Reply With Quote
Old 04-14-04, 08:53 PM   #8
Corona688
Registered User
 
Join Date: Feb 2004
Posts: 93
Default Re: Bad performance - what to do?

Quote:
Originally Posted by Phorem
You can't compile the agpgart or the amd64-agp as modules (in 32 or 64). The make menuconfig won't even give you (and obviously me) the option. I could be wrong, but i'm pretty sure you can't.
The problem is not the kernel but the processor. AMD64 processors have built-in GART support that the kernel must use for it to work. This means that AGPGART must always be included and must always be compiled into the kernel, and will always make the current nvidia amd64 driver go ape**** in many annoying ways, at the very least for the whole GeforceFX series..

try 'make xconfig' and fiddle with the advanced options, it'll show you the options which are there but disabled.

I'm using Gentoo, btw. That's at least three distributions now.
Corona688 is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
SGI Boosts Big Data Performance with Sandy Bridge News Archived News Items 0 05-15-12 08:10 AM
Boost Your Performance Goals 10x ' This Week on inside* Publications News Archived News Items 0 05-13-12 05:20 PM
NVIDIA Unleashes the GeForce GTX 670 Graphics Card ' Performance Perfected (WCCFTECH) News GeForce GTX 670 Reviews 0 05-10-12 08:40 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
so let's try this again in the new forum - bad performance with correctly inst.driver neutrino NVIDIA Linux 11 08-01-02 04:19 PM

All times are GMT -5. The time now is 07:28 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.