Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-10-02, 03:46 PM   #1
arise
Registered User
 
Join Date: Oct 2002
Location: Europe
Posts: 93
Default Cannot load AGPGART

Redhat 8.0
GF4 Ti4200
Asus P4S533 (Sis645DX)
Drivers 31.23 from SRPMs

GFX card is recognized as 4x 2x 1x capable:

Model: GeForce4 Ti 4200
IRQ: 11
Video BIOS: 04.25.00.30.00
Card Type: AGP
---------------------------------
Fast Writes: Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000217:0x00000000
------------------------------------------

The SIS 645DX looks like it's unknown:

Host Bridge: SiS (unknown)
Fast Writes: Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000217:0x00000000

----------------------

Modprobe, insmode and /etc/modules.conf cannot load the agpgart driver:

/lib/modules/2.4.18-14/kernel/drivers/char/agp/agpgart.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.18-14/kernel/drivers/char/agp/agpgart.o: insmod /lib/modules/2.4.18-14/kernel/drivers/char/agp/agpgart.o failed
/lib/modules/2.4.18-14/kernel/drivers/char/agp/agpgart.o: insmod agpgart failed


=========================
Help anyone, pls?
arise is offline   Reply With Quote
Old 10-10-02, 04:58 PM   #2
arise
Registered User
 
Join Date: Oct 2002
Location: Europe
Posts: 93
Default

I solved it.
I ran "dmesg" from a terminal, and i saw the kernel messages that told me:

Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 439M
agpgart: Unsupported SiS chipset (device id: 0646), you might want to try agp_tr
y_unsupported=1.
agpgart: no supported devices found.

I did just that:

"modprobe agpgart agp_try_unsupported=1"

...and it loaded just fine
arise is offline   Reply With Quote
Old 10-21-02, 04:11 PM   #3
Soul-Crusher
Leadtek 6800GT
 
Join Date: Aug 2002
Location: Albuquerque, NM, USA
Posts: 195
Send a message via ICQ to Soul-Crusher Send a message via AIM to Soul-Crusher Send a message via Yahoo to Soul-Crusher
Default

Very interesting. If you go into your source tree and edit the agpgart_be.c file in the linux/drivers/char/agp directory, you can add device ID's like this:
{ PCI_DEVICE_ID_SI_740,
PCI_VENDOR_ID_SI,
SIS_GENERIC,
"SiS",
"740",
sis_generic_setup },

It ain't pretty, but it's a more permanent solution. I had to do that on my SiS745 with some older kernels, but the new kernel fixed that. I suppose the latest 645 chipset is even newer than the 2.4.19 kernel?
__________________
"Floating in a dream-like state, I am the emporer of a parallel universe." --Arch Enemy
My xorg.conf file
Soul-Crusher is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GT9800 (and previously a 8600 GTS) randomly hangs X, more frequently under load robsims NVIDIA Linux 1 06-12-12 04:21 AM
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM
Lucid rt kernel can't load latest nvidia driver module, but generic does. marcod NVIDIA Linux 0 05-02-12 06:23 AM
Can't load NVdriver jojotux123 NVIDIA Linux 4 09-18-02 06:15 AM
Nvidia + XFree86 4.1.0.1 + iiyama VMPro 410 horizontal refresh probs Will NVIDIA Linux 6 08-09-02 08:57 AM

All times are GMT -5. The time now is 11:38 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.