Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-25-04, 09:52 PM   #1
bvitale
Registered User
 
Join Date: Mar 2004
Posts: 3
Unhappy TVout not working - MX440 on Fedora Core 1

Hi folks. Config is as follows:

GeForce4 MX440 AGP 8X 64MB with TVOut
Fedora Core 1, Linux 2.4.22-1.2115.nptl
Athlon XP 2500+ on a Gigabyte GA-7N400-L Motherboard
NVIDIA Driver: 1.0-5336 2004/01/07
Video Bios: 04.18.20.15.00

XF86Config and the XFree86 log are attached.

The problem is simple: nothing shows on the TV. I tried setting ConnectedMonitor to just "TV", but still nothing.

Video card is physically connected to the television with an svideo-composite adapter followed by a composite RCA cable. TV is a 27" JVC (NTSC).

The only relevant (I think) line from the log is this:
NVIDIA(0): Failure reading EDID parameters for display device TV-0

But later, I see..
(**) NVIDIA(0): Validated modes for display device TV-0:
(**) NVIDIA(0): Default mode "1024x768": 65.0 MHz, 48.4 kHz, 60.0 Hz
etc...

So it makes me think the TV connection is at least physically working?

Anyone have any insight?

TIA,

Ben
Attached Files
File Type: txt XF86Config.txt (2.1 KB, 240 views)
File Type: txt XFree86.0.txt (34.3 KB, 183 views)
bvitale is offline   Reply With Quote
Old 04-14-04, 01:45 PM   #2
Liontooth
GeForce4 420 Go 32M
 
Join Date: May 2003
Posts: 17
Default Re: TVout not working - MX440 on Fedora Core 1

Hi Ben --

Because you have Option "ConnectedMonitor" "CRT,TV" in your X config file, you can't infer the computer detects the TV -- it just assumes it's there and produces standard values.

It could be your cable. The nvtv project has a CONVERT parameter for the --connector flag, which "compensates for cheap SVideo to composite converter cables that don't merge both lines." (from the man page).

I have the same problem you have -- that is to say, s-video to s-video works, but the s-video to composite cable doesn't.

I'll give nvtv a try, or look for another cable. I borrowed the cable from a friend who uses this on a powerbook (OSX), where it works fine.

Cheers,
David
Liontooth is offline   Reply With Quote
Old 04-14-04, 03:49 PM   #3
Phorem
Registered User
 
Join Date: Dec 2003
Location: Toronto
Posts: 34
Default Re: TVout not working - MX440 on Fedora Core 1

Try toning down that resolution. When i was trying to do what you are doing on Exactly the same video card, i ran into troubles with the resolution and Freq.

Try 720x486 (i think that's it).
Maybe also add the "NTSC" option as well. And it might just be that cable. Do you have a tv or camcorder with S-video in? If so, try that first.
__________________
Gentoo Linux-64, AMD64 Athlon 3200, Asus K8V Deluxe, 1 gig(3200 400mhz) ram, GeForce FX5200 128, HP 400i DVD+R+RW, HP ScanJet 2200c, Epson Stylus C84, JVC DRV3000U (firewire - usb), Kodak CX6330
Phorem is offline   Reply With Quote
Old 04-16-04, 09:25 AM   #4
bvitale
Registered User
 
Join Date: Mar 2004
Posts: 3
Default Re: TVout not working - MX440 on Fedora Core 1

Thanks for the replies guys. When I use an S-VIDEO cable directly from the card to the TV, TV-out works properly at 1024x768, although the flicker is kinda bad. Unfortunately I don't have an s-video cable long enough to use it all the time.

I tried switching the RCA cable to a new one, and still nothing. Perhaps the svideo-composite converter is bad (?).

David, I grabbed nvtv to try the CONVERT parameter, but it states explicitly in their FAQ that MX440 chips with the tv encoder "NVIDIA" are not supported

On the up-side, at least I know my TV-out works, and that my X settings are all correct!

Ben
bvitale is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel's Ivy Bridge Core i7 3770K Overheating Issue Detailed News Archived News Items 0 05-16-12 10:40 AM
CPUMark99 - how do you compare fuelrod Benchmarking And Overclocking 66 07-19-11 08:32 AM

All times are GMT -5. The time now is 10:11 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.