Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-15-04, 10:58 PM   #1
FireFerum
Always Need Help
 
Join Date: Apr 2004
Location: Lawrenceville, GA
Posts: 8
Send a message via ICQ to FireFerum
Unhappy XFree86-4 (Mdk 10) crashes with driver 5336

I tried to install the new drivers as I am trying to be able to run Counter-Strike on WineX and I need OpenGL. So, I downloaded the drivers, followed the instructions to install, everything was OK, I loaded into XFree86-4 which is by default what comes up when I log in and edited the XF86Config-4 file just by switching nv to nvidia. Here is the file:
Code:
# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Mandrake 6.0 and later now use a font server independent of
    # the X server to render fonts.
    FontPath "unix/:-1"
EndSection

Section "ServerFlags"
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer
EndSection

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "Keyboard"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "en_US"
    Option "XkbOptions" ""
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/mouse"
    Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Plug'n Play"
    ModelName "Dell D1226H"
    HorizSync 30-95
    VertRefresh 50-160
    
    # Sony Vaio C1(X,XS,VE,VN)?
    # 1024x480 @ 85.6 Hz, 48 kHz hsync
    ModeLine "1024x480"    65.00 1024 1032 1176 1344   480  488  494  563 -hsync -vsync
    
    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
    
    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
    Identifier "device1"
    VendorName "nVidia Corporation"
    BoardName "NVIDIA GeForce2 DDR (generic)"
    Driver "nvidia"
    Option "DPMS"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24
    
    Subsection "Display"
        Depth 8
        Virtual 1024 768
    EndSubsection
    
    Subsection "Display"
        Depth 15
        Virtual 1024 768
    EndSubsection
    
    Subsection "Display"
        Depth 16
        Virtual 1024 768
    EndSubsection
    
    Subsection "Display"
        Depth 24
        Virtual 1024 768
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    Screen "screen1"
EndSection
So, once I did a reboot and all XFree86-4 did not come up and Linux went to non visual mode for me wonder what went wrong. I have the XFree86-4 log file too which I will list below (last part of it) because I am not too good with linux. I have been trying to get it to be in tip top shape for about a week now non-stop, mostly to get Counter-Strike to play on there (tried VMware and wine, and more but that's a different story). Back to the topic, I tried to install again with the same type of results so please somebody help me! Here is that log file and I am sorry if it makes the thread too long. I am new to this forum so I don't know all the rules yet.
Code:
(II) Module mouse: vendor="The XFree86 Project"
	compiled for 4.3.0.1, module version = 1.0.0
	Module class: XFree86 XInput Driver
	ABI class: XFree86 XInput driver, version 0.4
(II) v4l driver for Video4Linux
(II) NVIDIA XFree86 Driver  1.0-5336  Wed Jan 14 18:30:46 PST 2004
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) Primary Device is: PCI 00:0a:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found
(II) resource ranges after xf86ClaimFixedResources() call:
	[0] -1	0	0xffe00000 - 0xffffffff (0x200000) MX[b](B)
	[1] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
	[2] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[b]
	[3] -1	0	0x000c0000 - 0x000effff (0x30000) MX[b]
	[4] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[b]
	[5] -1	0	0xe2003000 - 0xe20030ff (0x100) MX[b]
	[6] -1	0	0xe2002000 - 0xe2002fff (0x1000) MX[b]
	[7] -1	0	0xe2001000 - 0xe2001fff (0x1000) MX[b]
	[8] -1	0	0xe2000000 - 0xe2000fff (0x1000) MX[b]
	[9] -1	0	0xd0000000 - 0xcfffffff (0x0) MX[b]O
	[10] -1	0	0xd8000000 - 0xdfffffff (0x8000000) MX[b](B)
	[11] -1	0	0xe0000000 - 0xe0ffffff (0x1000000) MX[b](B)
	[12] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[b]
	[13] -1	0	0x00000000 - 0x000000ff (0x100) IX[b]
	[14] -1	0	0x0000e800 - 0x0000e8ff (0x100) IX[b]
	[15] -1	0	0x0000e400 - 0x0000e47f (0x80) IX[b]
	[16] -1	0	0x0000e000 - 0x0000e0ff (0x100) IX[b]
	[17] -1	0	0x00004000 - 0x0000400f (0x10) IX[b]
	[18] -1	0	0x000010c0 - 0x000010df (0x20) IX[b]
(II) resource ranges after probing:
	[0] -1	0	0xffe00000 - 0xffffffff (0x200000) MX[b](B)
	[1] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
	[2] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[b]
	[3] -1	0	0x000c0000 - 0x000effff (0x30000) MX[b]
	[4] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[b]
	[5] -1	0	0xe2003000 - 0xe20030ff (0x100) MX[b]
	[6] -1	0	0xe2002000 - 0xe2002fff (0x1000) MX[b]
	[7] -1	0	0xe2001000 - 0xe2001fff (0x1000) MX[b]
	[8] -1	0	0xe2000000 - 0xe2000fff (0x1000) MX[b]
	[9] -1	0	0xd0000000 - 0xcfffffff (0x0) MX[b]O
	[10] -1	0	0xd8000000 - 0xdfffffff (0x8000000) MX[b](B)
	[11] -1	0	0xe0000000 - 0xe0ffffff (0x1000000) MX[b](B)
	[12] 0	0	0x000a0000 - 0x000affff (0x10000) MS[b]
	[13] 0	0	0x000b0000 - 0x000b7fff (0x8000) MS[b]
	[14] 0	0	0x000b8000 - 0x000bffff (0x8000) MS[b]
	[15] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[b]
	[16] -1	0	0x00000000 - 0x000000ff (0x100) IX[b]
	[17] -1	0	0x0000e800 - 0x0000e8ff (0x100) IX[b]
	[18] -1	0	0x0000e400 - 0x0000e47f (0x80) IX[b]
	[19] -1	0	0x0000e000 - 0x0000e0ff (0x100) IX[b]
	[20] -1	0	0x00004000 - 0x0000400f (0x10) IX[b]
	[21] -1	0	0x000010c0 - 0x000010df (0x20) IX[b]
	[22] 0	0	0x000003b0 - 0x000003bb (0xc) IS[b]
	[23] 0	0	0x000003c0 - 0x000003df (0x20) IS[b]
(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
	compiled for 4.3.0.1, module version = 0.1.0
	ABI class: XFree86 Video Driver, version 0.6
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xD8000000
(--) NVIDIA(0): MMIO registers at 0xE0000000
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0):  *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.
Oh, and I am running the following:

Mandrake 10.0 (kernel 2.6.3-4)
GeForce2 MX (64MB)
AMD XP2500+
512 MB PC3200 RAM

as for the rest I doubt they matter but here you go:
Winex3.3.1
FireFerum is offline   Reply With Quote
Old 04-16-04, 12:41 AM   #2
mr_niceguy
Registered User
 
Join Date: Feb 2004
Location: Canada
Posts: 4
Default Re: XFree86-4 (Mdk 10) crashes with driver 5336

The README I read said that "dri" and "GLcore" also need to be loaded under the "Module" section. I'll just quote your code with those lines added in:

Code:
# File generated by XFdrake.

# **************************************************  ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# **************************************************  ********************

Section "Files"
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Mandrake 6.0 and later now use a font server independent of
    # the X server to render fonts.
    FontPath "unix/:-1"
EndSection

Section "ServerFlags"
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer
    Load "dri"
    Load "GLcore"
EndSection

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "Keyboard"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "en_US"
    Option "XkbOptions" ""
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/mouse"
    Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Plug'n Play"
    ModelName "Dell D1226H"
    HorizSync 30-95
    VertRefresh 50-160
    
    # Sony Vaio C1(X,XS,VE,VN)?
    # 1024x480 @ 85.6 Hz, 48 kHz hsync
    ModeLine "1024x480"    65.00 1024 1032 1176 1344   480  488  494  563 -hsync -vsync
    
    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
    
    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
    Identifier "device1"
    VendorName "nVidia Corporation"
    BoardName "NVIDIA GeForce2 DDR (generic)"
    Driver "nvidia"
    Option "DPMS"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24
    
    Subsection "Display"
        Depth 8
        Virtual 1024 768
    EndSubsection
    
    Subsection "Display"
        Depth 15
        Virtual 1024 768
    EndSubsection
    
    Subsection "Display"
        Depth 16
        Virtual 1024 768
    EndSubsection
    
    Subsection "Display"
        Depth 24
        Virtual 1024 768
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    Screen "screen1"
EndSection
Hope that helps.
mr_niceguy is offline   Reply With Quote
Old 04-16-04, 09:27 AM   #3
FireFerum
Always Need Help
 
Join Date: Apr 2004
Location: Lawrenceville, GA
Posts: 8
Send a message via ICQ to FireFerum
Default Re: XFree86-4 (Mdk 10) crashes with driver 5336

I think you misread the README file... Here is what it says, but I also happened to fix the problem while it crashed with your idea of having those two load as well (i tried it just to make sure )
Code:
Device section and replace the line:
        Driver "nv" 
    with 
        Driver "nvidia"  
In the Module section, make sure you have:
        Load   "glx"
You should also remove the following lines:
      
        Load  "dri"
        Load  "GLcore"
if they exist.  There are also numerous options that can be added to
the XF86Config file to fine-tune the NVIDIA XFree86 driver.  Please see
Appendix D for a complete list of these options.
The way it worked for me was that while it was crashed, and I had the edited XF86Config-4 file already in place, I tried once more to run the install application and it did everything like before, except now the logo shows up and it loads !!!!
__________________
It is not the brains that matter most, but that which guides them -- the character, the heart, generous qualities, progressive ideas. -- Fyodor Dostoevsky
FireFerum is offline   Reply With Quote
Old 04-16-04, 10:01 AM   #4
savagearth
Registered User
 
Join Date: Dec 2003
Posts: 29
Default Re: XFree86-4 (Mdk 10) crashes with driver 5336

It looks like is trying to use a mode that's not there...

try to add this to your subsection display for the colordepth 24
Code:
    Subsection "Display"
        Depth 24
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
Hope that could help ya.
__________________
Personal PC:
AthlonXP 1800+ | MSI KT4VL | 512MB PC2100 | WD 20Gig | SBLive! Value | XFX GeForce FX5200 | LG GCE-8520B | PioneerDVD 16x Slot Load | VIA Rhine-II | Mandrake 10.0 (Cooker) | Linux Kernel 2.6.5-4Phoenix | KDE 3.2.2
savagearth is offline   Reply With Quote
Old 04-16-04, 10:40 AM   #5
mr_niceguy
Registered User
 
Join Date: Feb 2004
Location: Canada
Posts: 4
Default Re: XFree86-4 (Mdk 10) crashes with driver 5336

Nice Add, remove, what's the difference? :P
mr_niceguy is offline   Reply With Quote
Old 04-16-04, 02:41 PM   #6
savagearth
Registered User
 
Join Date: Dec 2003
Posts: 29
Default Re: XFree86-4 (Mdk 10) crashes with driver 5336

I though that maybe it was set to use something other then 1024x768
__________________
Personal PC:
AthlonXP 1800+ | MSI KT4VL | 512MB PC2100 | WD 20Gig | SBLive! Value | XFX GeForce FX5200 | LG GCE-8520B | PioneerDVD 16x Slot Load | VIA Rhine-II | Mandrake 10.0 (Cooker) | Linux Kernel 2.6.5-4Phoenix | KDE 3.2.2
savagearth is offline   Reply With Quote
Old 04-17-04, 03:07 AM   #7
FireFerum
Always Need Help
 
Join Date: Apr 2004
Location: Lawrenceville, GA
Posts: 8
Send a message via ICQ to FireFerum
Default Re: XFree86-4 (Mdk 10) crashes with driver 5336

Unrelated, but can the depth be 32? I don't really know what that number 24 reffers to, but I am thinking perhaps 24 million? If so, can I change it to 32 and have even more color depth? That would really come in useful when I run Counter-Strike. Because as of right now it's a little jumpy and not too smooth. I tried update rates and stuff but they don't make a squat of difference. I think I need a new vid card, but that's money that I can't afford to spend right now. Any advice would be useful, and if you happen to know about CS and winex3, then that's perfect


Anyway, thanks all for the help so far. It has made me from not being able to play Tuxracer to now actually knowing what that game is about. I can actually even have a cool screensaver because I use OpenGL.
__________________
It is not the brains that matter most, but that which guides them -- the character, the heart, generous qualities, progressive ideas. -- Fyodor Dostoevsky
FireFerum is offline   Reply With Quote
Old 04-18-04, 03:52 AM   #8
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default Re: XFree86-4 (Mdk 10) crashes with driver 5336

Quote:
Originally Posted by FireFerum
Unrelated, but can the depth be 32? I don't really know what that number 24 reffers to, but I am thinking perhaps 24 million?
No, X does not support 32 bit color.

The 24 refers not to a number of colors, but to a number of bits (24) that define the color. In 24bit color there are 8 bits each assigned to the 3 primary colors (Red Green Blue) so that by choosing a unique mix of those 3 colors (each ranging 0 - 255) you have a unique RGB color (and yes the number of them ranges in the millions). In 32bit color you have 8 more bits (used for alpha channel control). The number of available colors is not 'strictly' increased. Generally, you and I cannot tell the difference.
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote

Old 04-18-04, 09:32 AM   #9
FireFerum
Always Need Help
 
Join Date: Apr 2004
Location: Lawrenceville, GA
Posts: 8
Send a message via ICQ to FireFerum
Default Re: XFree86-4 (Mdk 10) crashes with driver 5336

Hum, nice to know. Thanks for the reply.
__________________
It is not the brains that matter most, but that which guides them -- the character, the heart, generous qualities, progressive ideas. -- Fyodor Dostoevsky
FireFerum is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM
RH7.3 and nForce - can't find the module dmw400 NVIDIA Linux 4 08-05-02 12:14 PM

All times are GMT -5. The time now is 03:49 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.