Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-20-04, 08:15 PM   #1
Electrode
cogito ergo doleo
 
Join Date: Aug 2003
Posts: 23
Send a message via ICQ to Electrode
Default X.org 6.7.0, driver 5336, two cards: X crashes if I try to use both cards

I recently upgraded from XFree86 4.3.99.12 to X.org 6.7.0. It's working fine, except for one major problem: if I try to use both of my video cards (FX5600U AGP, FX5200 PCI) at the same time, X starts taking up 99% of the CPU it's on and dmesg gets flooded with messages like these:

Code:
Apr 20 20:33:42 belphegor kernel: x2f/0x40
Apr 20 20:33:42 belphegor kernel:  [pci_find_slot+40/80] pci_find_slot+0x28/0x50
Apr 20 20:33:42 belphegor kernel:  [pg0+948376680/1066717184] os_pci_init_handle+0x39/0x68 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+946886751/1066717184] _nv001243rm+0x1f/0x24 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+947612253/1066717184] _nv003797rm+0xa9/0x128 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+948057249/1066717184] _nv001490rm+0x55/0xe4 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+948224340/1066717184] _nv000816rm+0x334/0x384 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+947603756/1066717184] _nv003801rm+0xd8/0x100 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+948223055/1066717184] _nv000809rm+0x2f/0x34 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+947607376/1066717184] _nv003816rm+0xf0/0x104 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+947601803/1066717184] _nv003795rm+0x867/0xaec [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+946987623/1066717184] _n7ef50>] pci_find_subsys+0x110/0x120
Apr 20 20:33:42 belphegor kernel:  [pci_find_device+47/64] pci_find_device+0x2f/0x40
Apr 20 20:33:42 belphegor kernel:  [pci_find_slot+40/80] pci_find_slot+0x28/0x50
Apr 20 20:33:42 belphegor kernel:  [pg0+948376680/1066717184] os_pci_init_handle+0x39/0x68 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+946886751/1066717184] _nv001243rm+0x1f/0x24 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+947612253/1066717184] _nv003797rm+0xa9/0x128 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+948057249/1066717184] _nv001490rm+0x55/0xe4 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+948224340/1066717184] _nv000816rm+0x334/0x384 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+947603756/1066717184] _nv003801rm+0xd8/0x100 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+948223055/1066717184] _nv000809rm+0x2f/0x34 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+947607376/1066717184] _nv003816rm+0xf0/0x104 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+947601803/1066717184] _nv003795rm+0x867/0xaec [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+946987623/1066717184] _nv004046rm+0x3a3/0x3b0 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+948042663/1066717184] _nv001476rm+0x277/0x45c [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+946897818/1066717184] _nv000896rm+0x4a/0x64 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+946903988/1066717184] rm_isr_bh+0xc/0x10 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+948366075/1066717184] nv_kern_isr_bh+0xf/0x13 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [tasklet_action+101/192] tasklet_action+0x65/0xc0
Apr 20 20:33:42 belphegor kernel:  [__do_softirq+166/176] __do_softirq+0xa6/0xb0
Apr 20 20:33:42 belphegor kernel:  [do_softirq+45/48] do_softirq+0x2d/0x30
Apr 20 20:33:42 belphegor kernel:  [do_IRQ+312/400] do_IRQ+0x138/0x190
Apr 20 20:33:42 belphegor kernel:  [common_interrupt+24/32] common_interrupt+0x18/0x20
Apr 20 20:33:42 belphegor kernel: 
Apr 20 20:33:42 belphegor kernel: Badness in pci_find_subsys at drivers/pci/search.c:167
Apr 20 20:33:42 belphegor kernel: Call Trace:
Apr 20 20:33:42 belphegor kernel:  [pci_find_subsys+272/288] pci_find_subsys+0x110/0x120
Apr 20 20:33:42 belphegor kernel:  [pci_find_device+47/64] pci_find_device+0x2f/0x40
Apr 20 20:33:42 belphegor kernel:  [pci_find_slot+40/80] pci_find_slot+0x28/0x50
Apr 20 20:33:42 belphegor kernel:  [pg0+948376680/1066717184] os_pci_init_handle+0x39/0x68 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+946886751/1066717184] _nv001243rm+0x1f/0x24 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+947612253/1066717184] _nv003797rm+0xa9/0x128 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+948057249/1066717184] _nv001490rm+0x55/0xe4 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+948224340/1066717184] _nv000816rm+0x334/0x384 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+947603756/1066717184] _nv003801rm+0xd8/0x100 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+948223055/1066717184] _nv000809rm+0x2f/0x34 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+947607376/1066717184] _nv003816rm+0xf0/0x104 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+947601803/1066717184] _nv003795rm+0x867/0xaec [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+946987623/1066717184] _nv004046rm+0x3a3/0x3b0 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+948042663/1066717184] _nv001476rm+0x277/0x45c [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+946897818/1066717184] _nv000896rm+0x4a/0x64 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+946903988/1066717184] rm_isr_bh+0xc/0x10 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [pg0+948366075/1066717184] nv_kern_isr_bh+0xf/0x13 [nvidia]
Apr 20 20:33:42 belphegor kernel:  [tasklet_action+101/192] tasklet_action+0x65/0xc0
Apr 20 20:33:42 belphegor kernel:  [__do_softirq+166/176] __do_softirq+0xa6/0xb0
Apr 20 20:33:42 belphegor kernel:  [do_softirq+45/48] do_softirq+0x2d/0x30
Apr 20 20:33:42 belphegor kernel:  [do_IRQ+312/400] do_IRQ+0x138/0x190
Apr 20 20:33:42 belphegor kernel:  [common_interrupt+24/32] common_interrupt+0x18/0x20
Before you say it, I have already tried XFree86 4.4.0, and it does the same exact thing. When I comment out the parts of my XF86Config that reference the PCI card, it works just fine.

Here's what I'm using:
Mobo: Tyan Thunder K8W
CPU: 2x AMD Opteron 240
RAM: 2 GB PC2100 (2x512mb per CPU, ECC+Scrub)
Video: Gainward GeForce FX5600 Ultra AGP, Apollo GeForce FX5200 PCI
Kernel: 2.6.5-mm3, ACPI on, APIC on, SMP, 32-bit

XF86Config and Xorg.0.log are attached.
Attached Files
File Type: txt Xorg.0.log.txt (37.2 KB, 111 views)
File Type: txt XF86Config.txt (4.5 KB, 104 views)
Electrode is offline   Reply With Quote
Old 04-21-04, 12:37 PM   #2
dpw2atox
Registered User
 
Join Date: May 2003
Posts: 170
Default Re: X.org 6.7.0, driver 5336, two cards: X crashes if I try to use both cards

is one of the cards doing dual display and the other card doing a single output? because I see 2 instances of all the configurations for the 5200. Also did this work before with XFree86-4.3.0?
dpw2atox is offline   Reply With Quote
Old 04-21-04, 01:30 PM   #3
Electrode
cogito ergo doleo
 
Join Date: Aug 2003
Posts: 23
Send a message via ICQ to Electrode
Default Re: X.org 6.7.0, driver 5336, two cards: X crashes if I try to use both cards

Yes, the 5200 has two monitors connected, and yes it worked perfectly in XFree86 4.3 (at least it did in 32-bit mode, never got it to work in 64-bit)
Electrode is offline   Reply With Quote
Old 04-22-04, 12:33 PM   #4
dpw2atox
Registered User
 
Join Date: May 2003
Posts: 170
Default Re: X.org 6.7.0, driver 5336, two cards: X crashes if I try to use both cards

well from what I can tell it seems to be a bug with the new xfree86-4.4.0 and xorg releases. i'd go to xorgs site and put in a bugzilla report with what you had here.
dpw2atox is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
_which_ quadro cards have stereo support under driver 3123 codingfrenzy NVIDIA Linux 3 12-29-02 03:24 PM

All times are GMT -5. The time now is 08:29 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.