Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-03-04, 08:41 AM   #1
redfrog
ArkLinux Beta Tester
 
Join Date: May 2004
Posts: 4
Question A few Questions Need Answering Please.

G'Day Everyone,

Thanks for the info from my last post. It helped a lot. I have finally gotten my nvidia drivers installed and they are for the most part working well. However, there are some things I am not aware of and am hoping I can have everyone take a look at this file:

http://www.arklinux.info/ark.docs/xfree86.0.log.txt

and tell me if anything seems odd. I have added the "NoLogo" option to my XF86Config file to avoid the logo, but now I am looking into something a little more complex.

Everything seems to run well. However, when I try to run chromium or Frozenbubble ( cause that is what is available ) when I try to go to a full screen for either my machine screen goes black ( normal when mode changing) and the sound skips really fast and then the machine is hosed. I have to actually turn off the machine to get it to work again.

I have been looking at a couple things in the readme file. One that caught my attention is below:

Q: When I run GameX, it crashes when changing video modes; what's wrong?

A: You are probably experiencing the problem described above. Please check the text output for the "WARNING" message describe in the previous hint. Setting __GL_SINGLE_THREADED to 1 as described above, before running GameX will fix the problem.

However, I DO NOT get this message, just the above skipping sound and then darkness.

WARNING: Your system is running with a buggy dynamic loader.
This may cause crashes in certain applications. If you
experience crashes you can try setting the environment
variable __GL_SINGLE_THREADED to 1. For more information
please consult the FREQUENTLY ASKED QUESTIONS section in
the file /usr/share/doc/NVIDIA_GLX-1.0/README.

If anyone has any ideas on anything to check or what to put somewhere, please let me know. Also, where does the __GL_SINGLE_THREADED option exists? What file? Where?

Any and all information is appreciated. Primarily I am concerned with the freezing in full screen modes. However, I am just as concerned that my file above is totally correct and nothing seems outta place, wrong or not running as it seems it should be.

Kind regards,
redfrog
redfrog is offline   Reply With Quote
Old 05-03-04, 09:55 AM   #2
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: A few Questions Need Answering Please.

__GL_SINGLE_THREADED is an environment variable which you can put for example in your .bashrc or another file you like. As far as I know it mainly exists to work around bugs in some old distros.

Likely there's some glibc related problem for example related to nptl.
Thunderbird is offline   Reply With Quote
Old 05-03-04, 11:17 AM   #3
redfrog
ArkLinux Beta Tester
 
Join Date: May 2004
Posts: 4
Default Re: A few Questions Need Answering Please.

Please check the log file I posted.. Please let me know if the warnings are a problem and your comments on it.

Kind regards,
redfrog
redfrog is offline   Reply With Quote
Old 05-03-04, 11:34 AM   #4
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: A few Questions Need Answering Please.

The log file is mainly for configuring X it doesn't have much to do with OpenGL stuff.
Thunderbird is offline   Reply With Quote
Old 05-03-04, 12:23 PM   #5
redfrog
ArkLinux Beta Tester
 
Join Date: May 2004
Posts: 4
Default Re: A few Questions Need Answering Please.

Understood, but there are some errors and it does indicate the entire nvidia process. I just want to make sure that it looks ok, and that it is loading the way it should be. I noticed some warnings in there cause my latop is 1600x1200 and I have to manually change the DisplaySize to keep my fonts at 75pixels x 75. Is that warning something that has an alternate solution.. yada..

I just want to make sure that you professionals do not see anything that stands out, that has a fix.

Kind regards,
redfrog
redfrog is offline   Reply With Quote
Old 05-03-04, 01:07 PM   #6
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: A few Questions Need Answering Please.

I guess you mean errors like this:
(II) NVIDIA(0): Not using default mode "320x200" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "720x400" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "360x200" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "640x480" (vrefresh out of range)

You can ignore those, the drivers just validate all builtin xfree86 modelines and like to print out lines like that. Further I don't know much about DPI but thought there were some settings to adjust it.
Thunderbird is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Arma 3 E3 hands-on preview: 8 important questions answered News Archived News Items 0 06-08-12 06:20 AM
AMD Counter-Attacks GeForce GTX 670, Questions NVIDIA's Kepler Availability (BSN) News GeForce GTX 670 Reviews 1 05-11-12 12:54 AM
Questions about Mafia cricket Gaming Central 16 10-05-02 09:44 AM
FastM, AdrianHall, Questions About Leadtek TV 2000 Essense General Hardware 3 09-30-02 12:15 AM
FSAA Questions LaoTzuTao NVIDIA Linux 16 09-11-02 01:55 PM

All times are GMT -5. The time now is 02:20 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.