Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-14-04, 09:03 AM   #1
Heroux
Registered User
 
Join Date: May 2004
Posts: 1
Default Can't find an IRQ for your NVIDIA card!

When I try to install the kernel module nvidia I get the following errors:
====
Code:
#insmod nvidia
Using /lib/modules/2.4.20-30.9/kernel/drivers/video/nvidia.o
Warning: loading /lib/modules/2.4.20-30.9/kernel/drivers/video/nvidia.o will taint the kernel: non-GPL license - NVIDIA
See export-tainted for information about tainted modules
0: nvidia :Can't find an IRQ for your NVIDIA card!
0: nvidia :Please check your bios settings.
0: nvidia :[Plug & Play OS] should be set to NO
0: nvidia :[Assign IRQ to VGA] should be set to YES
Loading NVIDIA Linux X86 NVIDIA Kernel Module 1.8-5336 Wed Jan 14 18:29:26 PST 2884
Module nvidia loaded, with warnings
I am trying to install a GeForce4 MX440:
====
Code:
#lspci
00:00.0 Host bridge: ALi Corporation M1541 (rev 04)
00:01.0 PCI bridge: ALi Corporation M1541 PCI to AGP Controller (rev 04)
00:04.0 Multimedia audio controller: ESS Technology ES1968 Maestro 2
00:06.0 Ethernet controller: Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE] (rev 44)
00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV] (rev c3)
00:08.0 VGA compatible controller: Chips and Technologies F69000 HiQVideo (rev 64)
00:0f.0 IDE interface: ALi Corporation M5229 IDE (rev c1)
00:13.0 Communication controller: FarSite Communications Ltd FarSync T2P (2 port X.21/V.35/V.24) (rev 02)
00:14.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 440] (rev a3)
The device ID output by lspci -vn is as follows 10de:0171:
====
Code:
#lspci -vn
00:00.0 Class 0600: 10b9:1541 (rev 04)
	Subsystem: 10b9:1541
	Flags: bus master, slow devsel, latency 64
	Memory at d0000000 (32-bit, non-prefetchable) [size=64M]
	Capabilities: [b0] AGP version 1.0

00:01.0 Class 0604: 10b9:5243 (rev 04)
	Flags: bus master, slow devsel, latency 64
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
	I/O behind bridge: 0000c000-0000cfff
	Memory behind bridge: cba00000-cbafffff
	Prefetchable memory behind bridge: bb700000-bb7fffff

00:04.0 Class 0401: 125d:1968
	Subsystem: 125d:0001
	Flags: bus master, medium devsel, latency 64, IRQ 11
	I/O ports at de00 [size=256]
	Capabilities: [c0] Power Management version 1

00:06.0 Class 0200: 1022:2000 (rev 44)
	Subsystem: 1022:2000
	Flags: bus master, medium devsel, latency 64, IRQ 10
	I/O ports at dd80 [size=32]
	Memory at eefdffe0 (32-bit, non-prefetchable) [size=32]
	Expansion ROM at eee00000 [disabled] [size=1M]
	Capabilities: [40] Power Management version 2

00:07.0 Class 0601: 10b9:1533 (rev c3)
	Subsystem: 10b9:1533
	Flags: bus master, medium devsel, latency 0

00:08.0 Class 0300: 102c:00c0 (rev 64)
	Subsystem: 102c:00c0
	Flags: stepping, medium devsel
	Memory at 10000000 (32-bit, non-prefetchable) [disabled] [size=16M]
	Expansion ROM at fffc0000 [disabled] [size=256K]

00:0f.0 Class 0101: 10b9:5229 (rev c1) (prog-if fa)
	Flags: bus master, medium devsel, latency 32
	I/O ports at ffa0 [size=16]

00:13.0 Class 0780: 1619:0400 (rev 02)
	Flags: medium devsel, IRQ 9
	Memory at eefdff00 (32-bit, non-prefetchable) [size=128]
	I/O ports at dc00 [size=128]
	Memory at eed00000 (32-bit, non-prefetchable) [size=1M]
	Memory at eefdffd0 (32-bit, non-prefetchable) [size=16]
	I/O ports at da00 [size=256]
	Expansion ROM at 0efc0000 [disabled] [size=64K]

00:14.0 Class 0300: 10de:0171 (rev a3)
	Flags: bus master, 66Mhz, medium devsel, latency 64
	Memory at ef000000 (32-bit, non-prefetchable) [size=16M]
	Memory at c0000000 (32-bit, prefetchable) [size=128M]
	Memory at cb980000 (32-bit, prefetchable) [size=512K]
	Expansion ROM at eefe0000 [disabled] [size=128K]
	Capabilities: [60] Power Management version 2
The README says that Decide ID 0171 is supported:
====
Code:
__________________________________________________________________________

(app-a) APPENDIX A: SUPPORTED NVIDIA GRAPHICS CHIPS
__________________________________________________________________________

  NVIDIA CHIP NAME                     DEVICE PCI ID

  RIVA TNT                             0x0020
  RIVA TNT2/TNT2 Pro                   0x0028
  Vanta/Vanta LT                       0x002C
  RIVA TNT2 Ultra                      0x0029
  RIVA TNT2 Model 64/Model 64 Pro      0x002D
  Aladdin TNT2                         0x00A0
  GeForce 256                          0x0100
  GeForce DDR                          0x0101
  Quadro                               0x0103
  GeForce2 MX/MX 400                   0x0110
  GeForce2 MX 100/200                  0x0111
  Quadro2 MXR/EX/Go                    0x0113
  GeForce2 Integrated GPU              0x01A0
  GeForce2 GTS/GeForce2 Pro            0x0150
  GeForce2 Ti                          0x0151
  GeForce2 Ultra                       0x0152
  Quadro2 Pro                          0x0153
  GeForce4 MX 460                      0x0170
  GeForce4 MX 440                      0x0171
  GeForce4 MX 420                      0x0172
  GeForce4 MX 440-SE                   0x0173
  Quadro4 550 XGL                      0x0178
  Quadro NVS                           0x017A
  GeForce4 MX 440 with AGP8X           0x0181
  GeForce4 MX 440SE with AGP8X         0x0182
  GeForce4 MX 420 with AGP8X           0x0183
  GeForce4 MX 4000                     0x0185
  Quadro4 580 XGL                      0x0188
  Quadro NVS with AGP8X                0x018A
  Quadro4 380 XGL                      0x018B
  GeForce4 MX Integrated GPU           0x01F0
  GeForce3                             0x0200
  GeForce3 Ti 200                      0x0201
  GeForce3 Ti 500                      0x0202
  Quadro DCC                           0x0203
  GeForce4 Ti 4600                     0x0250
  GeForce4 Ti 4400                     0x0251
  GeForce4 Ti 4200                     0x0253
  Quadro4 900 XGL                      0x0258
  Quadro4 750 XGL                      0x0259
  Quadro4 700 XGL                      0x025B
  GeForce4 Ti 4800                     0x0280
  GeForce4 Ti 4200 with AGP8X          0x0281
  GeForce4 Ti 4800 SE                  0x0282
  Quadro4 980 XGL                      0x0288
  Quadro4 780 XGL                      0x0289
  GeForce FX 5800 Ultra                0x0301
  GeForce FX 5800                      0x0302
  Quadro FX 2000                       0x0308
  Quadro FX 1000                       0x0309
  GeForce FX 5600 Ultra                0x0311
  GeForce FX 5600                      0x0312
  GeForce FX 5600XT                    0x0314
  GeForce FX 5200                      0x0320
  GeForce FX 5200 Ultra                0x0321
  GeForce FX 5200                      0x0322
  GeForce FX 5200SE                    0x0323
  Quadro NVS 280 PCI                   0x032A
  Quadro FX 500                        0x032B
  GeForce FX 5900 Ultra                0x0330
  GeForce FX 5900                      0x0331
  GeForce FX 5900XT                    0x0332
  GeForce FX 5950 Ultra                0x0333
  Quadro FX 3000                       0x0338
  GeForce FX 5700 Ultra                0x0341
  GeForce FX 5700                      0x0342
  Quadro FX 1100                       0x034E
  GeForce2 Go                          0x0112
  GeForce4 440 Go                      0x0174
  GeForce FX Go5600                    0x031A
  GeForce FX Go5650                    0x031B
  Quadro FX Go700                      0x031C
  GeForce FX Go5200                    0x0324
  GeForce FX Go5250                    0x0325
  GeForce FX Go5200 32M/64M            0x0328
  GeForce FX Go5300                    0x032C
  GeForce FX Go5100                    0x032D
  GeForce FX Go5700                    0x0348
As indicated when I ran insmod the card appears to not have an IRQ:
====
Code:
#cat /proc/driver/nvidia/cards/0
Model: GeForce4 MX 440
IRQ: 0
Video BIOS: ??.??.??.??.??
Card Type: PCI
Code:
#cat /proc/driver/nvidia/version
NVRM version: NVIDIA Linux x86 NVIDIA Kernel Module 1.0-5336 Wed Jan 14 18:29:26 PST 2004
GCC version: gcc version 3.2.2 20030222 (Red Hat Linux 3.2.2-5)
Code:
#more /proc/interrupts
CPU0 
0: 264508 XT-PIC timer
1: 1377 XT-PIC keyboard
2: 0 XT-PIC cascade
8: 1 XT-PIC rtc
10: 3989 XT-PIC PCnet/FAST III 79C973
12: 20 XT-PIC PS/2 Mouse
14: 4135 XT-PIC ide0
15: 0 XT-PIC ide1
NMI: 0 
ERR: 0
Code:
#ls /dev/nvidia*
/dev/nvidia0
/dev/nvidia1
/dev/nvidia2
/dev/nvidia3
/dev/nvidia4
/dev/nvidia5
/dev/nvidia6
/dev/nvidia7
/dev/nvidiactl
It says "Assign IRQ to VGA] should be set to YES" but I have custom BIOS and the only options I have under PNP/PCI Configuration are:
Clear NVRam :No or/ Yes
PCI Latency Timer : 64 or/ 32
PCI IDE BusMaster: Enabled or/ Disabled
PCI Slot1 Priority: Auto
PCI Slot2 Priority: Auto
PCI Slot3 Priority: Auto
PCI Slot4 Priority: Auto
IRQ3: PCI/PnP or/ ISA/EISA
IRQ4: PCI/PnP or/ ISA/EISA
IRQ5: PCI/PnP or/ ISA/EISA
IRQ7: PCI/PnP or/ ISA/EISA
IRQ9: PCI/PnP or/ ISA/EISA
IRQ10: PCI/PnP or/ ISA/EISA
IRQ11: PCI/PnP or/ ISA/EISA
IRQ12: PCI/PnP or/ ISA/EISA
IRQ14: PCI/PnP or/ ISA/EISA
IRQ15: PCI/PnP or/ ISA/EISA

The module is loaded but appears to be unused:
====
Code:
#lsmod
Module Size Used by Tainted: P 
nvidia 2124480 0 (unused)
smbfs 39792 1 (autoclean)
parport_pc 17508 2 (autoclean)
lp 8580 0 (autoclean)
parport 33952 2 (autoclean) [parport_pc lp]
autofs 12148 0 (autoclean) (unused)
pcnet32 16608 1 
mii 3720 0 [pcnet32]
ipt_REJECT 3736 6 (autoclean)
iptable_filter 2316 1 (autoclean)
ip_tables 14488 2 [ipt_REJECT iptable_filter]
ext3 64736 2 
jbd 47860 2 [ext3]
I ran the installer successfully using the following command:
====

Code:
#sh NVIDIA-Linux-x86-1.0-5336-pkg1.run --kernel-name=2.4.20-30.9

I am running RH 9:
====
Code:
#cat /etc/issue
Red Hat Linux release 9 (Shrike)
Kernel \r on an \m
Code:
#uname -r
2.4.20-30.9
Code:
#cat /etc/redhat-release
Red Hat Linux release 9 (Shrike)
Code:
#cat /proc/version
Linux version 2.4.20-30.9 (bhcompile@daffy.perf.redhat.com) (gcc version 3.2.2 20030222 (Red Hat Linux 3.2.2-5)) #1 Wed Feb 4 20:45:57 EST 2004
Code:
#rpm -q kernel kernel-source
kernel-2.4.20-8
kernel-2.4.20-30.9
kernel-source-2.4.20-30.9
Code:
#rpm -qa | grep kernel
kernel-pcmcia-cs-3.1.31-13
kernel-2.4.20-8
kernel-source-2.4.20-30.9
kernel-2.4.20-30.9
Obviously, when I try to startx it fails:
====
Code:
...
NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(EE) Screen(s) found, but none have a usable configuration.
Fatal server error:
no screens found
Please find attached Xserver log file (XFree86.0.log), X Server Config file (XF86Config), Kernel log file (messages), and the configuration file for loading kernel modules (modules.conf):

At this point I suspect my problem might be that because I have a custom BIOS it may not have the options required to install this card?

Thank you in advance for your assistance.

Regards,
Philippe
Attached Files
File Type: txt XF86Config.txt (3.3 KB, 166 views)
File Type: txt dmesg.txt (4.5 KB, 183 views)
File Type: txt modules.conf.txt (276 Bytes, 167 views)
File Type: txt XFree86.0.log.txt (15.6 KB, 169 views)

Last edited by Heroux; 05-14-04 at 10:35 AM.
Heroux is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Unleashes the GeForce GTX 670 Graphics Card ' Performance Perfected (WCCFTECH) News GeForce GTX 670 Reviews 0 05-10-12 08:40 AM
Rumor regarding lack of 680 availability ViN86 Rumor Mill 6 05-09-12 04:48 PM
Error! Linux cannot find my nVidia integrated sound card! Please help! targatop NVIDIA Linux 1 09-08-02 04:55 PM
NVIDIA could rule if they really wanted to Vid_craze NVIDIA GeForce 7, 8, And 9 Series 25 08-16-02 05:24 PM

All times are GMT -5. The time now is 02:58 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.