Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-06-03, 10:30 PM   #1
snaboofypop
Registered User
 
Join Date: Aug 2003
Posts: 29
Default Blurry Twinview/DVI

Hi. I am getting a blurry/fuzzy display from the DVI connected monitor on my TI4200. I am running RH9 with kernel 2.6.0-test9-bk25 (although I remember this problem happening with 2.4.x series kernels also). The resolution seems to be ok, and colors come ok, but everything on the DVI connected monitor appears slightly smeared. If I switch monitors, the previously clear vga monitor becomes fuzzy, and the previously fuzzy DVI connected monitor becomes clear (the problem always stays with the DVI connection). I have already tried different dvi to vga adaptors (neither of my monitors accepts direct dvi, so I use a dvi to vga adaptor). Accelerated video, GLX, Full screen TV (v4l extensions) all work fine, except on the DVI connected side, they appear fuzzy (and DVI is slightly slower..on the VGA side gears runs at 3053 FPS consistently, on the DVI side it runs at 2968). My current resolution (both monitors) is 1024x768.
My current driver version is 4496 (with 2.6.x extensions), but I recall the problems happening with 2.4.x kernels and native nvidia drivers also.
cat /proc/driver/nvidia/agp/* gives:
Fast Writes: Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000217:0x1f000104
Host Bridge: Silicon Integrated S SiS645 Host & Memory
Fast Writes: Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000217:0x00000104
Status: Enabled
Driver: NVIDIA
AGP Rate: 4x
Fast Writes: Disabled
SBA: Disabled
cat /proc/driver/nvidia/version gives:
NVRM version: NVIDIA Linux x86 nvidia.o Kernel Module 1.0-4496 Wed Jul 16 19:03:09 PDT 2003
GCC version: gcc version 3.2.2 20030222 (Red Hat Linux 3.2.2-5)
cat /proc/driver/nvidia/cards/* gives:
Model: GeForce4 Ti 4200
IRQ: 10
Video BIOS: 04.25.00.30.00
Card Type: AGP
My motherboard is a Soyo P4S Dragon Ultra c/w intel P4@1800 and 1GB of PC2700.

I have checked the screen horizontal/vertical resolution. For completeness, I will attach /var/log/XFree86.0.log and XF86Config

Is there a way to un-fuzz the DVI?


XF86Config:

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Multi Head"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
Screen 1 "Screen1" LeftOf "Screen0"
# LeftOf can also be RightOf, Above, Below
EndSection

Section "Files"

# The location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"

# Removed for Nvidia
# Load "GLcore"
# 2 removed for NVidia
# Load "dri"

Load "dbe"
Load "extmod"
# for better tv
Load "v4l"
Load "fbdevhw"
# Load "pex5"
Load "glx"
# Load "pex5"
Load "record"
# Load "xie"
EndSection

Section "InputDevice"

# Option "AutoRepeat" "500 5"
# when using XQUEUE, comment out the above line, and uncomment the
# following line
# Option "Protocol" "Xqueue"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:nocaps"
#Option "XkbOptions" ""
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
#Option "XkbVariant" ""
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Buttons" "3"
Option "Resolution" "250"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
DisplaySize 338 270
HorizSync 30.0 - 70.0
VertRefresh 56.0 - 76.0
ModeLine "1400x1050" 129.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
ModeLine "1400x1050" 151.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
ModeLine "1400x1050" 162.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
ModeLine "1400x1050" 184.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
Option "dpms"
# -- 1400x1050 --
# 1400x1050 @ 60Hz, 65.8 kHz hsync
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor1"
ModelName "Monitor Model1"
DisplaySize 338 270
HorizSync 30.0 - 70.0
VertRefresh 56.0 - 76.0
ModeLine "1400x1050" 129.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
ModeLine "1400x1050" 151.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
ModeLine "1400x1050" 162.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
ModeLine "1400x1050" 184.0 1400 1464 1656 1960 1050 1051 1054 1100 +hsync +vsync
Option "dpms"
# -- 1400x1050 --
# 1400x1050 @ 60Hz, 65.8 kHz hsync
EndSection

Section "Device"

# no known options
#BusID
Identifier "NVIDIA GeForce DDR (generic)"
Driver "nvidia"
Option "TwinView"
Option "SecondMonitorHorizSync" "30-81"
Option "SecondMonitorVertRefresh" "56-76"
Option "TwinViewOrientation" "LeftOf"
Option "MetaModes" "1024x768,1024x768"
Option "ConnectedMonitor" "crt,crt"
Option "NoLogo" "true"
Option "RenderAccel" "true"
Option "WindowFlip" "true"
VendorName "NVIDIA GeForce DDR (generic)"
BoardName "NVIDIA GeForce DDR (generic)"
BusID "AGP:1:0:0"

# Subsection "Display"
# Depth 24
# Virtual 2048 768
# EndSubsection
EndSection

Section "Screen"

# NvAgp 0 disables graphics AGP
# NvAgp 1 NvAgp (windoze based but runs on Linux)
# NvAgp 2 AGPGART (linux based - runs best on SiS chipsets)
# Option "NvAgp" "2"
# to enable fast writes pass NVreg_EnableAGPFW=0 to NVdriver (not here),
# use insmod NVdriver NVreg_EnableAGPFW=1
# or edit /etc/modules.conf with
# alias char-major-195 NVdriver
# options NVdriver NVreg_EnableAGPFW=1
# (or set it to 0 to force it off if it's unstable)
Identifier "Screen0"
Device "NVIDIA GeForce DDR (generic)"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 8
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "640x480" "800x600" "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
# NvAgp 0 disables graphics AGP
# NvAgp 1 NvAgp (windoze based but runs on Linux)
# NvAgp 2 AGPGART (linux based - runs best on SiS chipsets)
# Option "NvAgp" "2"
# to enable fast writes pass NVreg_EnableAGPFW=0 to NVdriver (not here),
# use insmod NVdriver NVreg_EnableAGPFW=1
# or edit /etc/modules.conf with
# alias char-major-195 NVdriver
# options NVdriver NVreg_EnableAGPFW=1
# (or set it to 0 to force it off if it's unstable)
Identifier "Screen1"
Device "NVIDIA GeForce DDR (generic)"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Depth 8
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "640x480" "800x600" "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection
snaboofypop is offline   Reply With Quote
Old 05-19-04, 06:52 PM   #2
oldkawman
Registered User
 
Join Date: Feb 2004
Posts: 12
Default Re: Blurry Twinview/DVI

I have a similar problem, I have 2 vid cards with both vga and dvi outputs, FX5200 and GF4 4200Ti, and always with either and on any of my monitors running in twinview or not, the monitor plugged into the dvi output goes blurry, even when not in X, The problem always follows the DVI output. 3 different monitors, Sony G520, NEC E1100, Viewsonic P225, either card. All previous NV driver versions as well as current, with both RH8 and RH9. I switched back to my old GF4 mx440 dual vga card and all is well. Must be a driver bug. I keep trying the new drivers when they are reliesed, but no luck as yet.
oldkawman is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
7100 GS blurry fonts gebra NVIDIA GeForce 7, 8, And 9 Series 3 05-02-12 01:06 PM

All times are GMT -5. The time now is 09:10 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.