Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-09-04, 03:21 PM   #1
khalid357
Registered User
 
Join Date: May 2004
Posts: 13
Smile editing XF86Config. in suse linux for nvidia driver

i dont have a clue as to how i am supposed to edit the file XF86config. for the use of the nvidia driver for suse linux 9.0. is there some one who can give me a step by step on how to do so.

thanks in advance
khalid357
khalid357 is offline   Reply With Quote
Old 05-09-04, 03:28 PM   #2
coroner
Registered User
 
Join Date: Feb 2004
Posts: 17
Default Re: editing XF86Config. in suse linux for nvidia driver

on suse you shouldn't edit the config file by hand, since it will be destroyed by all the crappy config-scripts and yast and stuff anyways. you should install the nvidia-driver package, which is brought to you by suse... search for it in yast maybe, i dont have much of a clue about suse, anyways i know that it's never a good idea to edit config-files by hand in suse...
coroner is offline   Reply With Quote
Old 05-09-04, 04:00 PM   #3
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: editing XF86Config. in suse linux for nvidia driver

Otherwise you have a step-by-step description ready in the README shipped with the driver package, or at ftp://download.nvidia.com/XFree86/Li....0-5336/README (assuming you use this driver). Editing your XF86Config by hand should be possible even with SUSE's weird notion of easy configuration. ;-)
hppnq is offline   Reply With Quote
Old 05-09-04, 04:37 PM   #4
khalid357
Registered User
 
Join Date: May 2004
Posts: 13
Question Re: editing XF86Config. in suse linux for nvidia driver

looking at the readme file is somewhat confusing to me concerneing what i am supposed to be entering into it for configuration so i have taken the liberty of typing in the conole as root this command : edit XF86Config. which gave me this output


generic XFree86 4.x configuration file

Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/truetype/"
FontPath "/usr/X11R6/lib/X11/fonts/URW/"
FontPath "/usr/X11R6/lib/X11/fonts/uni/"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
ModulePath "/usr/X11R6/lib/modules"
RgbPath "/usr/X11R6/lib/X11/rgb"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
"/etc/X11/XF86Config" [readonly] 183L, 4174C 1,1 Top


i also checked the log file to see what version of the config file that is being used by my system entering the same command with the log file i recieved this output

This is a pre-release version of XFree86, and is not supported in any
way. Bugs may be reported to XFree86@XFree86.Org and patches submitted
to fixes@XFree86.Org. Before reporting bugs in pre-release versions,
please check the latest version in the XFree86 CVS repository
(http://www.XFree86.Org/cvs).

XFree86 Version 4.3.0.1
Release Date: 9 May 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: SuSE Linux [ELF] SuSE
Build Date: 12 February 2004
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Sun May 9 12:46:12 2004
(==) Using config file: "/etc/X11/XF86Config"
(==) ServerLayout "Layout[all]"
(**) |-->Screen "Screen[fbdev]" (0)
(**) | |-->Monitor "Monitor[0]"
"/var/log/XFree86.0.log" 450L, 21674C

my reason for this output is the version of my program which is displayed above.

the readme doesnot tell me how to edit these files to make x server use the drivers that i installed being 1.0 5336. can someone baby step me through how to achieve this with the above information displayed
thanks for the patience
khalid357
khalid357 is offline   Reply With Quote
Old 05-10-04, 02:26 AM   #5
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: editing XF86Config. in suse linux for nvidia driver

Not to worry, it's not that hard.

You should try to configure X with yast or yast2 first. I don't know what it looks like nowadays, but after typing 'yast' on a prompt, you should get some menu through which you can navigate with your cursor keys. Probably one of the options is to configure your display. If 'yast' doesn't work, try 'yast2'.

Otherwise, you can try to use the sax2 command, like this:

# sax2 -m 0=nvidia

This will destroy your existing configuration and create a new one, so copy your XF86Config if you want to keep it as a backup.

If that still didn't work, you will have to edit your XF86Config by hand. To do this, you have several editors at your disposal. The easiest one that I know is 'pico', which behaves exactly like you would expect. However, it might not be installed. (You can check this easily of course by typing 'pico' at the prompt.) So I'm going to give you a crash course in vi.

If you got here, make a backup of your XF86Config in any case. If something goes wrong, you can always restore and try again.

Do the following (as root):

# cd /etc/X11
# cp XF86Config XF86Config.orig
# vi XF86Config

You will now see the first page of the file. If you get an error about vi being missing, install it from the SUSE cds, it should be there.

In vi, you can navigate with the cursor keys. Scroll down until you see a line that says

Driver "nv"

Maybe instead of "nv" it says something else, like "vga". Whatever it says,
move your cursor to the first letter of the driver name -- in this case, the 'n' of "nv". Type exactly this: cw (the two letters c and w) and you should see the driver name disappear, and a line should appear at the bottom of the screen that says "Insert".

Now, type: nvidia, so that the line now reads

Driver "nvidia"

Press escape, so the line "Insert" at the bottom of the screen disappears. We have now told X to use the nvidia driver. Next, we have to remove some things from the configuration file.

Scrolling around (start with going up, it's probably there), try to locate the lines that start with "Load". If they are present, remove the two lines that go

Load "dri"
Load "GLcore"

You do this by moving the cursor to the first of these two lines and then typing "dd". The line should disappear. Move the cursor to the other one, if necessary, and remove that one by again typing "dd".

Now, check whether there is a line that says

Load "glx"

If it's not there, you have to add it. Move to one of the lines that start with "Load" and press 'o'. You should see a new empty line appear, with the cursor at the beginning. Type the line above (Load "glx") and press Escape when you're done.

You have now finished editing, so it's time to save and quit. Type ':' (single colon). You should see the cursor move to the bottom of the screen, and there should be a colon there. Now, type "wq" (the letters w and q) and Enter.

The file should now have been saved, so you're done.

If anything goes wrong while you're doing this, you can quit by typing the colon ":" and then "q!" (the letter q and an exclamation mark). You will then exit without saving.

vi comes with a tutorial and plenty of help to get you going. If you just type 'vi' you have easy access to both. Also, try the web for more information about configuring nvidia on SUSE -- there is a lot of information out there with the exact information you need.

Good luck!
hppnq is offline   Reply With Quote
Old 05-20-04, 03:40 PM   #6
RTFM
Registered User
 
Join Date: May 2004
Posts: 1
Default Re: editing XF86Config. in suse linux for nvidia driver

Just wanted to say: hppnq you are a god! I've been looking for a resolve for this issue for a week and a half and just found this post tonight. The "sax2 -m 0=nvidia" command resolved it.

To think it was that easy!
RTFM is offline   Reply With Quote
Old 05-20-04, 04:07 PM   #7
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default Re: editing XF86Config. in suse linux for nvidia driver

Quote:
Originally Posted by RTFM
Just wanted to say: hppnq you are a god! I've been looking for a resolve for this issue for a week and a half and just found this post tonight. The "sax2 -m 0=nvidia" command resolved it.

To think it was that easy!
it's in the SuSE readme on there site, and it's always been that easy.
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
173.14.35 Linux Driver annb NVIDIA Legacy Graphics Cards 0 06-13-12 06:46 PM
Best Linux driver for Quadro FX2700M dclement NVIDIA Linux 0 05-07-12 06:58 AM
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 09:55 AM
Trouble with SuSE 8 & NVIDIA latest driver bughill NVIDIA Linux 3 08-20-02 12:31 PM
download problem with linux NVIDIA driver packages Timo NVIDIA Linux 7 07-31-02 09:22 AM

All times are GMT -5. The time now is 06:07 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.