Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-20-04, 10:10 AM   #13
gilboa
Linux addict...
 
Join Date: Jan 2004
Posts: 540
Default Re: Fedora Core 2 - lockup problems

Your X fonts server (xfs) seems to be down.
Try /etc/init.d/xfs restart (as root)
gilboa is offline   Reply With Quote
Old 05-20-04, 11:24 AM   #14
oyvind
Registered User
 
Join Date: May 2004
Location: Norway
Posts: 117
Default Re: Fedora Core 2 - lockup problems

Quote:
Originally Posted by ogetbilo
So I opened the xorg.conf and commented out the line

FontPath ¨unix/:7100¨


and now it works.


Is it OK to comment out that line?
Yes, put the fontpaths present in `/etc/X11/fs/config' into `xorg.conf' (with `FontPath' before each element) and don't ever turn on that silly XFS thingy again =)

After you get X working without the "unix/:7100" fontpath, you can completely disable XFS like this (as root):
/etc/init.d/xfs stop && chkconfig --level 2345 xfs off

Note, however, that installation of RPM packages which include new fonts will perhaps add paths into `/etc/X11/fs/config', since this is what Fedora intended. In this case, you have to manually add the new paths to xorg.conf, also.
oyvind is offline   Reply With Quote
Old 05-20-04, 07:14 PM   #15
ogetbilo
Registered User
 
Join Date: May 2004
Posts: 52
Default Re: Fedora Core 2 - lockup problems

Quote:
Originally Posted by oyvind
Yes, put the fontpaths present in `/etc/X11/fs/config' into `xorg.conf' (with `FontPath' before each element) and don't ever turn on that silly XFS thingy again =)

After you get X working without the "unix/:7100" fontpath, you can completely disable XFS like this (as root):
/etc/init.d/xfs stop && chkconfig --level 2345 xfs off

Note, however, that installation of RPM packages which include new fonts will perhaps add paths into `/etc/X11/fs/config', since this is what Fedora intended. In this case, you have to manually add the new paths to xorg.conf, also.
ok i will do that but

can you explain why i should do that?
my X is working fine (at least it seems to be working fine) right now with that "unix/:7100" commented out.

I wonder what that line actuaaly does (and those lines you told me to add to xorg.conf).
ogetbilo is offline   Reply With Quote
Old 05-20-04, 08:29 PM   #16
m1oluf
Registered User
 
Join Date: May 2004
Posts: 5
Default Re: Fedora Core 2 - lockup problems

the 2.6.6 kernel worked for me, and it works great as long as i'm root.


the driver is 5336
the /dev/nv* files are all 0666 permissions.
the dri in /etc/security/console.perms are 0666

what should i look for when games are flickering as an logged in user?
m1oluf is offline   Reply With Quote
Old 05-21-04, 08:25 AM   #17
oyvind
Registered User
 
Join Date: May 2004
Location: Norway
Posts: 117
Default Re: Fedora Core 2 - lockup problems

Drifting slightly off topic now, but anyway:

First of all: if things are working fine and you're not annoyed by any problems, you could always say "If it ain't broke, don't fix it" .

XFS is, IMO, an archaic thing of old times, no longer necessary for X fonts. But if you want to, by all means, use it, you will probably not notice any difference. Either start up XFS (and check it's config) and uncomment the "unix/:7100" fontpath, or just leave it out, and put your systems font locations directly into xorg.conf.

The line tells the X server that it should look for fonts from a font server running at unix socket port 7100 (which is XFS). If that server isn't running, or not configured properly, X will probably fail. But since X also can look for fonts from directories in your system (look in /etc/X11/fs/config), you could simply just put in these instead, like I suggested earlier.

Many of todays modern X apps use the XFT/fontconfig solution (client side fonts), for example all KDE3/GNOME/GTK2 apps will use this. It's easy to identify: The XFT/fontconfig enabled clients' fonts are usually rendered with anti-aliasing (default), and have sane human readable names, like `Monospace 9', instead of `-monotype-courier new-bold-r-*-*-*-*-*-*-*-*-*-*'. The point is that this solution is not dependent(AFAIK) upon the old X-server provided fonts (which are configured in xorg.conf). They will therefore pay no attention to missing fonts there. But still, I find it weird your X server starts without XFS and no fontpaths configured in xorg.conf at all, perhaps the location of the "Fixed" font (necessary for X to run at all) is hardcoded into the server, for "emergencies". Check `/var/log/Xorg.0.log' for possible answers.

Hey, isn't this a nVIDIA driver forum, time to stop writing now=).
oyvind is offline   Reply With Quote
Old 05-23-04, 09:13 AM   #18
grash
Registered User
 
Join Date: May 2004
Posts: 1
Default Re: Fedora Core 2 - lockup problems

Quote:
Originally Posted by LordMorgul
This is ultimately an nVIDIA problem, and presumably will be fixed soon.
Sorry, you are wrong. This is a Fedora/RedHat issue. The 5336 drivers work on Debian and SuSE and any stock 2.6 kenel. Whether or not NVIDIA should open source their drivers is certainly open for debate, but do not try to pin this one on NVIDIA. It's Fedora/RedHat that modified the kernel source to suit their needs thus breaking the NVIDIA driver. If NVIDIA modifies their driver to work with Fedora/RedHat then good for them.
grash is offline   Reply With Quote
Old 05-23-04, 09:17 AM   #19
gilboa
Linux addict...
 
Join Date: Jan 2004
Posts: 540
Default Re: Fedora Core 2 - lockup problems

Actually, FC2 uses the now default (will be default in 2.6.7) 4K stacks option that kills the nVidia drivers.

The current nVidia drivers will not work on any 2.6 distro that uses a kernel above 2.6.6.
Even worse, the 8K option will be completely *removed* in future kernels.

Cheers,
gilboa is offline   Reply With Quote
Old 05-23-04, 04:30 PM   #20
Gnubox
Registered User
 
Join Date: May 2004
Posts: 1
Default Re: Fedora Core 2 - lockup problems

Quote:
Originally Posted by Omnifarious
Ask, and you shall recieve. Here is the .config file I used for my 2.6.6. Keep in mind that I disabled a few things I knew I would never use. I'm guessing hardly anybody with a desktop system will use them, but they include things like PCMCIA.
This config works fine, many thanks. I can now use my laptop with Fedora Core 2.
Just a little question : with this config, I lost the pretty boot screen of the Fedora (with the progress bar). How could I retreive it ?

Many thanks

Pierre
Gnubox is offline   Reply With Quote

Old 05-23-04, 08:16 PM   #21
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default Re: Fedora Core 2 - lockup problems

Quote:
Originally Posted by grash
Quote:
Originally Posted by LordMorgul
This is ultimately an nVIDIA problem, and presumably will be fixed soon.
Sorry, you are wrong. This is a Fedora/RedHat issue. The 5336 drivers work on Debian and SuSE and any stock 2.6 kenel. Whether or not NVIDIA should open source their drivers is certainly open for debate, but do not try to pin this one on NVIDIA. It's Fedora/RedHat that modified the kernel source to suit their needs thus breaking the NVIDIA driver. If NVIDIA modifies their driver to work with Fedora/RedHat then good for them.
No I am not.. your point is valid for now only but not for the near future. I did not say that nVIDIA caused the problem, but it is nevertheless a problem that nVIDIA should.. and only nVIDIA can.. fix -> an nVIDIA problem. I did not in any way blame nVIDIA for the problem's existence or for the 'late' timing of a fix, I am just pointing out that Fedora did not create the problem itself.. the mainline kernel did / is / will be.

Red Hat developers chose to use Fedora Core 2 as a cutting-edge platform to push this stock Linux kernel change forward, they did not develop anything specific to Fedora in that regard.. the change is in the stock kernel source and approved by the mainline kernel developers for the near future as a permanent change. Might they change their minds and not make the change? Sure, they might, but at present that does not look likely.

The other distros you mention work now because they decided not to enable the option which is slated for change as a default... it is to their benefit now, perhaps, but it will be Fedora's support of this change that helps to mainstream it. If noone accepts and tests/uses the technology changes made in the stock kernel they remain unusable... that will not be the case for 4K Stack frames and Register Parameters.
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.

Last edited by LordMorgul; 05-23-04 at 08:22 PM. Reason: full quote included
LordMorgul is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
i3 one core runs hotter than the other muelo1000 CPUs, Motherboards And Memory 3 05-29-12 12:00 PM
Intel's Ivy Bridge Core i7 3770K Overheating Issue Detailed News Archived News Items 0 05-16-12 10:40 AM
CPUMark99 - how do you compare fuelrod Benchmarking And Overclocking 66 07-19-11 08:32 AM
Nvidia Problems in Slackware 8.1 xtreme NVIDIA Linux 3 10-01-02 12:03 PM
GeForce4 hard lockup with games under Windows XP Snap NVIDIA GeForce 7, 8, And 9 Series 6 09-27-02 02:37 PM

All times are GMT -5. The time now is 10:37 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.