Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-31-04, 11:53 AM   #13
john_betelgeuse
Registered User
 
Join Date: May 2004
Posts: 11
Default Re: Floating Point Exception Error: Help?

Here's the ls of /usr/lib/libGL*

ls -la /usr/lib/libGL*
-rw-r--r-- 1 root root 653 May 30 18:33 /usr/lib/libGL.la
lrwxrwxrwx 1 root root 10 May 30 18:33 /usr/lib/libGL.so -> libGL.so.1
lrwxrwxrwx 1 root root 17 May 30 18:33 /usr/lib/libGL.so.1 -> libGL.so.1.0.5336
-rwxr-xr-x 1 root root 367092 May 30 18:33 /usr/lib/libGL.so.1.0.5336
-rw-r--r-- 1 root root 924278 Feb 15 14:38 /usr/lib/libGLU.a
lrwxrwxrwx 1 root root 17 May 16 13:10 /usr/lib/libGLU.so -> libGLU.so.1.3.500
lrwxrwxrwx 1 root root 17 May 16 13:10 /usr/lib/libGLU.so.1 -> libGLU.so.1.3.500
-rw-r--r-- 1 root root 504440 Feb 15 14:38 /usr/lib/libGLU.so.1.3.500
lrwxrwxrwx 1 root root 21 May 30 18:33 /usr/lib/libGLcore.so.1 -> libGLcore.so.1.0.5336
-rwxr-xr-x 1 root root 4913084 May 30 18:33 /usr/lib/libGLcore.so.1.0.5336
-rw-r--r-- 1 root root 123518 Feb 15 14:37 /usr/lib/libGLw.a

When I try to run as root, I get the traditional "Could not load OpenGL library" message, even though strace shows /usr/lib/tls/libGL.so.1 getting opened, etc.

From strace, running as root:

open("/usr/lib/tls/libGL.so.1", O_RDONLY) = 49
read(49, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\3 60\235"..., 512) = 512
lseek(49, 307260, SEEK_SET) = 307260
read(49, "\4\0\0\0\20\0\0\0\1\0\0\0GNU\0\0\0\0\0\2\0\0\0\3\ 0\0\0"..., 32) = 32
fstat64(49, {st_mode=S_IFREG|0755, st_size=367332, ...}) = 0
close(49) = 0
munmap(0x413ae000, 100224) = 0

But then, for some reason, it doesn't like the taste, and closes it!
john_betelgeuse is offline   Reply With Quote
Old 05-31-04, 11:57 AM   #14
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: Floating Point Exception Error: Help?

@ john: No, your traces are all I need. I just want to see some traces from someone who is succesfully running UT, so I can compare and see where exactly things go wrong. Could you still post the ls -l stuff? And have you installed the latest UT patch(es), by the way? (You can get them from the UT website.)
hppnq is offline   Reply With Quote
Old 05-31-04, 02:33 PM   #15
john_betelgeuse
Registered User
 
Join Date: May 2004
Posts: 11
Default Re: Floating Point Exception Error: Help?

Here 'tis:

ls -l /usr/lib/libGL*
-rw-r--r-- 1 root root 653 May 30 18:33 /usr/lib/libGL.la
lrwxrwxrwx 1 root root 10 May 30 18:33 /usr/lib/libGL.so -> libGL.so.1
lrwxrwxrwx 1 root root 17 May 30 18:33 /usr/lib/libGL.so.1 -> libGL.so.1.0.5336
-rwxr-xr-x 1 root root 367092 May 30 18:33 /usr/lib/libGL.so.1.0.5336
-rw-r--r-- 1 root root 924278 Feb 15 14:38 /usr/lib/libGLU.a
lrwxrwxrwx 1 root root 17 May 16 13:10 /usr/lib/libGLU.so -> libGLU.so.1.3.500
lrwxrwxrwx 1 root root 17 May 16 13:10 /usr/lib/libGLU.so.1 -> libGLU.so.1.3.500
-rw-r--r-- 1 root root 504440 Feb 15 14:38 /usr/lib/libGLU.so.1.3.500
lrwxrwxrwx 1 root root 21 May 30 18:33 /usr/lib/libGLcore.so.1 -> libGLcore.so.1.0.5336
-rwxr-xr-x 1 root root 4913084 May 30 18:33 /usr/lib/libGLcore.so.1.0.5336
-rw-r--r-- 1 root root 123518 Feb 15 14:37 /usr/lib/libGLw.a

As for the latest patches . . . sorry, I didn't know that anything after 436 was available. I'll dig around some, see if I can find anything.
john_betelgeuse is offline   Reply With Quote
Old 05-31-04, 02:40 PM   #16
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: Floating Point Exception Error: Help?

436 might just be the latest patch. ;-) (Check to be sure, I don't remember exactly.)

Could you also post the output of "ls -l /usr/lib/tls/libGL*"? Cheers!
hppnq is offline   Reply With Quote
Old 05-31-04, 02:45 PM   #17
john_betelgeuse
Registered User
 
Join Date: May 2004
Posts: 11
Default Re: Floating Point Exception Error: Help?

Here tis:

ls -l /usr/lib/tls
total 5220
-rw-r--r-- 1 root root 657 May 30 18:33 libGL.la
lrwxrwxrwx 1 root root 10 May 30 18:33 libGL.so -> libGL.so.1
lrwxrwxrwx 1 root root 17 May 30 18:33 libGL.so.1 -> libGL.so.1.0.5336
-rwxr-xr-x 1 root root 367332 May 30 18:33 libGL.so.1.0.5336
lrwxrwxrwx 1 root root 21 May 30 18:33 libGLcore.so.1 -> libGLcore.so.1.0.5336
-rwxr-xr-x 1 root root 4954300 May 30 18:33 libGLcore.so.1.0.5336

I tried copying just the libGL stuff into the ut/System directory (because that is where it looks first), then the tls/libGL stuff, to see if that made a difference.

No real change. I deleted it back out again, so all further attempts should (and do) look in /usr/lib or /usr/lib/tls. UT is sure enough getting the NVidia libraries.

Sure enough, unless OpenUT has some later code, 436 was the last released version. Good suggestion, though.

Thanks!

john_betelgeuse is offline   Reply With Quote
Old 05-31-04, 02:56 PM   #18
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: Floating Point Exception Error: Help?

John, I think something messed up your GL libraries. Notice how the sizes of the libGL.so libraries in /usr/lib and /usr/lib/tls differ, although they have the same name. Best thing probably is to uninstall the driver, uninstall your OpenGL stuff and re-install (OpenGL first if you need it).

(Then post the ls -l output of both /usr/lib and /usr/lib/tls again, please.)

Can you also check the Nvidia driver README, and see if any of the described libGL problems is a known problem for your setup?
hppnq is offline   Reply With Quote
Old 05-31-04, 03:37 PM   #19
john_betelgeuse
Registered User
 
Join Date: May 2004
Posts: 11
Default Re: Floating Point Exception Error: Help?

The size differences are because the /usr/lib/tls/libGL* stuff is for "Thread Local Storage" versions of pthread, while the /usr/lib/libGL* is for the non-TLS stuff..

However, I did try uninstalling and re-installing (from version 4363 through the current one), and no luck. It's still SGIFPE'ing.

As a desparate act, I acquired a patch from

http://www.utpg.org/

That claims it's for both client and server, and applied it.

No luck.

Just for safeties sake, I'm going to reinstall the 436-GOTY version to minimize the number of changes.

Thanks!
john_betelgeuse is offline   Reply With Quote
Old 05-31-04, 03:47 PM   #20
hppnq
Registered User
 
Join Date: Apr 2004
Location: Dutch
Posts: 113
Default Re: Floating Point Exception Error: Help?

What was I thinking?!;-)

Thing is, the only thing I can think of is that it is either a problem regarding library versions, or you have a problem similar to the ones described in the README. (I guess there's not a chance that you could run this on another distribution easily? ;-) But both are unlikely.

Can you fiddle with the UT configuration or parameters? What options do you have?
hppnq is offline   Reply With Quote

Old 05-31-04, 07:34 PM   #21
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default Re: Floating Point Exception Error: Help?

If tuxracer loads the tls libraries.. perhaps you should be running them for UT as well. You mentioned trying to move the libs into the UT install.. but you can force / request tls libs to be installed / used with a switch to the installer. You could also relink the directories to load the tls libs instead (ln -sf /usr/lib/libGL.so /usr/lib/tls/libGL.so). Worth investigation.
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:26 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.