Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-02-04, 05:59 PM   #1
geki
Registered User
 
Join Date: Jun 2004
Posts: 14
Default nvidia driver - AddScreen/ScreenInit fails...

Hi all,

whenever I reinstall my system (Gentoo) they work once as long as I let run my XFree86. After stopping XFree86 and trying to restart it I get the following:

(II) NVIDIA(0): Memory and vga registers mapped
(II) NVIDIA(0): Verifying AGP usage for Screen 0...
(II) NVIDIA(0): AGP 8X successfully initialized
(EE) NVIDIA(0): Failed to map framebuffer memory
(EE) NVIDIA(0): *** Aborting ***

Fatal server error:
AddScreen/ScreenInit failed for driver 0


I tried 4496, 5336, 5341... Always the same...
I tried Gentoo stable, unstable and even newer packages...

ACPI/APM off in BIOS and kernel... well, I use 2.6 kernels but many do without problems...
is glibc with NPTL an issue because many use that without problems...

The only thing I can't change is AGP 8X, no option in BIOS and that flag (NVreg_ReqAGPRate=8) in /etc/modules.d/nvidia I changed to 4 but starting X still used AGP 8X.

I have added these three files that you can check?


Also check my thread on gentoo.org:

http://forums.gentoo.org/viewtopic.php?t=180522


I hope here someone can help...
Sure I miss some infos, I tried all I think... but ask please...

I use Gainward GeForce FX 5900 Ultra card.
If here is noone that can help sure my gfx card firmware must be buggy?!?
Attached Files
File Type: txt XFree86.0.log.txt (39.7 KB, 122 views)
File Type: txt syslog.txt (210 Bytes, 131 views)
File Type: txt XF86Config.txt (3.5 KB, 131 views)
geki is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia driver quality decrease? legluondunet NVIDIA Linux 17 06-26-12 10:03 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Lucid rt kernel can't load latest nvidia driver module, but generic does. marcod NVIDIA Linux 0 05-02-12 06:23 AM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM

All times are GMT -5. The time now is 04:20 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.