Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-31-04, 01:53 AM   #1
QOAC
Registered User
 
Join Date: Mar 2004
Posts: 12
Default Mandrake 10 final & FX5700Q crashes with agp enabled

My system has the following components, Asus A7V133 main board bios revision 1009. Athlon 1800+ cpu 512 mg sdram and my graphics card is a Albatron Geforce FX5700Q 256mg ram.
I am currently running the 4620 drivers, the 5341 also work for me. Providing AGP is disabled. If AGP is enabled the system crashes with in minutes of entering the desktop (kde) sometimes it hangs while loading into the graphical enviroment.
It seems only the graphical server is crashing and i lose keyboard. I am running the 2.6 kernel that shipped with mandrake 10. For the moment my system is stable and 3d performance is on a par with my old card (geforce2 ti 200).
The only area were the system falls over is those games that require AGP for there performance (unreal Tournament 2004) with the geforce 2 i would average 20 fps which whilst not brilliant was acceptabel, with the fx i get 4 fps due to AGP being disabled.
Is my problem related to the motherboard i am using? Should I try upgrading it?
It seems that the FX series of cards have some issues with some distros especially mandrake.
XFdrake sets my FX card up as a custom card, almost as if mandrake doesnt know what it is, but harddrake identifies it correctly.
APart from the above niggling issues I am really happy with Nvidia's continuing support for my favorite OS.
Attached Files
File Type: txt XF86Config-4.txt (2.6 KB, 149 views)
File Type: txt XFree86.0.log.txt (30.7 KB, 136 views)
QOAC is offline   Reply With Quote
Old 05-31-04, 08:47 PM   #2
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: Mandrake 10 final & FX5700Q crashes with agp enabled

Check your ram with memtest86. Athlons have a thing about needing good ram.
whig is offline   Reply With Quote
Old 06-01-04, 12:42 PM   #3
QOAC
Registered User
 
Join Date: Mar 2004
Posts: 12
Default Re: Mandrake 10 final & FX5700Q crashes with agp enabled

Hi Whig
Thanks for the tip, I will do that.
I ran memtest86 v3.1 results of the tests showed errors on test 5 consistently (Test 5 [Block move, 64 moves, cached]). What I cant understand is why this didnt affect my previous graphics card. Looks like im up for some new ram?

Last edited by QOAC; 06-01-04 at 03:13 PM.
QOAC is offline   Reply With Quote
Old 06-01-04, 09:28 PM   #4
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: Mandrake 10 final & FX5700Q crashes with agp enabled

A pity you got those ram errors. New ram could be the answer. In my case I ordered this computer and the shop selling it reported crashes as they were burning it in. Switching to Kingmax 400MHz DDR made it stable, not that you can use it in your sdram motherboard. Who else has solved this problem on such a system?
whig is offline   Reply With Quote
Old 06-02-04, 05:47 AM   #5
QOAC
Registered User
 
Join Date: Mar 2004
Posts: 12
Default Re: Mandrake 10 final & FX5700Q crashes with agp enabled

Well I will get some new ram see if it fixes the problem, might be a good excuse to do an upgrade. (get past the missus)
QOAC is offline   Reply With Quote
Old 06-08-04, 11:29 AM   #6
QOAC
Registered User
 
Join Date: Mar 2004
Posts: 12
Default Re: Mandrake 10 final & FX5700Q crashes with agp enabled

Ok situation partially resolved, I have upgraded my mainboard to an Asus A7N8X-E and bought new ddr ram for the board. I now have AGP enabled.
glx gears reports the following

[kernel_panic@zuess kernel_panic]$ glxgears
21165 frames in 5.0 seconds = 4233.000 FPS
21927 frames in 5.0 seconds = 4385.400 FPS
22162 frames in 5.0 seconds = 4432.400 FPS
22180 frames in 5.0 seconds = 4436.000 FPS
X connection to :0.0 broken (explicit kill or server shutdown).
[kernel_panic@zuess kernel_panic]$

I am still experiencing the odd lock up but not like before. Now it usually results in the Xserver resetting itself. For now I can live with this.
Here is some more info from my system

[root@zuess kernel_panic]# cat /proc/driver/nvidia/agp/status
Status: Enabled
Driver: NVIDIA
AGP Rate: 8x
Fast Writes: Disabled
SBA: Enabled
[root@zuess kernel_panic]#

[root@zuess kernel_panic]# cat /proc/driver/nvidia/agp/card
Fast Writes: Supported
SBA: Supported
AGP Rates: 8x 4x
Registers: 0x1f000e1b:0x1f004302
[root@zuess kernel_panic]#

[root@zuess kernel_panic]# cat /proc/driver/nvidia/agp/host-bridge
Host Bridge: nVidia Corporation nForce2 AGP (different version?)
Fast Writes: Supported
SBA: Supported
AGP Rates: 8x 4x
Registers: 0x1f00421b:0x00000302
[root@zuess kernel_panic]#

So it seems part of my problems were due to a flaky motherboard and or ram
QOAC is offline   Reply With Quote
Old 06-11-04, 12:01 PM   #7
QOAC
Registered User
 
Join Date: Mar 2004
Posts: 12
Default Re: Mandrake 10 final & FX5700Q crashes with agp enabled

Finally got the system stable, replaced the DDR ram with a new stick, system has been stable for 24 hours now. Things are looking good.
QOAC is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake Linux 9.0 (Dolphin) now available | comments? volt General Linux 10 10-19-02 11:13 PM
POSSIBLE AGP TROUBLE (mandrake 9.0) chrono86 NVIDIA Linux 4 10-12-02 01:09 PM
Mandrake 9.0 upgrade - x crashes gozilla NVIDIA Linux 2 09-27-02 11:04 AM
AGP not being enabled on Geforce2 mx frankjr NVIDIA Linux 1 09-22-02 03:01 PM
X freezes when agp 4x is enabled jinksed NVIDIA Linux 1 08-07-02 05:56 PM

All times are GMT -5. The time now is 10:01 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.