Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-08-04, 11:23 AM   #1
Spring
Registered User
 
Join Date: Jun 2004
Posts: 4
Default startx reports "no screens found" with nvidia driver

Hi. I recently built a new computer with a NVidia geForce 4 MX 440 Card and have had a long history of problems trying to get it to work. I am running Mandrake 10 Community. I have to have my machine boot into runlevel 3 because it resets the driver to "nvidia" everytime I restart. That isn't the problem. Running the command "startx" (or having X start any other way) gives my a "no screens found" error when I am using the "nvidia" driver. I am using driver version 1.0-5336. I can edit the XF86Config file so that it uses the "nv" driver and then I can startx just fine. Thats how I am writing this now. My computer has a VIA KT600 chipset mainboard, a Athalon T-Bird 1000Mhz processor, 128M of RAM and the NVidia video card. The video card was the most expensive part and it really sucks not to have any 3D acceleration.
Any help would be greatly appreciated. Thanks in advance.
-Spring
Attached Files
File Type: txt XF86Config-4.txt (2.6 KB, 127 views)
Spring is offline   Reply With Quote
Old 06-08-04, 11:29 AM   #2
Spring
Registered User
 
Join Date: Jun 2004
Posts: 4
Default Re: startx reports "no screens found" with nvidia driver

My XFree.0.log file doesn't want to be an attachment so I'll dump the contents here:

This is a pre-release version of XFree86, and is not supported in any
way. Bugs may be reported to XFree86@XFree86.Org and patches submitted
to fixes@XFree86.Org. Before reporting bugs in pre-release versions,
please check the latest version in the XFree86 CVS repository
(http://www.XFree86.Org/cvs).

XFree86 Version 4.3.0.1
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.6.3-3mdkenterprise i686 [ELF]
Build Date: 24 March 2004
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Tue Jun 8 00:08:40 2004
(==) Using config file: "/etc/X11/XF86Config-4"
(==) ServerLayout "layout1"
(**) |-->Screen "screen1" (0)
(**) | |-->Monitor "monitor1"
(**) | |-->Device "device1"
(**) |-->Input Device "Keyboard1"
(**) Option "XkbModel" "pc105"
(**) XKB: model: "pc105"
(**) Option "XkbLayout" "en_US"
(**) XKB: layout: "en_US"
(WW) Option "XkbOptions" requires an string value
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "Mouse1"
(**) FontPath set to "unix/:-1"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(**) Option "AllowMouseOpenFail"
Using vt 7
(--) using VT number 7

(II) Open APM successful
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.2
XFree86 Video Driver: 0.6
XFree86 XInput driver : 0.4
XFree86 Server Extension : 0.2
XFree86 Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x80008d48, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 1106,3189 card 1106,3189 rev 80 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 1106,b198 card 0000,0000 rev 00 class 06,04,00 hdr 01
(II) PCI: 00:0f:0: chip 1106,3149 card 1106,3149 rev 80 class 01,04,00 hdr 80
(II) PCI: 00:0f:1: chip 1106,0571 card 1106,0571 rev 06 class 01,01,8a hdr 00
(II) PCI: 00:10:0: chip 1106,3038 card 1106,3038 rev 81 class 0c,03,00 hdr 80
(II) PCI: 00:10:1: chip 1106,3038 card 1106,3038 rev 81 class 0c,03,00 hdr 80
(II) PCI: 00:10:2: chip 1106,3038 card 1106,3038 rev 81 class 0c,03,00 hdr 80
(II) PCI: 00:10:3: chip 1106,3038 card 1106,3038 rev 81 class 0c,03,00 hdr 80
(II) PCI: 00:10:4: chip 1106,3104 card 1106,3104 rev 86 class 0c,03,20 hdr 80
(II) PCI: 00:11:0: chip 1106,3227 card 1106,3227 rev 00 class 06,01,00 hdr 80
(II) PCI: 00:11:5: chip 1106,3059 card 1106,4552 rev 60 class 04,01,00 hdr 00
(II) PCI: 00:12:0: chip 1106,3065 card 1106,0102 rev 78 class 02,00,00 hdr 00
(II) PCI: 01:00:0: chip 10de,0181 card 0000,0000 rev c1 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,1), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[b]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[b]
(II) Bus 0 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[b]
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x000c (VGA_EN is set)
(II) Bus 1 non-prefetchable memory range:
[0] -1 0 0xec000000 - 0xedffffff (0x2000000) MX[b]
(II) Bus 1 prefetchable memory range:
[0] -1 0 0xe0000000 - 0xe7ffffff (0x8000000) MX[b]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:17:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI:*(1:0:0) nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] rev 193, Mem @ 0xec000000/24, 0xe0000000/27
(II) Addressable bus resource ranges are
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[b]
[1] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[b]
(II) OS-reported resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
(II) PCI Memory resource overlap reduced 0xe8000000 from 0xebffffff to 0xe7ffffff
(II) Active PCI resource ranges:
[0] -1 0 0xee001000 - 0xee0010ff (0x100) MX[b]
[1] -1 0 0xee000000 - 0xee0000ff (0x100) MX[b]
[2] -1 0 0xe8000000 - 0xe7ffffff (0x0) MX[b]O
[3] -1 0 0xe0000000 - 0xe7ffffff (0x8000000) MX[b](B)
[4] -1 0 0xec000000 - 0xecffffff (0x1000000) MX[b](B)
[5] -1 0 0x0000c000 - 0x0000c0ff (0x100) IX[b]
[6] -1 0 0x0000bc00 - 0x0000bcff (0x100) IX[b]
[7] -1 0 0x0000b800 - 0x0000b81f (0x20) IX[b]
[8] -1 0 0x0000b400 - 0x0000b41f (0x20) IX[b]
[9] -1 0 0x0000b000 - 0x0000b01f (0x20) IX[b]
[10] -1 0 0x0000ac00 - 0x0000ac1f (0x20) IX[b]
[11] -1 0 0x0000a800 - 0x0000a80f (0x10) IX[b]
[12] -1 0 0x0000a400 - 0x0000a4ff (0x100) IX[b]
[13] -1 0 0x0000a000 - 0x0000a00f (0x10) IX[b]
[14] -1 0 0x00009c00 - 0x00009c03 (0x4) IX[b]
[15] -1 0 0x00009800 - 0x00009807 (0x8) IX[b]
[16] -1 0 0x00009400 - 0x00009403 (0x4) IX[b]
[17] -1 0 0x00009000 - 0x00009007 (0x8) IX[b]
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0 0xee001000 - 0xee0010ff (0x100) MX[b]
[1] -1 0 0xee000000 - 0xee0000ff (0x100) MX[b]
[2] -1 0 0xe8000000 - 0xe7ffffff (0x0) MX[b]O
[3] -1 0 0xe0000000 - 0xe7ffffff (0x8000000) MX[b](B)
[4] -1 0 0xec000000 - 0xecffffff (0x1000000) MX[b](B)
[5] -1 0 0x0000c000 - 0x0000c0ff (0x100) IX[b]
[6] -1 0 0x0000bc00 - 0x0000bcff (0x100) IX[b]
[7] -1 0 0x0000b800 - 0x0000b81f (0x20) IX[b]
[8] -1 0 0x0000b400 - 0x0000b41f (0x20) IX[b]
[9] -1 0 0x0000b000 - 0x0000b01f (0x20) IX[b]
[10] -1 0 0x0000ac00 - 0x0000ac1f (0x20) IX[b]
[11] -1 0 0x0000a800 - 0x0000a80f (0x10) IX[b]
[12] -1 0 0x0000a400 - 0x0000a4ff (0x100) IX[b]
[13] -1 0 0x0000a000 - 0x0000a00f (0x10) IX[b]
[14] -1 0 0x00009c00 - 0x00009c03 (0x4) IX[b]
[15] -1 0 0x00009800 - 0x00009807 (0x8) IX[b]
[16] -1 0 0x00009400 - 0x00009403 (0x4) IX[b]
[17] -1 0 0x00009000 - 0x00009007 (0x8) IX[b]
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
(II) All system resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0 0xee001000 - 0xee0010ff (0x100) MX[b]
[6] -1 0 0xee000000 - 0xee0000ff (0x100) MX[b]
[7] -1 0 0xe8000000 - 0xe7ffffff (0x0) MX[b]O
[8] -1 0 0xe0000000 - 0xe7ffffff (0x8000000) MX[b](B)
[9] -1 0 0xec000000 - 0xecffffff (0x1000000) MX[b](B)
[10] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[11] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[12] -1 0 0x0000c000 - 0x0000c0ff (0x100) IX[b]
[13] -1 0 0x0000bc00 - 0x0000bcff (0x100) IX[b]
[14] -1 0 0x0000b800 - 0x0000b81f (0x20) IX[b]
[15] -1 0 0x0000b400 - 0x0000b41f (0x20) IX[b]
[16] -1 0 0x0000b000 - 0x0000b01f (0x20) IX[b]
[17] -1 0 0x0000ac00 - 0x0000ac1f (0x20) IX[b]
[18] -1 0 0x0000a800 - 0x0000a80f (0x10) IX[b]
[19] -1 0 0x0000a400 - 0x0000a4ff (0x100) IX[b]
[20] -1 0 0x0000a000 - 0x0000a00f (0x10) IX[b]
[21] -1 0 0x00009c00 - 0x00009c03 (0x4) IX[b]
[22] -1 0 0x00009800 - 0x00009807 (0x8) IX[b]
[23] -1 0 0x00009400 - 0x00009403 (0x4) IX[b]
[24] -1 0 0x00009000 - 0x00009007 (0x8) IX[b]
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.5336
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.5336
Module class: XFree86 Video Driver
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.4
(II) NVIDIA XFree86 Driver 1.0-5336 Wed Jan 14 18:30:46 PST 2004
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0 0xee001000 - 0xee0010ff (0x100) MX[b]
[6] -1 0 0xee000000 - 0xee0000ff (0x100) MX[b]
[7] -1 0 0xe8000000 - 0xe7ffffff (0x0) MX[b]O
[8] -1 0 0xe0000000 - 0xe7ffffff (0x8000000) MX[b](B)
[9] -1 0 0xec000000 - 0xecffffff (0x1000000) MX[b](B)
[10] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[11] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[12] -1 0 0x0000c000 - 0x0000c0ff (0x100) IX[b]
[13] -1 0 0x0000bc00 - 0x0000bcff (0x100) IX[b]
[14] -1 0 0x0000b800 - 0x0000b81f (0x20) IX[b]
[15] -1 0 0x0000b400 - 0x0000b41f (0x20) IX[b]
[16] -1 0 0x0000b000 - 0x0000b01f (0x20) IX[b]
[17] -1 0 0x0000ac00 - 0x0000ac1f (0x20) IX[b]
[18] -1 0 0x0000a800 - 0x0000a80f (0x10) IX[b]
[19] -1 0 0x0000a400 - 0x0000a4ff (0x100) IX[b]
[20] -1 0 0x0000a000 - 0x0000a00f (0x10) IX[b]
[21] -1 0 0x00009c00 - 0x00009c03 (0x4) IX[b]
[22] -1 0 0x00009800 - 0x00009807 (0x8) IX[b]
[23] -1 0 0x00009400 - 0x00009403 (0x4) IX[b]
[24] -1 0 0x00009000 - 0x00009007 (0x8) IX[b]
(II) resource ranges after probing:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0 0xee001000 - 0xee0010ff (0x100) MX[b]
[6] -1 0 0xee000000 - 0xee0000ff (0x100) MX[b]
[7] -1 0 0xe8000000 - 0xe7ffffff (0x0) MX[b]O
[8] -1 0 0xe0000000 - 0xe7ffffff (0x8000000) MX[b](B)
[9] -1 0 0xec000000 - 0xecffffff (0x1000000) MX[b](B)
[10] 0 0 0x000a0000 - 0x000affff (0x10000) MS[b]
[11] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[b]
[12] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[b]
[13] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[14] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[15] -1 0 0x0000c000 - 0x0000c0ff (0x100) IX[b]
[16] -1 0 0x0000bc00 - 0x0000bcff (0x100) IX[b]
[17] -1 0 0x0000b800 - 0x0000b81f (0x20) IX[b]
[18] -1 0 0x0000b400 - 0x0000b41f (0x20) IX[b]
[19] -1 0 0x0000b000 - 0x0000b01f (0x20) IX[b]
[20] -1 0 0x0000ac00 - 0x0000ac1f (0x20) IX[b]
[21] -1 0 0x0000a800 - 0x0000a80f (0x10) IX[b]
[22] -1 0 0x0000a400 - 0x0000a4ff (0x100) IX[b]
[23] -1 0 0x0000a000 - 0x0000a00f (0x10) IX[b]
[24] -1 0 0x00009c00 - 0x00009c03 (0x4) IX[b]
[25] -1 0 0x00009800 - 0x00009807 (0x8) IX[b]
[26] -1 0 0x00009400 - 0x00009403 (0x4) IX[b]
[27] -1 0 0x00009000 - 0x00009007 (0x8) IX[b]
[28] 0 0 0x000003b0 - 0x000003bb (0xc) IS[b]
[29] 0 0 0x000003c0 - 0x000003df (0x20) IS[b]
(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xE0000000
(--) NVIDIA(0): MMIO registers at 0xEC000000
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.
Spring is offline   Reply With Quote
Old 06-08-04, 02:24 PM   #3
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default Re: startx reports "no screens found" with nvidia driver

The kernel module fails to insert into the kernel. Run depmod then modprobe nvidia to see if the module itself will even work with the kernel. If there are errors (other than the 'tainted kernel' message, then you will have to correct these before the driver will work. It is possible you did not build the module (when it installed) using the right kernel sources -- perhaps the wrong version. After you run the above commands, run lsmod and post the output.

Make this addition as well.
Code:
Subsection "Display"
        Depth 16
        Virtual 1024 768
        Modes "1024x768"
    EndSubsection
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Old 06-08-04, 05:26 PM   #4
Spring
Registered User
 
Join Date: Jun 2004
Posts: 4
Default Re: startx reports "no screens found" with nvidia driver

The nvidia module seems to be loaded at boot. I even ran 'rmmod' and then modprobed it again. No messages. Using 'modprobe -v nvidia', all I got was:

insmod /lib/modules/2.6.3-4mdk/kernel/drivers/video/nvidia.ko

I added the Mode lines to my XF86Config-4' file... Still the same.
Spring is offline   Reply With Quote
Old 06-08-04, 10:39 PM   #5
reyawn
Registered User
 
Join Date: May 2004
Posts: 11
Default Re: startx reports "no screens found" with nvidia driver

Here's my XF86Config-4 file in Mandrake 10 (running it now).
I'm using the 2.6.3-13 kernel and since there were no headers for the nvidia driver, it had to custom build the kernel module (I had the kernel source and such installed).

Hope this helps (I'm using 1280x1024 resolution right now).


Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "en_US"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "Dell M782"
HorizSync 30-85
VertRefresh 50-160

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
BoardName "NVIDIA GeForce FX 5900XT"
Driver "nvidia"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 15
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 16
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 24
Virtual 1280 1024
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection
reyawn is offline   Reply With Quote
Old 06-08-04, 10:46 PM   #6
reyawn
Registered User
 
Join Date: May 2004
Posts: 11
Default Re: startx reports "no screens found" with nvidia driver

also, I found a problem in your XF86Config, you commented out everything in your "Module" section except for the glx module. This isn't good, glx only draws 3d so you cut out all your other modules for 2d and everything. just uncomment all of those modules you have commented there and it should work (it will look the same as my XF86Config-4 then) and disable the "Mode" lines because they aren't needed and may cause even more problems.
reyawn is offline   Reply With Quote
Old 06-09-04, 09:03 PM   #7
Spring
Registered User
 
Join Date: Jun 2004
Posts: 4
Default Re: startx reports "no screens found" with nvidia driver

Still no good... Maybe if I compile a new kernel and then recompile the driver so I know they match... You say you're using 2.6.3-13, I am currently using 2.6.3-4, guess I'll try to find a kernel compilation FAQ. Any more suggestions?
Spring is offline   Reply With Quote
Old 06-13-04, 04:58 AM   #8
lucaspiller
Registered User
 
Join Date: Jun 2004
Posts: 2
Default Re: startx reports "no screens found" with nvidia driver

I have the same problem, luckily I upgraded from 9.2 so I am just using the old kernel. This causes a few problems though as some of the things only work with the new kernel.

I still have problems with the driver though, unless I restart the x server whenever I run an OpenGL app the system locks up.
lucaspiller is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Responds to Reports of Kepler V-Sync Stuttering Issue Rieper NVIDIA GeForce 600 Series 13 03-03-13 10:56 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM
Worked fine before, now getting "no screens found" HansBoldt NVIDIA Linux 3 08-22-02 06:20 AM

All times are GMT -5. The time now is 06:56 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.