Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-12-02, 12:17 PM   #1
amino911
Registered User
 
Join Date: Nov 2002
Posts: 6
Unhappy GL application VERY SLOW

I have redhat 8.0 and an RIVA TNT2 graphics card. I have followed the instructions for installing the GLX and driver but GL applications are so slow. I checked all the libraries and removed the MESA ones, but no change. I suspect it is the GLU libraries that I have may have some incompatibility issues with the NVIDIA GL extensions, but I am not sure where to find compatible GLU libraries, or what to do

Any help greatly appreciated

Thanks
amino911 is offline   Reply With Quote
Old 11-12-02, 06:01 PM   #2
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

What's the output of 'glxinfo'? Can you post your /var/log/XFree86.0.log file?

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 11-12-02, 09:45 PM   #3
amino911
Registered User
 
Join Date: Nov 2002
Posts: 6
Post

Sorry for this long message.

This is part of the XFree86.0.log file (it is quite big) If you need another part please let me know:
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "fbdevhw"
(II) Loading /usr/X11R6/lib/modules/linux/libfbdevhw.a
(II) Module fbdevhw: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 0.0.2
ABI class: XFree86 Video Driver, version 0.5
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.3123
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/X11R6/lib/modules/extensions/librecord.a
(II) Module record: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.13.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension RECORD
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.1.10
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.3
(II) Loading font FreeType
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.1
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.3
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.3123
Module class: XFree86 Video Driver

.....

(II) NVIDIA XFree86 Driver 1.0-3123 Tue Aug 27 16:00:08 PDT 2002
(II) NVIDIA: NVIDIA driver for: RIVA TNT, RIVA TNT2, Vanta,
RIVA TNT2 Ultra, RIVA TNT2 Model 64, Aladdin TNT2, GeForce 256,
GeForce DDR, Quadro, GeForce2 MX/MX 400, GeForce2 MX 100/200,
Quadro2 MXR/EX/Go, GeForce2 Integrated GPU, GeForce2 GTS,
GeForce2 Ti, GeForce2 Ultra, Quadro2 Pro, GeForce4 MX 460,
GeForce4 MX 440, GeForce4 MX 420, Quadro4 500/550 XGL,
Quadro4 200/400 NVS, NV18, NV18 , NV18 , NV18, NV18GL, NV18GL ,
NV18GL , 0x01F0, GeForce3, GeForce3 Ti 200, GeForce3 Ti 500,
Quadro DCC, GeForce4 Ti 4600, GeForce4 Ti 4400, GeForce4 Ti 4200,
Quadro4 900 XGL, Quadro4 750 XGL, Quadro4 700 XGL, NV28, NV28 ,
NV28GL, NV28GL , GeForce2 Go, GeForce4 440 Go, GeForce4 420 Go,
GeForce4 420 Go 32M, GeForce4 460 Go, GeForce4 440 Go 64M,
GeForce4 410 Go 16M, Quadro4 500 GoGL
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset Vanta found

.....

(II) NVIDIA(0): AGP 2X successfully initialized
(II) NVIDIA(0): Setting mode "1024x768"
(II) NVIDIA(0): Using XFree86 Acceleration Architecture (XAA)
Screen to screen bit blits
Solid filled rectangles
Solid filled trapezoids
8x8 mono pattern filled rectangles
8x8 mono pattern filled trapezoids
Indirect CPU to Screen color expansion
Solid Lines
Scanline Image Writes
Offscreen Pixmaps
Driver provided FillSolidRects replacement
Driver provided FillSolidSpans replacement
Driver provided FillMono8x8PatternRects replacement
Driver provided WritePixmap replacement
Driver provided ReadPixmap replacement
Setting up tile and stipple cache:
16 128x128 slots
4 256x256 slots
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-GLX
(II) Loading extension NV-CONTROL

I have also attached the output of glxinfo

Any help on this greatly appreciated.
For extra info, I would like to mention here, that I have always had this problem since I had Redhat7.1 The GLU libraries somehow mess things up. However, for a short period of time, I downloaded from somewhere some GLU libraries and the system was working great. I mean at good resolutions the speed was awesome, it was really great but then the same problem occured when I tried to update the system. So I am not sure exactly what is going on or how to detect the problem. I am just guessing now

Thanks a lot
Attached Files
File Type: txt glxinfo.txt (2.5 KB, 130 views)
amino911 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox is still slow with NV30GL, NV31GL and driver 173.14.35 djanssen NVIDIA Linux 0 07-05-12 04:27 PM
$64.99 - Polk Audio OWM3 White Multi Application Compact Loudspeaker Pair News Archived News Items 0 07-04-12 12:30 PM
Nvidia 173.14.35: Fedora 17 x86 terribly slow Mr Wolf NVIDIA Linux 25 07-02-12 01:44 AM
Gnome3 with composite is very slow on Geforce FX 5200 with 173.14.31 driver Artox NVIDIA Linux 0 05-26-12 10:33 AM
Very slow X startup Jeremy NVIDIA Linux 96 05-23-03 10:11 AM

All times are GMT -5. The time now is 08:03 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.