Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-29-04, 03:48 PM   #1
Vorpal blade
Registered User
 
Join Date: Jul 2004
Posts: 2
Default X will not start after install

After installing Redhat 9, I discovered that hardware OpenGL was not working. I figured that if i installed the nvidia driver, the problem would go away. I downloaded it, followd instructions, and it appeared to have installed correctly. when I changed the runlevel back to 5 and rebooted, X tried to start 5 or six times, displaying the nvidia spalsh for a fraction of a second, before going black again. then i got a messege asking weather I would like to reconfigure X. I did so, but it just reinstalled the nv driver. now OpenGL doesnt work at all, when I try and run a OpenGL app I get this error message repeatedly:
Xlib: extension "GLX" missing on display ":0.0".
the X config file is back to the way it was before I installed the nvidia driver. If I change it again to point to the nvidia driver, the same thing happens, and X will not start.

Kernel version 2.4.20-6
Red hat 9
GeForce 2 MX 440
Intel P3 500MHz

used NVIDIA-Linux-x86-1.0-6106-pkg1.run

Thanks in advance
Vorpal blade is offline   Reply With Quote
Old 07-29-04, 09:33 PM   #2
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: X will not start after install

Inspect your X log in /var/log and look for errors. Post it here if you need more help.
whig is offline   Reply With Quote
Old 07-29-04, 11:35 PM   #3
Vorpal blade
Registered User
 
Join Date: Jul 2004
Posts: 2
Default Re: X will not start after install

Here are the log file and the config file.
In addition, when I tried startx from the command prompt, I got back the last bit of the log file, (complete with "caught signal 11 error" and this error message: XIO: fatal IO error 104 (connection reset by peer) on x server ":0.0" after 0 requests (0 known prossesed) with 0 events remaining"

Godspeed

-Vorpal
Attached Files
File Type: txt XFree86.0.log.txt (24.5 KB, 173 views)
File Type: txt XF86Config.txt (3.2 KB, 182 views)
Vorpal blade is offline   Reply With Quote
Old 07-30-04, 01:35 AM   #4
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: X will not start after install

It is failing on initializing GLX but I'm unsure why. All I can think of is to check you have all necessary X libs installed (which if the "nv" driver goes, you probably have), use a different "NvAGP" setting (refer readme) or try a previous driver, eg 5336.
whig is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Microsoft explained why they killed start button AthlonXP1800 Microsoft Windows 8 19 10-28-12 10:07 AM
Base mosaic and rotation? happyfunbot NVIDIA Linux 5 07-13-12 01:23 PM
Mageia 2 Cannot Install 71.86.15 for Riva TNT/TNT2 kbulgrien NVIDIA Linux 3 06-29-12 09:27 AM
nForce + RedHat 7.3 Success Story rtz NVIDIA Linux 47 02-15-03 03:20 AM
Red Hat null(limbo beta 3), guide to install Nvidia Drivers utiel NVIDIA Linux 21 09-30-02 06:32 PM

All times are GMT -5. The time now is 12:46 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.