Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-29-04, 02:10 PM   #1
himba
Registered User
 
Join Date: Jul 2004
Posts: 2
Unhappy garbage on console when switching from x11

hi,

I've just upgraded to 6106 nvidia driver on my laptop - gericom x5 force. I managed to install the new driver with no problems using yast2 & sax2 in suse9 distribution.

X server start fine and everything is loking great!

When I switch to vt1 or any other text consoles (using alt+ctrl+Fn; n: 1-6) i can't see any text - only garbaled display. If I blindly type sometning (eg. log in and do reboot.. ) it works.

This used to happen in older versions of driver too, but it was solved somewhere in the middle - in some late 4xxx version as I recall. Now the same problem is back

Here are my specs:
* Pentium 4-M 1.6GHz
* 256 MB DDR RAM
* VIA P4X266A chip set
* GeForce 4 go with 32 MB
* Combo Drive (CD-RW writer and DVD reader)
* 30 GB harddisk
* internal WLAN 802.11b adapter
* 1 CompactFlash card slot
* AC'97 compatible sound
* 10/100 Mbit Ethernet built-in
* Modem built-in
* Fast Irda built-in
* Firewire 1394
* 3 USB 2.0 connectors

video card (lspci -v)
01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 440 Go 64M]
(rev a3) (prog-if 00 [VGA])
Subsystem: TWINHEAD INTERNATIONAL Corp: Unknown device 030b
Flags: bus master, 66Mhz, medium devsel, latency 248, IRQ 11
Memory at de000000 (32-bit, non-prefetchable) [size=16M]
Memory at d0000000 (32-bit, prefetchable) [size=128M]
Memory at ddc80000 (32-bit, prefetchable) [size=512K]
Expansion ROM at dfee0000 [disabled] [size=128K]
Capabilities: [60] Power Management version 2
Capabilities: [44] AGP version 2.0

regards, himba
himba is offline   Reply With Quote
Old 07-29-04, 07:00 PM   #2
jerickson314
Registered User
 
Join Date: May 2004
Posts: 43
Default Re: garbage on console when switching from x11

Try adding

Option "ConnectedMonitor" "CRT"
Option "IgnoreDisplayDevices" "TV"

to your XF86Config, or changing these options in the video card section of SaX2 (They're on the Advanced tab of the video card settings). If that doesn't work, remove the option "vga=" from your GRUB config. Unfortunately, neither of these options seem to fix the problem for people using DVI, but they seem to work for people using VGA connectors. With a laptop's built-in display, I don't know if it will work, let me know.
jerickson314 is offline   Reply With Quote
Old 07-30-04, 10:19 AM   #3
himba
Registered User
 
Join Date: Jul 2004
Posts: 2
Default Re: garbage on console when switching from x11

hi,

I wasn't using vga= on command prompt.

I tried the Options in X config, and if I used CRT the X didn't run, when replaced with DFP it started as usual, but text consoles are still garbled
himba is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
BUG 302.17 - can not access TTY console legluondunet NVIDIA Linux 9 06-24-12 05:16 PM
Console Killers News Archived News Items 0 06-11-12 10:10 PM
Official Linux driver 1.0-3123 thread bammbamm808 NVIDIA Linux 126 12-05-02 06:21 PM
how to boot SuSe 8.0 to console? chrisr NVIDIA Linux 8 08-19-02 09:08 PM

All times are GMT -5. The time now is 04:09 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.