Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-13-02, 11:55 PM   #1
MadDog
Registered User
 
Join Date: Nov 2002
Location: South Africa
Posts: 9
Default Video 4 Linux

Hi There,

Thanks for all the help in the forum. I successfully compiled and installed the latest drivers on Mandrake 9.0 and got twinview up and running first time.

could anyone please give me some insight in how I can use v4l (Video For Linux) to display live input from my card's video input.

I have a LeadTek A250 UTD+ (Geforce4 Ti4600) This card is the MyVivo edition which has video in and out capabilities. The TV encoder I think is a Phillips, and according to the MOTV MINI HOWTO's the Phillips encoder is supported indirectly.

The problem I have is that Mandrake did not create a /dev/video0 for my card, as it probably did not detect the capture device. I have tried to follow the instructions in the MOTV howto, but I am missing some libraries.

Has anyone managed to use an NVIDIA card as a capture device under Linux, and if so how ??

Kind Regards

MadDog
MadDog is offline   Reply With Quote
Old 11-15-02, 01:06 AM   #2
dgently
Registered User
 
Join Date: Jul 2002
Posts: 7
Default

The standard video4linux kernel drivers don't work with nvidia cards.
You need a special driver from http://rivatv.sourceforge.net/

(rivatv is a v4l driver like bttv which supports riva, tnt and geforce based cards)

just download http://prdownloads.sourceforge.net/r...ar.gz?download
and see the readme for instructions to build.

if you dont have the /dev/video0 device you can create it with the MAKEDEV script from your distro or by hand with:
mknod /dev/video0 c 81 0


good luck
dgently is offline   Reply With Quote
Old 11-15-02, 01:36 AM   #3
MadDog
Registered User
 
Join Date: Nov 2002
Location: South Africa
Posts: 9
Default

Hi,

Thanks for the help, I have installed RivaTV successfully, and got it working. I just have one small problem left. I use the SVideo Input on my card, not the composite input, so I am only getting a B&W Picture. This could also be TV Standard, as I have no idea how to set the input standard between PAL & NTSC.

Any help here would be greatly appreciated.

Regards

MadDog
MadDog is offline   Reply With Quote
Old 11-15-02, 01:54 AM   #4
dgently
Registered User
 
Join Date: Jul 2002
Posts: 7
Default

so you have connected your card via an svideo cable with your vcr/tv ?

just try selecting composite as the source (although you are using svideo)

i might be wrong (feel free to correct me) but i think, that svideo also has wires for composite signals, and the bw picture means that your source (the tv/vcr) doesn't ouput the svideo signals but only composite..

and the distinction of svideo/composite in the driver/app does not switch between the port the cable is connected to but for the wires used:
svideo: svideo from svideo port,
composite: composite from composite port or svideo port.
...hope that makes some sense

at least that worked for me
(i also use an svideo cable in composite mode)
dgently is offline   Reply With Quote
Old 11-15-02, 02:04 AM   #5
MadDog
Registered User
 
Join Date: Nov 2002
Location: South Africa
Posts: 9
Default

Thanks again

Where do I specify the source, I assume it goes somewhere in the XF86Config-4 file.

Please could you provide me with a sample snippet ?

Thanks in advance

Regards

MadDog
MadDog is offline   Reply With Quote
Old 11-15-02, 02:16 AM   #6
dgently
Registered User
 
Join Date: Jul 2002
Posts: 7
Default

no the source is selected in the application you use, eg. xawtv, ffmpeg, nvrec...
see the man/docs for your capture programm

(and the tv norm - pal/ntsc is also selected in the application)
dgently is offline   Reply With Quote
Old 11-15-02, 02:26 AM   #7
MadDog
Registered User
 
Join Date: Nov 2002
Location: South Africa
Posts: 9
Default

Thanks for all the help,

I will try tonight.

Regards

MadDog
MadDog is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Steam for Linux Beta Now Available News Archived News Items 0 11-06-12 05:20 PM
NVIDIA GPUs Enable Adobe Tool for Video Collaboration News Archived News Items 0 09-08-12 06:40 AM
Trying the Stereo 3D Support of the MK802 Android 4.0 Mini PC News Archived News Items 0 08-30-12 05:00 PM
Google's Linux Video Acceleration API: VAVDA News Archived News Items 0 06-01-12 05:50 AM
Mandrake Linux 9.0 (Dolphin) now available | comments? volt General Linux 10 10-19-02 10:13 PM

All times are GMT -5. The time now is 09:09 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.