Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-01-04, 02:28 PM   #1
fudd
Registered User
 
Join Date: Aug 2004
Posts: 9
Default X hangups solution - disable int10

I've had the same troubbles as many others on this board. Random X lockups.
I've tried all the suggestions I've found here, but with no luck. As many others have to.

Now it seems like my lockups are gone. What I did was to comment out
load "int10"
in the XF86config-4 config.
Seems like this module messes up some irq stuff. Also it seems like disabling it gives quite an performance boost to X to
Might just be my imagination.

Is there any reason to load int10 if I'm not running dual graphics adapters?
My old riva tnt2 adapter worked just fine with the exact same configuration that was causing crashes with the Gainward mx440.
My guess is that the int10 modules tries to reset the tv out.

Hope this helps other to.

---
My hardware config:
I have a Epox KRAI8 (KT600) and a Gainward MX440 nforce4,

From XF86config-4:
-------------------------------------------------
Section "Module"
# Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
# Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
# Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"

Section "Device"
Identifier "Generic Video Card"
Driver "nvidia"
Option "NvAGP" "1"
Option "ConnectedMonitor" "CRT"
Option "IgnoreDisplayDevices" "DFP,TV"
# Option "RenderAccel" "true"
# Option "Accel" "false"
Option "WindowFlip" "false"
Option "MetaModes" "1152x864,1280x960"

EndSection
--------------------------------------------------------------------
fudd is offline   Reply With Quote
Old 08-02-04, 07:36 AM   #2
quadfour
Registered User
 
Join Date: Mar 2004
Posts: 83
Default Re: X hangups solution - disable int10

Hate to burst the bubble... I've never had int10 module in my config. I found that upgrading to 2.6.8 kernel did the trick, or at least X hasn't locked up even once since I've upgraded
quadfour is offline   Reply With Quote
Old 08-02-04, 04:18 PM   #3
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: X hangups solution - disable int10

Hi,

while you are cleaning up, you do not need record.
energyman76b is offline   Reply With Quote
Old 08-02-04, 11:56 PM   #4
fudd
Registered User
 
Join Date: Aug 2004
Posts: 9
Default Re: X hangups solution - disable int10

what is the record module anyway? I'll try to remove it. Thanks
I tried kernel 2.6.8-rc2 but it gave me the same prooblems. Also the via-rhine eth module is broken in the rc2.
Planning on switching to xorg soon, but things seem to be stable now. Only problem I have is that tuxracer looks awful. UT2k4 works fine, though. Seems like openGL doesn't work at whatever resolution tuxracer is running. Anyone know how to change tuxracer resolution?
fudd is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Evidon and Adobe Tag Manager Privacy Solution Launches! News Archived News Items 0 05-15-12 05:30 AM

All times are GMT -5. The time now is 03:46 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.