Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-06-04, 06:53 AM   #1
fatty
Registered User
 
Join Date: Aug 2004
Posts: 3
Default FAKK2 and the new drivers

I've installed the latest drivers (6111) today.

After that I wanted to play Heavy Metal FAKK2, but all I got was an error while loading libGL.so.
While preloading the GL-library works for ut2004, fakk2 won't run.

Here's my console output:
Code:
----- Client Initialization -----
----- Initializing Renderer ----
----- R_Init -----
...loading libGL.so: SDL: SDL_GL_LoadLibrary() failed! rc == (-1).
SDL_GetError() reports "Could not load OpenGL library".
failed
...loading libMesaVoodooGL.so.3.1: SDL: SDL_GL_LoadLibrary() failed! rc == (-1).
SDL_GetError() reports "Could not load OpenGL library".
failed
----- CL_Shutdown -----
-----------------------
----- CL_Shutdown -----
-----------------------
Error: GLimp_Init() - could not load OpenGL subsystem
I don't know why this happens, but it worked with driver versions 5336 and older.
fatty is offline   Reply With Quote
Old 08-06-04, 09:39 AM   #2
kgroombr
Using Linux Since 1995
 
Join Date: Sep 2002
Posts: 130
Default Re: FAKK2 and the new drivers

I was planning on loading up FAKK2 again since I really enjoy the game. I will do it this weekend to check this issue.

The problem may be something I had with ut2004. Other games worked fine, but the ut2004 message stated that it couldn't loaded libGL.so.1

I use Gentoo and the main thing that changed between when ut2004 worked and didn't work was I just upgraded my glibc.

My fix, was to re-emerge the latest kernel headers, re-emerge the latest glibc, and reboot.

I am thinking that something happened with the previous emerge and it didn't build glibc correctly. Just a guess, but it worked for me.

Ken
__________________
Kenton A. Groombridge
kgroombr@comcast.net
http://home.comcast.net/~kgroombr/
kgroombr is offline   Reply With Quote
Old 08-06-04, 12:23 PM   #3
fatty
Registered User
 
Join Date: Aug 2004
Posts: 3
Default Re: FAKK2 and the new drivers

I've triggered the problem with LD_PRELOAD.

This environment variable was set in my FAKK2 startup script, too, so it had no effect to set it manually in the console.

After changing that behavior I was able to play again

But it's really strange, that the drivers need to be manually preloaded...
fatty is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:51 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.