Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-06-04, 06:02 PM   #1
Aristiana
Registered User
 
Join Date: Aug 2004
Posts: 5
Default Unable to install / compile

Hi!

I'm running:

AMD 2500
512 MB
GeForce FX 5200 (MSI)
Asus A7N8X
I don't have any nVidia driver installed so I don't know my BIOS revision.
Mandrake 10.0 Community
KDE 3.2.2

I'm already at runlevel 3, so I logged out of X, SUed, ran the "sh NVIDIA-Linux-x86-1.0-6111-pkg1.run" and got an error about the sources not being found.

uname -r reported 2.6.3-4.mdk, and since I haven't installed a newer version since the begining, I installed the sources RPM for this version, and the installer installed a bunch of librairies at the same time.

Tried again, this time, it requested a "make mrproper" since my sources weren't "clean". That's what I did.

Third time, my logfile doesn't even show an error. It's attached to this message.

I tried to run "make install". I got: unable to determine the target kernel version
Thinking it was unable to figure my kernel version, I tried:
"sh NVIDIA-Linux-x86-1.0-6111-pkg1.run --kernel-name='2.6.3-4mdk"' but I ended up exactly at the same point, logfile showing no error message.

Does anyone have an idea what I should try?

Thanks

Aristiana
Attached Files
File Type: txt nvidia-installer.txt (1.9 KB, 222 views)
Aristiana is offline   Reply With Quote
Old 08-06-04, 07:01 PM   #2
can|s|_ycan
Registered User
 
Join Date: Jul 2004
Posts: 12
Default Re: Unable to install / compile

Aristiana: I doubt you need to do a "make install". That will attempt to install your kernel.

I haven't used mandrake in a long time so I'm not sure how they prefer to maintain their kernel sources. I'm guessing you should try this:

su - root
cd /usr/src/linux
make mrproper
make cloneconfig
make prepare-all

Now try to compile your driver:
sh NVIDIA-Linux-x86-1.0-6111-pkg1.run --kernel-source-path=/usr/src/linux

If the nvidia script finishes without errors you can then configure your x config file. If you still have problems try uninstalling your kernel sources, then reinstall them and start this procedure again.
can|s|_ycan is offline   Reply With Quote
Old 08-07-04, 11:32 AM   #3
Aristiana
Registered User
 
Join Date: Aug 2004
Posts: 5
Default Re: Unable to install / compile

Hum, I wasn't clear.

I did "make install" in the directory where I uncompressed the file included in the "NVIDIA[...].run" file. That's where I got that error I mentionned about the target kernel version.

I tried your instruction. That's what I got:

make[1]: ***No rule to make target 'cloneconfig'. Stop.
make: ***cloneconfig error 2.

I even looked in the kernel makefile and I couldn't find the "cloneconfig".
Aristiana is offline   Reply With Quote
Old 08-07-04, 01:37 PM   #4
Albert
Registered User
 
Join Date: May 2003
Location: Antwerp, BELGIUM
Posts: 19
Default Re: Unable to install / compile

I'm having the same problem running a Mandrake kernel 2.6.3-15mdk.

I tried several options:

make mrproper
make config
make (this one goes on for a century)

I also tried reinstalling the complete kernel sources -> makes no difference
The installer still refuses to compile the module.

On former occasions I solved any kernel difficulties by adding the option:

--add-this-kernel (which gives you a 'custom.run' installer. The latter usually runs fine (on both Fedora and Mandrake)

I don't see a solution. Anyone?
__________________
Albert
Albert is offline   Reply With Quote
Old 08-08-04, 09:55 AM   #5
Antti
Registered User
 
Join Date: Aug 2004
Posts: 45
Default Re: Unable to install / compile

Same problem here, fails to compile the latest 6111-drivers on the following kernels on Mandrake 10 Community and Official:

2.6.3-4mdk
2.6.3-7mdk
2.6.3-15mdk
2.6.3-15mdksecure
2.6.7-2tmb

It just isn't compiling! 5336 and 6106 install and compile just fine. Reported this problem to nVidia.
Antti is offline   Reply With Quote
Old 08-08-04, 12:11 PM   #6
Aristiana
Registered User
 
Join Date: Aug 2004
Posts: 5
Default Re: Unable to install / compile

Well, I think I'm getting somewhere.

I did:
cp /boot/config-2.6.3-4mdk /usr/src/linux-2.6.3-4mdk/.config

Then If I was running the installer, I would get an error about the need to run "make mrproper". BUT, I also noticed my logfile was getting farther than normal! (When I first wrote this message I wasn't even getting to the rivafb sanity check).

So I decided to "make install" the driver instead of running the installer. Guess what? It worked.

So, in my "very newbie" opinion, it seems like it doesn't compile if it can't find the .config file, but when it's there it stop because it wants a "make mrproper".

Aristiana
Aristiana is offline   Reply With Quote
Old 08-08-04, 12:43 PM   #7
Aristiana
Registered User
 
Join Date: Aug 2004
Posts: 5
Default Re: Unable to install / compile

All I had to do after all this was to change XF68Config-4.

Before:
Section "Device"
Identifier "device1"
Driver "nv"
Option "DPMS"
EndSection
After:
Section "Device"
Identifier "device1"
Driver "nvidia"
Option "DPMS"
EndSection
Now it's working perfectly!

Aristiana
Aristiana is offline   Reply With Quote
Old 08-08-04, 04:07 PM   #8
Antti
Registered User
 
Join Date: Aug 2004
Posts: 45
Default Re: Unable to install / compile

It works! Thanks, Aristiana.

So here's the solution in short form:

1. Uninstall any previous drivers manually (./NVIDIA-Linux-x86-1.0-[version]-pkg1.run --uninstall).
2. Extract the driver file with command ./NVIDIA-Linux-x86-1.0-6111-pkg1.run -x
3. Make a backup of the file .config in the kernel source tree (/usr/src/linux-[version]).
4. Copy the matching config file for your kernel from /boot to replace .config in the source tree (/boot/config-[version]).
5. Start the driver installation from the folder you just extracted (./nvidia-installer). It will say it failed, but it did manage to compile the drivers. Just didn't install them...
6. ...so after "failing" the installation program, enter "make install" in the extracted driver folder.

Done!


P.S. Oh, and you might wish to recover the backup of .config back to your kernel source folder.
Antti is offline   Reply With Quote

Old 09-22-04, 11:12 PM   #9
JSD303
Registered User
 
Join Date: Sep 2004
Posts: 1
Default Re: Unable to install / compile

I followed the same steps as Antti and Aristiana. Then I run make install and it errors out.

(nvidia directory shortened to prevent carpal tunnel)


/NVIDIA-Linux..../usr/src/nv/nv-linux.h:86:75: linux/syscalls.h: No such file or directory
make[4]: *** [/NVIDIA-Linux.../usr/src/nv/nv.o] Error 1
make[3]: *** [ " /nv] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[2]: *** [module] Error 1
make[1]: *** [install] Error 2
make[1]: *** Leaving directory '/NVIDIA.../usr/src/nv'
make: *** [kernel_module_install] Error 2
#

This is running kernel 2.6.3-11mdk
AMD 3000+
NVidia 6800
Mandrake 10.0 AMD64

Last edited by JSD303; 09-22-04 at 11:22 PM.
JSD303 is offline   Reply With Quote
Old 09-23-04, 12:18 AM   #10
wolfkhan
Registered User
 
wolfkhan's Avatar
 
Join Date: Sep 2004
Location: Australia
Posts: 11
Default Re: Unable to install / compile



How does one uninstall the previous version of nvidia drivers please???

I have Suse pro 9.1 with yast updates, kernel 2.6, a Leadtek FX 5700 tdh 256mb gfx card, a Gigabyte 8ipe1000 with a 3.0 gig cpu and 1 gb ddr ram, and the nvidia driver version is 1.0-5336

My kernel version is: 2.6.5-7.108 i586 and YOU kernel -51606

My nvidia kernel is 1.0-5336

As far as I know I need to have a kernel version of 2.6.6.x???? and when I tried to
the nvidia drivers I got the relevant error that says I need this and do I want to download the driver from there and so on

I am at my wits end trying to resolve the black screen lockup on exiting from kde and so on, so would anyone mind giving me a tip on how to get rid of my old drivers and how can I get my hands on the proper kernel version to then be able to install the nvidia 1.-6111 drivers please.

Your help is most definately appreciated

Many thanks


Last edited by wolfkhan; 09-23-04 at 02:14 AM.
wolfkhan is offline   Reply With Quote
Old 09-23-04, 08:39 AM   #11
Antti
Registered User
 
Join Date: Aug 2004
Posts: 45
Default Re: Unable to install / compile

Quote:
Originally Posted by wolfkhan


How does one uninstall the previous version of nvidia drivers please???
./NVIDIA-xxx --uninstall


JSD303, try running the installer with --add-this-kernel and then run the newly created custom installation file.
Antti is offline   Reply With Quote
Old 09-23-04, 08:58 AM   #12
wolfkhan
Registered User
 
wolfkhan's Avatar
 
Join Date: Sep 2004
Location: Australia
Posts: 11
Default Re: Unable to install / compile

Many thanks will give it a go
wolfkhan is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mageia 2 Cannot Install 71.86.15 for Riva TNT/TNT2 kbulgrien NVIDIA Linux 3 06-29-12 08:27 AM
nForce + RedHat 7.3 Success Story rtz NVIDIA Linux 47 02-15-03 02:20 AM
Red Hat null(limbo beta 3), guide to install Nvidia Drivers utiel NVIDIA Linux 21 09-30-02 05:32 PM
Nvidia drivers won't compile with Slackware 8.0 z28Power NVIDIA Linux 6 09-18-02 06:20 PM
can't install old det's after 40.41's m!n!0n NVIDIA Windows Graphics Drivers 1 09-16-02 11:58 AM

All times are GMT -5. The time now is 09:18 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.