Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-23-04, 08:38 PM   #13
bannerboy
Registered User
 
bannerboy's Avatar
 
Join Date: Jul 2004
Posts: 27
Default Re: nvidia.ko will not build, no matter what I do..

OK, try messing with the power management section of your kernel configuration, I had some terrable problems installing it for me, turn power management on, and everything under it off, recompile your kernel, and then try again.
bannerboy is offline   Reply With Quote
Old 07-23-04, 09:09 PM   #14
token
Food eater
 
token's Avatar
 
Join Date: Jul 2004
Location: Rock Creek, Ohio
Posts: 10
Default Re: nvidia.ko will not build, no matter what I do..

Actually, I think the problem may have been found. VMWare seems to do something suprisingly similar.. It seems to dislike kernel.h apparently..

Anyone know where a pre-built 2.6.7 nvidia.ko can be found?

Probobly a kernel problem, but just in case this helps anyone else looking at this thread trying to find help, this is a snippet from the vmware installer..

include/linux/kernel.h:10:20: stdarg.h: No such file or directory

If I can get it working, I promise to post how for anyone out there experiencing the problem.. If no response, You can safely assume I purchased another video card

EDIT: Problem solved... Kinda..
I copied the files listed in the kernel.h file locally, and it built the module.. But... Uhhh.. The text explains it..

FATAL: Error inserting nvidia (/lib/modules/2.6.7/kernel/drivers/video/nvidia.ko): No such device
make[2]: *** [package-install] Error 1
make[1]: *** [install] Error 2
make[1]: Leaving directory `/home/token/NVIDIA-Linux-x86-1.0-6106-pkg1/usr/src/nv'
make: *** [kernel_module_install] Error 2

I'm getting closer, w00t!

Last edited by token; 07-23-04 at 09:29 PM.
token is offline   Reply With Quote
Old 07-24-04, 01:13 AM   #15
token
Food eater
 
token's Avatar
 
Join Date: Jul 2004
Location: Rock Creek, Ohio
Posts: 10
Default Re: nvidia.ko will not build, no matter what I do..

GOT IT!

First, symlink all the files that kernel.h is looking for in the include directory (the one the nvidia installer is looking at)

Then run the installer. It failed the first time, saying 'device not found'. Restart your computer. Now, you may get a 'Cannot allocate memory' error.. Simply extract the installer files, cd to [nvidia dir]/usr/src/nv. Type 'make install'. It *should* compile cleanly. To verify this, type 'modprobe nvidia'.. If it doesnt say anything, run the installer once more.. Watch it load

Hope this helps anyone who's having the same problem.. I've seen this problem in a lot of places, and hope you find some use in this
token is offline   Reply With Quote
Old 07-24-04, 01:03 PM   #16
xatmes
Registered User
 
Join Date: May 2004
Posts: 4
Default Re: nvidia.ko will not build, no matter what I do..

I know I recieved this error when I had an original gentoo build of the 4496 drivers installed, and installed the new 6106 drivers with the nvidia install program over top without really thinking. Gentoo and nvidia install the nvidia.ko module file in different directories within the /lib/modules/2.6.x/ hierarchy...you may want to check and see if you have two modules in there. It may be trying to load an older driver version.
xatmes is offline   Reply With Quote
Old 08-16-04, 07:14 PM   #17
mansuetus
Registered User
 
Join Date: Aug 2004
Posts: 2
Default Re: nvidia.ko will not build, no matter what I do..

I'm having quite the same problem, excpept dmesg speaks quite more :
"nvidia: version magic '2.6.8.1 K7 gcc-3.2' should be '2.6.8.1 K7 gcc-3.4''

the problem is : I have made my kernel just now, and nvidia too !
(I did not change GCC for the time ^^ )

$ gcc --version
gcc (GCC) 3.4.1
(...)


# uname -a
Linux mylinux 2.6.8.1 #2 Tue Aug 17 01:49:01 CEST 2004 i686 unknown
is the unknown about my GCC ? I bulit the gcc from "gcc.gnu.org" with src files... and it works since my kernel seems to do so ^^
mansuetus is offline   Reply With Quote
Old 08-17-04, 07:28 AM   #18
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: nvidia.ko will not build, no matter what I do..

What does cc -v report?
zander is offline   Reply With Quote
Old 08-17-04, 08:58 AM   #19
mansuetus
Registered User
 
Join Date: Aug 2004
Posts: 2
Default Re: nvidia.ko will not build, no matter what I do..

zander : I love you !

it reported an old gcc !

I type this from my new nvidia driver ^^

love from Paris !
mansuetus is offline   Reply With Quote
Old 08-17-04, 02:15 PM   #20
Meteoris
Registered User
 
Join Date: Aug 2004
Posts: 2
Default Re: nvidia.ko will not build, no matter what I do..

After scorching the mandrake 10.0 kernel and latest nVidia drivers I've managed (through hell and lots of swearing and sweating) to install it manualy... now I have a problem with GL libraries. Any application that touches 3D crashez my X. It just dies and reverts to console then restarts in some ... 10 - 15 seconds.
I've run through the nVidia readme and all the stuff I've found on the net and so far I don't know what to do to make 3D applications run instead of crashing the X.

I have Mandrake 10.0 with kernel 2.6.3-7mdkcustom (custom compile) with the latest nVidia drivers and GCC 3.3.2
I'd like to mention that I've read all it's been posted on this thread since that was my original problem as well. The thing with make install worked but then the sh NVIDIA...run didn't bode well with my kernel and anything I did didn't make it run so I've put the bone to work and did manualy anything that I should by reading the nVidia documentation provided with the driver (APENDIX C was not useful in making the libGL work it brought me to this situation where X crashez).

Any help for me ?

Last edited by Meteoris; 08-18-04 at 01:57 AM.
Meteoris is offline   Reply With Quote

Old 08-18-04, 02:35 AM   #21
Meteoris
Registered User
 
Join Date: Aug 2004
Posts: 2
Default Re: nvidia.ko will not build, no matter what I do..

Quote:
Originally Posted by Meteoris
After scorching the mandrake 10.0 kernel and latest nVidia drivers I've managed (through hell and lots of swearing and sweating) to install it manualy... now I have a problem with GL libraries. Any application that touches 3D crashez my X. It just dies and reverts to console then restarts in some ... 10 - 15 seconds.
I've run through the nVidia readme and all the stuff I've found on the net and so far I don't know what to do to make 3D applications run instead of crashing the X.

I have Mandrake 10.0 with kernel 2.6.3-7mdkcustom (custom compile) with the latest nVidia drivers and GCC 3.3.2
I'd like to mention that I've read all it's been posted on this thread since that was my original problem as well. The thing with make install worked but then the sh NVIDIA...run didn't bode well with my kernel and anything I did didn't make it run so I've put the bone to work and did manualy anything that I should by reading the nVidia documentation provided with the driver (APENDIX C was not useful in making the libGL work it brought me to this situation where X crashez).

Any help for me ?
Ok... I got this one.

I've used this nice script to help me and it did indeed helped me:
http://lists.debian.org/debian-devel.../msg00490.html

And I've also did this:
Quote:
Check that you have device files /dev/nvidia*:


$ ls -l /dev/nvidia*
crw-rw---- 1 root video 195, 0 Nov 10 03:59 /dev/nvidia0
crw-rw---- 1 root video 195, 1 Nov 10 03:59 /dev/nvidia1
crw-rw---- 1 root video 195, 2 Nov 10 03:59 /dev/nvidia2
crw-rw---- 1 root video 195, 3 Nov 10 03:59 /dev/nvidia3
crw-rw---- 1 root video 195, 4 Nov 10 03:59 /dev/nvidia4
crw-rw---- 1 root video 195, 5 Nov 10 03:59 /dev/nvidia5
crw-rw---- 1 root video 195, 6 Nov 10 03:59 /dev/nvidia6
crw-rw---- 1 root video 195, 7 Nov 10 03:59 /dev/nvidia7
crw-rw---- 1 root video 195, 255 Nov 10 03:59 /dev/nvidiactl
If you don't have them, then create them:

mknod /dev/nvidiactl c 195 255
for nn in 0 1 2 3 4 5 6 7 ; do
mknod /dev/nvidia$nn c 195 $nn
done
chown root.video /dev/nvidia*
chmod 0660 /dev/nvidia*
Now everything's fine with glx.

Hope this helps others with similar problems.
Meteoris is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Video: High Schoolers Build Supercomputer in Ontario News Archived News Items 0 06-01-12 12:10 PM
Diablo 3 Wizard build guide News Archived News Items 0 05-30-12 02:40 PM
Build versus buy: One company's decision to go it alone News Archived News Items 0 05-13-12 08:40 PM
Diablo 3 build guide: Barbarian, Demon Hunter, Monk, Witch Doctor and Wizard News Archived News Items 0 05-12-12 12:00 PM
My source RPM won't build right! z28Power NVIDIA Linux 5 09-18-02 11:55 AM

All times are GMT -5. The time now is 07:22 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.