Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-23-04, 03:05 AM   #1
haunted
Registered User
 
Join Date: Jul 2004
Posts: 17
Default Probable solution for "slow" cards/drivers

Hello friends,

as many have reported, the "latest drivers" seem to be slow. Sometimes, it was due to the kernel scheduler, for others it stayed. I myself had this issue, and I can say that glxgears can be a benchmark.

In the past I used: 1.0-4363, Linux 2.4 (XFree version does not matter) and I had about 800 FPS with glxgears. The card is a GF2 MX400.

Recently I had: 1.0-5336 and later 1.0-6106, Linux 2.6, and only had 100 FPS, with the same card. I was suggested to look for AGP enabled stuff and such, though even enabling it (in a forced manner) did not solve the 100 FPS issue. Games were "not quite" affected, since they did their job up to a specific framerate which was anyway so fluid that you don't know whether you have 100 or 200 fps, but in detailed maps it began to struggle.

So I detailedly investigated this issue trying all drivers with all kernels.
2.4/4363: 800
2.6/4363: ---4363 driver not 2.6-ready---
2.4/4496: 800
2.6/4496: ---4496 driver not 2.6-ready---
2.4/5336: 100
2.6/5336: 100
2.4/6106: 100
2.6/6106: 100

Thanks to #nvidia (irc.freenode.net) I got a link to http://sh.nu/nvidia/ so I could try a modified 4496 (besides that 4363, etc.) which works with 2.6. Guess what, I got by 800 fps back. Of course, this is an old driver so it works best with cards released before 4496 came out.

Hope this helps some of you :-)

(added) This is what I use now: http://www.sh.nu/download/nvidia/lin...-4496-pkg0.run

Last edited by haunted; 07-23-04 at 03:05 AM. Reason: added link
haunted is offline   Reply With Quote
Old 07-23-04, 04:00 AM   #2
Haraldbluetooth
Registered User
 
Join Date: Jul 2004
Posts: 3
Default Re: Probable solution for "slow" cards/drivers

Has anyone tried the old driver (4496) i games and got any benchmarks (UT or eqvivalent)?
Haraldbluetooth is offline   Reply With Quote
Old 07-24-04, 09:23 PM   #3
pigeon
Registered User
 
Join Date: Jul 2004
Posts: 57
Default Re: Probable solution for "slow" cards/drivers

Perhaps... just a note here...

I have the same problem with my TNT card.

I'm with 2.4 kernel, Debian stable (woody), X (4.2.1.1/4.2.1-3.bunk.10)

Thanks for putting the link for 4496. That solved the problem.
I realized the "slow" problem not only happens to 3d, but also normal drawing under X.

I really hope there's a real solution for this...

Or, is there any kernel module parameters or X options we can try?
Tried NvAGP in X options, doesn't make a difference. Those kernel module params (NVreg_*) look interesting but I have no idea what they do and they're not mentioned in the README.

Thanks.
pigeon is offline   Reply With Quote
Old 08-22-04, 08:43 AM   #4
pigeon
Registered User
 
Join Date: Jul 2004
Posts: 57
Default Re: Probable solution for "slow" cards/drivers

I just discovered that this "solution" is not really THE solution anymore.
It seems that after using XVideo for a long time, it starts to cause the slow drawing on everything again.

I'm not sure how exactly this can be recovered yet, but it's either an X restart (sometimes), or a reboot...

I tried the latest 6111 too, and it has the same slow drawing problem all the way.

Still no solution for this?
pigeon is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Evidon and Adobe Tag Manager Privacy Solution Launches! News Archived News Items 0 05-15-12 06:30 AM

All times are GMT -5. The time now is 10:35 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.