Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-04-04, 11:41 PM   #1
itsjustme
Registered User
 
itsjustme's Avatar
 
Join Date: Aug 2004
Posts: 2
Default artifacts, screen unreadable after exiting X

I have a geForce mx 420 (as shown by lspci -v) and the latest nvidia driver, 6111. The system is Slackware 10 running WindowMaker or BlackBox.

When I exit X, the screen only shows little block artifacts, dark blue, light blue, red. It's like the text has been exploded because the artifacts appear to be in 3 lines across the screen, each line takes up a wide path across the screen. And, although it is unreadable, I can restart X by 'blindly' typing in startx or I can 'blindly' type in su - and then reboot to get rid of the artifacts.

I just ran a swaret --update and --upgrade with VERSION=current and the problem persists.

Has anybody else seen this and what's the fix?

Thanks..
itsjustme is offline   Reply With Quote
Old 09-05-04, 08:25 PM   #2
RinkyDinks_RJ
Registered User
 
Join Date: Sep 2004
Posts: 1
Unhappy Re: artifacts, screen unreadable after exiting X

Yes I've gotten this too. It's like it blows up your console text by 100X. I think it's a configuration issue, as it only happened when I tried to hook up a tv to the card.

I haven't found a fix yet. I'll let you know if I do.
RinkyDinks_RJ is offline   Reply With Quote
Old 09-07-04, 07:27 PM   #3
jerickson314
Registered User
 
Join Date: May 2004
Posts: 43
Default Re: artifacts, screen unreadable after exiting X

Happens all the time. Try adding

Option "ConnectedMonitor" "CRT"
Option "IgnoreDisplayDevices" "TV"

to your XF86Config file. The second line will probably disable the TV-Out, so if you need that you may want to disable the framebuffer rather than using these options. To do that, just remove any "vga=" options from your GRUB or LILO configuration and reboot. Then the consoles will be 640x480 with no graphics support, but they work.

Unfortunately, neither fix seems to work for people using DVI cables to hook up the monitor. I use a flat panel monitor but with a standard VGA cable and both fixes work for me. I do not use the TV-Out but have noticed that I had problems on the cards I have tried with three outputs, but not the one I tried with only two.
jerickson314 is offline   Reply With Quote
Old 09-07-04, 07:55 PM   #4
unknownprogramm
Registered User
 
Join Date: Sep 2004
Posts: 4
Default Re: artifacts, screen unreadable after exiting X

I have this problem too...and trying to get tv-out to work...I get interference on the right half of the screen...and a buzzing noise when i plug the s-video cable into the computer (power on or off doesn't matter)
unknownprogramm is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
RHEL 5.6 .nvidia-settings-rc settings un-applied on screen lock bluziff NVIDIA Linux 1 06-14-12 05:12 AM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 04:40 PM
Stubborn screen res problem Alpsoandso NVIDIA Linux 6 05-03-12 06:00 PM
Toshiba Sat 1950 screen setup beaulieu NVIDIA Linux 7 06-13-03 03:17 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM

All times are GMT -5. The time now is 10:01 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.