Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-06-04, 02:39 AM   #1
skamp
Registered User
 
Join Date: Mar 2004
Posts: 13
Unhappy Poor 3D performance compared to Windows

Hi,

Although I've successfully installed and used NVIDIA's driver for my GeForce FX5900, I get lower framerates under linux/X11 than under Windows. I get about 35 FPS in UT2004 under linux, versus about 50 under Windows; 23 FPS in DOOM 3 (timedemo demo1 usecache) under linux, vs. 41 under Windows. glxgears gives me about 6110 FPS.

Everything seems to be fine in my installation: there are no duplicates of the GL libs, X.org loads everything correctly, etc... I can't see anything wrong. So, is it just the drivers that are at fault? I'm not the only one getting such results.

Asus A7N8X Deluxe, Athlon XP 2500+, 1 GiB of DDR-SDRAM, GeForce FX5900
Distribution: LFS
Kernel: 2.6.8.1-mm4
Driver: 1.0-6111
GCC: 3.4.1
X: X11R6.8.0

Code:
cat /proc/driver/nvidia/agp/status      
Status: 	 Enabled
Driver: 	 AGPGART
AGP Rate: 	 8x
Fast Writes: 	 Disabled
SBA: 		 Enabled

cat /proc/driver/nvidia/cards/0 
Model: 		 GeForce FX 5900
IRQ:   		 10
Video BIOS: 	 04.35.20.22.00
Card Type: 	 AGP
Attached Files
File Type: txt glxinfo.txt (6.8 KB, 139 views)
File Type: txt Xorg.0.log.txt (26.3 KB, 99 views)
File Type: txt xorg.conf.txt (5.8 KB, 124 views)
skamp is offline   Reply With Quote
Old 10-06-04, 03:07 AM   #2
zeb
Registered User
 
Join Date: Apr 2003
Posts: 52
Default Re: Poor 3D performance compared to Windows

This seems specific to doom3, I see this loss of perfs with it, but I am suprised for the other games, because for me UT2004 or RTCW have the same perf than under Windows or even better.
zeb is offline   Reply With Quote
Old 10-06-04, 03:10 AM   #3
zeb
Registered User
 
Join Date: Apr 2003
Posts: 52
Default Re: Poor 3D performance compared to Windows

I am wondering if this is related to xorg. Do people with XFree 4.3 have the same issue ?
zeb is offline   Reply With Quote
Old 10-06-04, 06:18 AM   #4
skamp
Registered User
 
Join Date: Mar 2004
Posts: 13
Default Re: Poor 3D performance compared to Windows

I just installed XFree86 4.4.0 and ran Doom 3, no difference.
skamp is offline   Reply With Quote
Old 10-06-04, 06:46 AM   #5
zeb
Registered User
 
Join Date: Apr 2003
Posts: 52
Default Re: Poor 3D performance compared to Windows

Quote:
Originally Posted by skamp
I just installed XFree86 4.4.0 and ran Doom 3, no difference.
you mean, there is no difference between Linux and Windows, or you have the same problem ?
zeb is offline   Reply With Quote
Old 10-06-04, 07:30 AM   #6
dante_uk
Geforce FX5900
 
dante_uk's Avatar
 
Join Date: Aug 2002
Location: Crawley-Sussex-UK
Posts: 120
Default Re: Poor 3D performance compared to Windows

My performance is almost the same, linux is just a 1 or 2 slower.
Maybe in my case it's because I'm on GF4 4200GO (laptop).

I have a FX5900nu on my home machine but thanks to my XP partition screwing up so I had to re-install, I've lost my grub loader.
I hope to sort this out tonight and get my Linux partition back up and running again, then I've got to upgrade the vid driver to 61.11 and then I can try Doom3.
__________________
-- "I have always wished that my computer would be as easy to use as my telephone. My wish has come true. I no longer know how to use my telephone" Bjarne Stronstrup (originator of C++ programming language)

Gigabyte S478 Intel 845E / P4 2.2Ghz / 1GB DDR / GF FX 5900 128MB (400/850) / SB Live! Player 5.1 / XP Pro sp1 (DirectX9.0c) / Suse 8.2
dante_uk is offline   Reply With Quote
Old 10-06-04, 07:51 AM   #7
zeb
Registered User
 
Join Date: Apr 2003
Posts: 52
Default Re: Poor 3D performance compared to Windows

dante_uk : can you try both xorg and XFree ? There seem to be a difference, at least with Doom 3.
zeb is offline   Reply With Quote
Old 10-06-04, 08:18 AM   #8
skamp
Registered User
 
Join Date: Mar 2004
Posts: 13
Default Re: Poor 3D performance compared to Windows

Quote:
Originally Posted by zeb
you mean, there is no difference between Linux and Windows, or you have the same problem ?
No difference between X.org and XFree86, I still experience the same loss of performance compared to Windows.
skamp is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why Windows 8 could be the next Vista News Archived News Items 0 06-15-12 10:30 AM
Like XP or Vista: how will businesses treat Windows 8? News Archived News Items 0 06-06-12 09:10 AM
NVIDIA Brings 18 Years of Experience to Windows 8 News Archived News Items 0 06-03-12 06:20 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
poor kde X windows performance after restart HeadStrong NVIDIA Linux 5 08-19-02 07:17 PM

All times are GMT -5. The time now is 03:40 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.