Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-07-04, 11:54 AM   #1
Swede
Registered User
 
Join Date: Oct 2004
Posts: 2
Angry Graphics crash when changing console

My graphics used to work really great with the nvidia drivers. I have been using 2 seperate screens, one monitor and one TV-out.
But many months ago it stopped working, and as soon as I try to change console, or start a new copy of X, the screen goes black and systems halt. And I can't exit X, either it halts with black screen, or the consoletext have funny colorblocks instead.

If I don't use the Nvidia's drivers in my xconf, everything works as it should.
The computer got EXACTLY the same hardware as when it used to work.

------------------
Graphic card: Geoforce Ti 4200, with 128 MB RAM
My distro during the period: Slackware 9.0 , 9.1, 10.0
P4-2.53 GHZ, 512MB RAM.
------------------
More information about my computer is probably not necessary, since everything used to work well.

Problemshooting done: Tried 3 different versions of Slackware, both XFree and Xorg, About 10 different kernel versions, from 2.4.x to 2.6.8, tried lots of different settings in Xconfigs.

I've been fighting with this problem now for a very long time, and I'd really appreciate if anyone had solutions or any ideas to this problem.

My configuration is attached, and has never been changed since it used to work.
Attached Files
File Type: txt XF86Config.txt (4.1 KB, 176 views)
Swede is offline   Reply With Quote
Old 10-07-04, 06:09 PM   #2
jerickson314
Registered User
 
Join Date: May 2004
Posts: 43
Default Re: Graphics crash when changing console

Try adding

Option "ConnectedMonitor" "CRT"
Option "IgnoreDisplayDevices "TV"

to your config file, or disable the framebuffer by removing any "vga=" options from the GRUB or LILO configuration. These are known to fix the colorblock problems for people using monitors with a VGA cable (unfortunately not with a DVI cable), but they might not fix crashes. Since you're using TV-Out, you'll probably have to use the second option (to disable the framebuffer).

On kernel 2.4 you can use version 4363 or earlier of the drivers to fix the problem.
jerickson314 is offline   Reply With Quote
Old 10-07-04, 07:28 PM   #3
Swede
Registered User
 
Join Date: Oct 2004
Posts: 2
Default Re: Graphics crash when changing console

Thank you, kind sir. You are now officially my hero. I recompiled the 2.4.26 kernel that comes with Slackware 10, and installed Nvidia driver 4363 again. Now it all works like a dream again.

Problem solved!

Thanks mate!
Swede is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thoughts from console owners on NVIDIA's GEFORCE GRID MikeC Console World 11 05-27-12 08:43 AM

All times are GMT -5. The time now is 02:20 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.