Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-02-02, 11:38 AM   #1
Master0ne
Registered User
 
Join Date: Dec 2002
Location: Maryland
Posts: 4
Send a message via AIM to Master0ne Send a message via Yahoo to Master0ne
Post Nvidia Drivers

all the FAQ's ive read on how to install NVIDIA DRIVERS are pretty much right, but id like to add one comment for RH8.0 users, this might effect other systems aswell....


This Was Posted by STEEL1, because im lazy and dont feel like retyping everything ill just add my comments in this form /#

Step 1> Download the following from NVidia's site. (Note that the NVIDIA_kernel is the **src.rpm** rpm file and the NVIDIA_GLX is a **rpm**):
NVIDIA_kernel-1.0-3123.src.rpm
and
NVIDIA_GLX-1.0-3123.i386.rpm
/# i used NVIDIA_GLX-1.0-3123.src.rpm

Step 2> Make sure you have the kernel headers installed along with all other dev tools - these are needed along with other dependencies. The best way to ensure that you have all dependencies is to just go start menu > system settings > packages > and in the development section choose the Kernel development packge and install the whole thing.

Step 3> In a gnome terminal window do a "rpmbuild --rebuild NVIDIA_kernel-1.0-3123.src.rpm" to create drivers for the RH 8.0 kernel. (This will create the binary RPM in "/usr/src/redhat/RPMS/i386/NVIDIA_kernel-1.0-3123.i386.rpm")
/# i did everything in console without X running
/# for my i686 archetecture i had to use these lines
/# rpmbuild --rebuild NVIDIA_kernel-1.0-3123.src.rpm --target=i686
/#(This will create the binary RPM in "/usr/src/redhat/RPMS/i686/NVIDIA_kernel-1.0-3123.i386.rpm")
/# i also had to rpmbuild --rebuild NVIDIA_GLX-1.0-3123.src.rpm --target=i686
/# this will also be in /usr/src/redhat/RPMS/i686/
Confirm this.

Note: "rpm --rebuild" does not work with newer versions of rpm so use "rpmbuild --rebuild".
Also do the rebuild in "X" in a gnome terminal. I dont know why but I had problems doing the rebuild and especially installing the kernel on command line. when I did this in a Gnome terminal in a runing Xserver it works fine. So do it in a gnome terminal.

STEP 4> Installed this new (NVIDIA_kernel-1.0-3123.i386.rpm)
"rpm -ivh /usr/src/redhat/RPMS/i386/NVIDIA_kernel-1.0-3123.i386.rpm"
/# i had to change filenames for my archeture NVIDIA_kernel-1.0-3123.i686.rpm

Note: It is important that you do this step also in a gnome terminal in a xserver session and not on command line. When doing through a command line the rpm install hanged and did not complete, I had to restart my computer. (I dont know why). But it works great in a terminal window in gnome and completes fine.
The rpm after installation may complain that the nvidia_kernel is export tainted. This is OK ignore it. To read more on export tained and what it means:
http://www.tux.org/lkml/#export-tainted

/# I did everything in CONSOLE (because my drivers wernt working ;-) seemd to work fine in console...)

Step 5>Now log out of gnome and go to the command line. Install the GLX (NVIDIA_GLX-1.0-3123.i386.rpm)
"rpm -ivh NVIDIA_GLX-1.0-3123.i386.rpm"
/# i had to change filenames for my archeture NVIDIA_GLX-1.0-3123.i686.rpm

Note: I did this on the command line outside of gnome and it works so just do it guys the same way :-)

Step 6> Edit the /etc/X11/XF86Config file and make a backup copy of the original:

- Remove the Load "dri" line.
/# i did not find this line Load "dri" line
- Change the Driver line from "nv" to "nvidia"
/#this is IMPORTNANT

Happy UT2003 playing.......
I am so so happy. Hope this helps you guys. Its working yeah !!!
Master0ne is offline   Reply With Quote
Old 12-09-02, 08:49 PM   #2
bjchenxu
Registered User
 
Join Date: Dec 2002
Posts: 1
Default 3d acceration?

your instruction is great!

But my quesiton is:
after the new driver works fine, why my 3d acceration is still grayed out, how to make it active
bjchenxu is offline   Reply With Quote
Old 12-10-02, 08:21 AM   #3
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default Re: 3d acceration?

Quote:
Originally posted by bjchenxu
after the new driver works fine, why my 3d acceration is still grayed out, how to make it active
Because your wonderful little GUI program that displays that checkbox doesn't understand how the nVidia drivers work. So it can't enable 3D for them -- it doesn't know how. So it grays out the checkbox. You do have 3D, in spite of what that program says.

If you want to make sure, then instead of running whatever program that is, just run a glxinfo and look for "direct rendering: Yes" in the output. If that's there, then you have 3D.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Nvidia GeForce 310.54 Beta Drivers are Now Available News Archived News Items 0 11-12-12 06:20 PM
vdpau issues with openSUSE 12.2 x86_64 and nvidia 304.43 drivers frispete NVIDIA Linux 0 09-29-12 04:41 PM
NVIDIA Drivers Receive Windows 8 Certification News Archived News Items 0 06-01-12 05:30 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
NVIDIA 2960 Drivers & RH 7.3 W/2.4.18-5 XASCompuGuy NVIDIA Linux 6 08-02-02 11:53 AM

All times are GMT -5. The time now is 02:53 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.