Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-08-02, 12:34 PM   #1
ploum
Registered User
 
Join Date: Dec 2002
Posts: 8
Unhappy nvidia drivers freeze screen when coming back from console

Hi,

I'm now under debian woody 3.0 for 3 weeks. My duron 800 with a GeForce 2 MX was worked perfectly with nv oss drivers. (I don"t use any games or GL apps for the moment)

I thought that it's interresting to install nvidia drivers, in case I had time to play some games after my exams, but it's really unusable ! ! ! !

My kernel is a self-made 2.4.20 and I have somes (bigs !) troubles with nvidia drivers :

- an awful splashscreen (can I bypass this ?)
- A double-pink cursor in console (instead of the regular white block !)
-A very hard crash when returning from console.

The first point is not really significant, but the third is the worste !
When I'm under console (with my twins pink cursors, beautiful and "different" but not easy to use) and I press alt+F7 to come back to X, my screen freeze with white, grey and blacks lines. It seems that computer is still working, but not screen at all ! (even if I try a console)
I just have to push ctrl+alt+del !

What do you think it's wrong with my configuration ? I use XFree 4 and I recently updated it without any changes...
__________________
Take a look on http://napul.be.tf
ploum is offline   Reply With Quote
Old 12-08-02, 04:21 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

You can bypass the splash screen by adding an Option "NoLogo" "true" in your XF86Config(-4) file. But that's detailed in the README.

For the other problem, when you configured that kernel, did you disable rivafb (Console drivers / Framebuffer support / nVidia Riva support inside menuconfig)? You can't use rivafb and the nVidia drivers at the same time -- if you want a framebuffer console, you have to use vesafb (Console drivers / Framebuffer support / VESA VGA graphics console) instead. Don't worry, it works at least up to 1280x1024 (mode number 794).
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 12-09-02, 02:48 AM   #3
ploum
Registered User
 
Join Date: Dec 2002
Posts: 8
Default

you are right ! I have framebuffer with the gforce driver ! ! I will try what you say (oh no, another kernel compile ! ! !) many thanks for help, I was looking on forums and faqs without finding any answer !
__________________
Take a look on http://napul.be.tf
ploum is offline   Reply With Quote
Old 12-10-02, 12:35 PM   #4
ploum
Registered User
 
Join Date: Dec 2002
Posts: 8
Talking

It works great ! thank you ! But now, I can't have mplayer playing in fullscreen... do you think it's rekated ?
__________________
Take a look on http://napul.be.tf
ploum is offline   Reply With Quote
Old 12-10-02, 02:51 PM   #5
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

I don't know much about mplayer, so I don't have any idea if it's related.

I do use mplayer, but only in X, at normal (i.e. 100% of original, not fullscreen) size. It works fine for me with that setup (fullscreen is too scaled-up; even with bilinear filtering, it looks non-crisp to me).

Are you running mplayer in X? What -vo option are you using (it's either in the config file, or specified by you on the command line)? You could try -vo xv, or (maybe) -vo gl / -vo gl2.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 12-10-02, 03:35 PM   #6
ploum
Registered User
 
Join Date: Dec 2002
Posts: 8
Talking

Thx a lot !

Once again, you are right ! I simply must set vo=xv (it was on vo=x11)

I don't know which is better, but it's really good in xv !


Do you have to enable bilinear filtering ?

You really help me a lot for those problems... Many thanx ! I try to help people too ...
__________________
Take a look on http://napul.be.tf
ploum is offline   Reply With Quote
Old 12-10-02, 04:47 PM   #7
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

I haven't seen anywhere to enable it, but if, when you enlarge the picture (to like 2x or even larger), slanted lines look like stairsteps instead of straight lines, then it's probably not enabled. I don't know how to turn it on or off, though -- I'm just fairly sure it exists.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adobe Flash full screen mode doesn't work in Google Chrome 23 with NVIDIA drivers artem NVIDIA Linux 1 11-16-12 03:24 PM
New Nvidia GeForce 310.54 Beta Drivers are Now Available News Archived News Items 0 11-12-12 06:20 PM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
Splash Screen then back to console jsc230 NVIDIA Linux 1 08-17-02 01:54 PM
NVIDIA 2960 Drivers & RH 7.3 W/2.4.18-5 XASCompuGuy NVIDIA Linux 6 08-02-02 11:53 AM

All times are GMT -5. The time now is 04:59 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.