Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-12-02, 03:59 PM   #1
Aristotle
Registered User
 
Join Date: Dec 2002
Posts: 2
Default GLX Not Working after clean install??

Just downloaded and installed to a RH 80 machine, Althon 1400, Asus V7100, GeForce 2 MX card.

from console, no X, I ran

rpm --rebuild NVIDIA_kernel-1.0-4191.src.rpm

rpm -ivh NVIDIA_kernel.-1.0-4191.i386.rpm

rpm -ivh NVIDIA_GLX.1.0-4191.i386rpm

So far so good.

Changed XF86Config (no XF86Config-4) to use "nvidia" instead of "nv"

commented out "load dri"

X will start but clearly no GLX. Tux fails with

"couldnt find matching GLX visual"

and glxinfo gives

"couldnt find RGB GLX visual"


Any help would really be appreciated and heres my XF86Config.






# File generated by anaconda.

Section "ServerLayout"
Identifier "Anaconda Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
#

InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# The location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

RgbPath "/usr/X11R6/lib/X11/rgb"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

FontPath "unix/:7100"

EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
#Load "dri"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"

# Option "AutoRepeat" "500 5"

# when using XQUEUE, comment out the above line, and uncomment the
# following line
# Option "Protocol" "Xqueue"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
#Option "XkbVariant" ""
#Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

#


Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 31-115
VertRefresh 50-160
Option "dpms"

# 1800x1440 @ 64Hz, 96.15 kHz hsync
ModeLine "1800X1440" 230 1800 1896 2088 2392 1440 1441 1444 1490 +HSync +VSync

# 1800x1440 @ 70Hz, 104.52 kHz hsync
ModeLine "1800X1440" 250 1800 1896 2088 2392 1440 1441 1444 1490 +HSync +VSync


EndSection

Section "Device"
# no known options
Identifier "NVIDIA GeForce 2 MX (generic)"
#Driver "nv"
Driver "nvidia"
VendorName "NVIDIA GeForce 2 MX (generic)"
BoardName "NVIDIA GeForce 2 MX (generic)"

#BusID
EndSection

Section "Screen"
Identifier "Screen0"
Device "NVIDIA GeForce 2 MX (generic)"
Monitor "Monitor0"
DefaultDepth 15

Subsection "Display"
Depth 15
Modes "1800X1440" "1600x1200" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubsection
Option "IgnoreEDID" "1"
EndSection

Section "DRI"
Mode 0666
EndSection
Aristotle is offline   Reply With Quote
Old 12-12-02, 04:35 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

It is possible that you're seeing what I am (problems with libGLcore), but I think checking your X log to make sure would be a good idea.

Anyway, post it (/var/log/XFree86.0.log) as an attachment. Chances are that it will have something about why it failed to load the glx module, and that should give a good idea of where to go from here.

EDIT: never mind, the problem might be that you're in 15-bit color. See if setting both the 15's (in the Screen section) to either 16 or 24 helps.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 12-12-02, 05:16 PM   #3
Aristotle
Registered User
 
Join Date: Dec 2002
Posts: 2
Default YEAH!!! Working Now

That was it!!! Changed to 16 bit and works great now. glxgears gives me over 1600fps at default size and still 80fps at full screen, 1800x1440. Cool
Aristotle is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
The Windows 8 upgrade install experience News Archived News Items 0 10-25-12 01:10 PM
Mageia 2 Cannot Install 71.86.15 for Riva TNT/TNT2 kbulgrien NVIDIA Linux 3 06-29-12 08:27 AM
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM
nForce + RedHat 7.3 Success Story rtz NVIDIA Linux 47 02-15-03 02:20 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM

All times are GMT -5. The time now is 03:57 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.