Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-12-02, 11:40 PM   #1
LinHack
Registered User
 
Join Date: Dec 2002
Location: PA
Posts: 4
Send a message via AIM to LinHack
Question Resolution Problem

Have a computer with a 433MHz Pentium II, running a 64MB GF4 MX420 and installed the RedHat 8.0 video drivers to replace the sloppy vesa driver. I was running 1600x1200 with the vesa driver, but now with the nvidia driver loaded, I can only run a max of 1024x768 which is very odd to me...What could be wrong?

Thank you in advance for any help.
LinHack is offline   Reply With Quote
Old 12-13-02, 12:35 PM   #2
sanat
Registered User
 
Join Date: Aug 2002
Posts: 17
Default

Probably your XF86Config file.
sanat is offline   Reply With Quote
Old 12-13-02, 12:57 PM   #3
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

LinHack:

Can you please post your /var/log/XFree86.0.log file?

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 12-13-02, 01:17 PM   #4
azazello
Registered User
 
azazello's Avatar
 
Join Date: Dec 2002
Location: Kiev, UA
Posts: 10
Send a message via ICQ to azazello
Default

probably EDID/DDC settings from your monitor?
azazello is offline   Reply With Quote
Old 12-13-02, 02:37 PM   #5
LinHack
Registered User
 
Join Date: Dec 2002
Location: PA
Posts: 4
Send a message via AIM to LinHack
Post RE: Post Log files

I have a XFree86.0.log and an XFree86.1.log file, so I will attach them both

Here is the XFree86.0.log
Attached Files
File Type: txt xfree86.0.log.txt (23.7 KB, 104 views)
LinHack is offline   Reply With Quote
Old 12-13-02, 02:38 PM   #6
LinHack
Registered User
 
Join Date: Dec 2002
Location: PA
Posts: 4
Send a message via AIM to LinHack
Post XFree86.1.log

And the XFree86.1.log file
Attached Files
File Type: txt xfree86.1.log.txt (23.8 KB, 115 views)
LinHack is offline   Reply With Quote
Old 12-13-02, 02:54 PM   #7
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Your HorizSync and VertRefresh values are very conservative. This is causing X to throw out the modes, as an appropriate modeline doesn't exist for those resolutions. It probably worked with the vesa driver because the mode checks are far less stringent. You should update your HorizSync and VertRefresh values to ones appropriate for your monitor.

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 12-13-02, 02:59 PM   #8
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

From the .0.log file:

Quote:
(II) NVIDIA(0): Monitor0: Using hsync range of 31.50-48.50 kHz
(II) NVIDIA(0): Monitor0: Using vrefresh range of 50.00-70.00 Hz
The hsync seems a bit low. From the hsync/vsync settings, the maximal resolution you will be able to get (which will run at 50Hz) is 48500/50, or 970 lines. At 60 Hz, this turns into 48500/60 = 808 lines.

hsync = (vert_res) * vsync

So vert_res = hsync/vsync

hsync is in kHz, and vsync is in Hz, so you have to multiply the hsync by 1000 to get them into the same units.

If you raise your HorizSync range (to what your monitor's documentation says it should be), you will be able to use higher resolutions. If all else fails and you can't find documentation on the proper horizontal refresh rate range, just set it to e.g. 31.5-80, and let the monitor DDC / EDID probing cut that range down to what the monitor can handle. However, you CAN'T use the Option "IgnoreEDID", or you stand a good chance of killing your monitor.

EDIT: beaten! Rats!
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote

Old 12-13-02, 03:01 PM   #9
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Wow... I beat bwkaz to a post!

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 12-13-02, 05:23 PM   #10
LinHack
Registered User
 
Join Date: Dec 2002
Location: PA
Posts: 4
Send a message via AIM to LinHack
Thumbs up Mad props

I must say thank you. I never even realized my sync values were so narrow. Thank you both for pointing this out to me. My problems are solved and I am now running 1600x1200 at 24-bit color.
LinHack is offline   Reply With Quote
Old 12-13-02, 05:41 PM   #11
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Quote:
Originally posted by Andy Mecham
Wow... I beat bwkaz to a post!
Heh heh.

Only because I was going into detail on it, though...

Glad the problem got solved, in any case, of course.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
The Nvidia GeForce GTX 650 Ti GPU is Out Now, Great for 720p S3D News Archived News Items 0 10-09-12 09:40 AM
Uploading 3D Videos to YouTube Easier, but Not Entirely Problem Free News Archived News Items 0 07-04-12 06:30 PM
HDMI overscan fix for multiple resolutions + Zod Engine Problem. cheechr1 NVIDIA Linux 0 06-11-12 02:27 PM
30.82 and 40.41 resolution + monitor OSD. Max3D NVIDIA Windows Graphics Drivers 2 09-05-02 02:15 AM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 10:58 AM

All times are GMT -5. The time now is 03:51 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.