Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-15-04, 11:40 AM   #1
lucat
Registered User
 
Join Date: Dec 2004
Posts: 7
Default GeForce2 MX and American Army game problem...

Hello,
i'm having a problem with American Army 2.2.1
If i try to run it sometimes i get this error message:
extension "XiG-SUNDRY-NONSTANDARD" missing on display 0.0
and some other times X simply crashes and restarts.

Other 3D games and apps work just fine (FreedroidRPG, ArmageTron, 3DDesktop, ...)

Any idea? Btw, if i run 3DDesktop sometimes when i switch from X to text mode and viceversa X hangs and must be terminated using a different terminal. Is this normal?

This is my system:
OS: Mandrake Linux 10.1 (Kernel 2.6.8.1-12mdk)
RAM: 512MByte
Graphic Card: GeForce2 MX (or MX400 i don't really remember)
Driver: Nvidia 6111

This is the output of lspci:
00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 AGP]
00:0b.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 50)
00:0b.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 50)
00:0b.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 51)
00:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:0f.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 02)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8233A ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 23)
00:11.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 23)
00:13.0 RAID bus controller: Triones Technologies, Inc. HPT366/368/370/370A/372 (rev 05)
01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2)


These are the results of glxgears:
1434 frames in 5.0 seconds = 286.800 FPS
1540 frames in 5.0 seconds = 308.000 FPS
1540 frames in 5.0 seconds = 308.000 FPS
1540 frames in 5.0 seconds = 308.000 FPS
1540 frames in 5.0 seconds = 308.000 FPS


This is the output of glxinfo:
name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: NVIDIA Corporation
server glx version string: 1.3
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method,
GLX_OML_sync_control, GLX_SGI_make_current_read, GLX_SGI_swap_control,
GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
GLX_SGIX_visual_select_group
GLX extensions:
GLX_ARB_get_proc_address, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_SGI_swap_control, GLX_SGI_video_sync, GLX_SGIX_fbconfig
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce2 MX/AGP/SSE/3DNOW!
OpenGL version string: 1.2 (1.5.1 NVIDIA 61.11)
OpenGL extensions:
GL_EXT_texture_object, GL_ARB_multitexture, GL_EXT_vertex_array,
GL_EXT_multi_draw_arrays, GL_ARB_point_parameters,
GL_EXT_draw_range_elements, GL_EXT_blend_color, GL_EXT_secondary_color,
GL_EXT_fog_coord, GL_EXT_blend_minmax, GL_ARB_window_pos, GL_ARB_imaging
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x21 24 tc 0 32 0 r y . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x22 24 dc 0 32 0 r y . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x23 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x24 24 tc 0 32 0 r . . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x25 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x26 24 tc 0 32 0 r y . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x27 24 tc 0 32 0 r y . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x28 24 tc 0 32 0 r . . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x29 24 tc 0 32 0 r . . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x2a 24 tc 0 32 0 r y . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x2b 24 tc 0 32 0 r y . 8 8 8 8 0 0 0 16 16 16 16 0 0 None
0x2c 24 tc 0 32 0 r . . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x2d 24 tc 0 32 0 r . . 8 8 8 8 0 0 0 16 16 16 16 0 0 None
0x2e 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x2f 24 dc 0 32 0 r . . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x30 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x31 24 dc 0 32 0 r y . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x32 24 dc 0 32 0 r y . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x33 24 dc 0 32 0 r . . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x34 24 dc 0 32 0 r . . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x35 24 dc 0 32 0 r y . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x36 24 dc 0 32 0 r y . 8 8 8 8 0 0 0 16 16 16 16 0 0 None
0x37 24 dc 0 32 0 r . . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x38 24 dc 0 32 0 r . . 8 8 8 8 0 0 0 16 16 16 16 0 0 None


This is my xorg.conf file:
Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "1280x1024 @ 76 Hz"
HorizSync 31.5-82
VertRefresh 50-90
Gamma 1.60 1.60 1.60

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# Dell D800 and few Inspiron (16/10) 1280x800
ModeLine "1280x800" 147.89 1280 1376 1512 1744 800 801 804 848

# Dell D800 and few Inspiron (16/10) 1680x1050
ModeLine "1680x1050" 214.51 1680 1800 1984 2288 1050 1051 1054 1103

# Dell D800 and few Inspiron (16/10) 1920x1200
ModeLine "1920x1200" 230 1920 1936 2096 2528 1200 1201 1204 1250 +HSync +VSync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corp."
BoardName "NVIDIA GeForce2 DDR (generic)"
Driver "nvidia"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 15
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 16
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 24
Virtual 1280 1024
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection



Thank you,
Luca
lucat is offline   Reply With Quote
Old 12-15-04, 11:54 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: GeForce2 MX and American Army game problem...

Your NVIDIA driver installation seems to have been altered or is incomplete, glxinfo picks up Mesa instead of NVIDIA's libGL.
zander is offline   Reply With Quote
Old 12-15-04, 11:58 AM   #3
lucat
Registered User
 
Join Date: Dec 2004
Posts: 7
Default Re: GeForce2 MX and American Army game problem...

How do you suggest to proceed to repair to this problem?

Thank you,
Luca
lucat is offline   Reply With Quote
Old 12-15-04, 12:23 PM   #4
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: GeForce2 MX and American Army game problem...

Make sure any distribution provided Mesa/NVIDIA/OpenGL packages are uninstalled, then reinstall 1.0-6111 (or 1.0-6629). You will still see the XiG-SUNDRY-NONSTANDARD error, but it's harmless.
zander is offline   Reply With Quote
Old 12-15-04, 12:33 PM   #5
lucat
Registered User
 
Join Date: Dec 2004
Posts: 7
Default Re: GeForce2 MX and American Army game problem...

I installed the new nvidia driver a couple of times and now the game works fine. Also any "MESA" reference disappeared from glxinfo.

So now everything works.

Thank you,
Luca
lucat is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:54 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.