Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-19-04, 09:08 PM   #1
BoltAction
Mostly Harmless
 
BoltAction's Avatar
 
Join Date: Nov 2004
Location: America
Posts: 17
Send a message via AIM to BoltAction Send a message via MSN to BoltAction
Default Problem with 1.0-6629 drivers and Slackware 10

I can't seem to get KDE to start after I install these drivers. The installer says that it installed successfully and when I change the "driver 'vesa'" line to "driver 'nvidia'" (I also made sure that Load "glx" was there and that Load "dri" and Load "GLcore" were disabled) then restart X, it says that it can't find the nvidia module and no drivers were found. Any help is appreciated.
__________________
"Forty-two" -Deep Thought
http://www.thecosmotron.com/

Registered Linux User #358572
BoltAction is offline   Reply With Quote
Old 12-19-04, 11:50 PM   #2
borgzilla
Linux Assimilator
 
Join Date: Aug 2002
Location: Scottsdale, AZ
Posts: 72
Default Re: Problem with 1.0-6629 drivers and Slackware 10

Type modprobe nvidia then startx
borgzilla is offline   Reply With Quote
Old 12-20-04, 03:06 PM   #3
BoltAction
Mostly Harmless
 
BoltAction's Avatar
 
Join Date: Nov 2004
Location: America
Posts: 17
Send a message via AIM to BoltAction Send a message via MSN to BoltAction
Default Re: Problem with 1.0-6629 drivers and Slackware 10

Hum, it said:

modprobe: can't located module nvidia

Perhaps it didn't install correctly. Any suggestions?
__________________
"Forty-two" -Deep Thought
http://www.thecosmotron.com/

Registered Linux User #358572
BoltAction is offline   Reply With Quote
Old 12-20-04, 09:14 PM   #4
borgzilla
Linux Assimilator
 
Join Date: Aug 2002
Location: Scottsdale, AZ
Posts: 72
Default Re: Problem with 1.0-6629 drivers and Slackware 10

Post error logs and xorg.conf files here. What kernel version are you running?
borgzilla is offline   Reply With Quote
Old 12-21-04, 12:28 PM   #5
jhackl
Registered User
 
Join Date: Dec 2004
Posts: 2
Default Re: Problem with 1.0-6629 drivers and Slackware 10

Would it be appropriate for me to tuck my problem into this thread as well instead of creating a new thread?

I am getting about the same errors that BrendaEM and Laktose were getting in the "1.0-6629 for Linux x86 released" thread. I am running Slackware 10.0 (only using udev from current) and I have recently compiled the 2.6.9 kernel (I am not sure what rc and bk level I am using, as I downloaded the source three weeks ago). The installer, when invoked with

sh NVIDIA-Linux-x86-1.0-6629-pkg1.run --kernel-name=`uname -r`

with and without --force-tls=new, both seem to work fine, as the attached nvidia-installer.log appear to me. However, 'modprobe nvidia' with and without -f returns:
FATAL: Error inserting nvidia (/lib/modules/2.6.9/kernel/drivers/video/nvidia.ko): Unknown symbol in module, or unknown parameter (see dmesg)

with dmesg repeatedly complaining about:

nvidia: module license 'NVIDIA' taints kernel.
nvidia: Unknown symbol page_address

All of these errors show up in /var/log/messages and /var/log/syslog as well. syslog also complains about version magic:

nvidia: no version magic, tainting kernel

Is this as simple to fix as following the exact steps here?:
http://www.nvnews.net/vbulletin/show...0&postcount=64

I kept the 2.4.26 kernel I had before and have had similar problems installing this driver on it.

Thanks for your help.
Attached Files
File Type: txt nvidia-installer.txt (17.8 KB, 124 views)
jhackl is offline   Reply With Quote
Old 12-21-04, 01:35 PM   #6
borgzilla
Linux Assimilator
 
Join Date: Aug 2002
Location: Scottsdale, AZ
Posts: 72
Default Re: Problem with 1.0-6629 drivers and Slackware 10

Bad news my friend. Nvidia drivers don't work with slackware 2.6.9 in most cases and that's why I'm running fedora core 3 now. I spent weeks searching for solution and nothing could help so I moved to FC3. I'll give slackware 11 another shot tho.
borgzilla is offline   Reply With Quote
Old 12-21-04, 02:13 PM   #7
jhackl
Registered User
 
Join Date: Dec 2004
Posts: 2
Default Re: Problem with 1.0-6629 drivers and Slackware 10

hmmmm.....that's life I guess (I don't strictly need accelerated 3D graphics right this second, but it would be, as always, great to have).

Going through the motions on 2.4.26 yields a tainted module that gets loaded anyway (modprobe returns warnings, lsmod shows nvidia), all manner of color garbage (root window color changes as an open mozilla is raised and lowered, etc.) and the only openGL program I have right now (noeGNUd) claims that openGL is configured correctly, but "Failed to create primary rendering surface."

Ok, that same sticky thread mentioned a patch for the 2.6.10 kernel. Has anyone had any luck with that? I won't pester further if these difficulties are due to very specific problems with gcc and glibc as they appear in Slackware 10.0 and current.

Thanks again.
jhackl is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia drivers won't compile with Slackware 8.0 z28Power NVIDIA Linux 6 09-18-02 06:20 PM
nvidia drivers and slackware 9.0 pbrennen NVIDIA Linux 5 09-16-02 06:57 AM

All times are GMT -5. The time now is 05:20 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.