Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-14-02, 11:36 AM   #1
EdHunter
Registered User
 
Join Date: Dec 2002
Location: Portugal
Posts: 2
Exclamation RedHat Kernel/nVidia Drivers HELP!!!

Hi everyone, this is my first post here!!!

I have 2 questions and 1 BIG problem:

1st Q------------------------------
Why RedHat7.X/8.X nVidia Kernel driver is UPgrade??? Where is the "full" version??? (or that "up" doesn't realy mean Upgrade?!)
-------------------------------------

2nd Q------------------------------
Why when we remove ALL nVidia RPM packages from system, nvidia.o module dissapears?!? And installing nVidia Kernel/GLX drivers again don't fix this???
-------------------------------------

Problem---------------------------
I'm using RH7.3 (kernel 2.4.14-3) and nVidia drivers are updated and working just fine!!!

I donwloaded a pre-compiled kernel from RH8.0 (kernel 2.4.14-13 Athlon version) and when I try to upgrade the kernel by installing this new kernel version, when I boot, I can't get Xserver to start!!!
The screen gets flashing, and when it stops give this message:
"INIT: Id "x" respawning too fast: disabled for 5 minutes"

I did some net research, and they say that I must start Linux in level 3 - Text Multiuser Mode (/etc/inittab), and then configure my graphic Drivers...

My question is: Why nVidia Drivers get de-configured (broken) after an kernel update???

I can't fix this!!! I can't run Xserver anymore, not even by installing nVidia drivers again...
-------------------------------------

Thanks In Advance!!!
EdHunter is offline   Reply With Quote
Old 12-14-02, 12:16 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

For your first question, the "up" in the driver is UniProcessor, not upgrade. It's "up" as opposed to "smp", which some people have, and which requires a different kernel configuration -- and therefore a different nvidia.o kernel module.

For your second question, when you upgrade your kernel, the modules are looked for in a different place. No matter which kernel you're running, the modules will be under /lib/modules/<that kernel's version>/ somewhere. The thing is, the <that kernel's version> part changes when you upgrade your kernel.

When you install a prebuilt nVidia RPM package, it puts the nvidia.o module in the directory that matches the kernel that that specific RPM was built for. That's also part of the reason why there are different RPMs for different kernels. But if the directory it puts the nvidia.o module in doesn't match your running kernel version, then you won't be able to modprobe nvidia -- which is most likely the problem you're seeing with "init: x: respawning too fast". That's actually really not the right error message (the right one would not be generated by init, but rather by X itself, in the /var/log/XFree86.0.log file), but I'm pretty sure it doesn't matter.

Boot to your old kernel, and make sure the nVidia kernel and GLX packages are installed (the ones that worked before you did your upgrade thingy). Then, load the 4191 driver page, and download the NVchooser shell script. Then, reboot back into your upgraded kernel (runlevel 3, like you did before), and run the script (with sh NVchooser.sh). What does it tell you to install?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 12-14-02, 12:42 PM   #3
DarkLLord
Registered User
 
Join Date: Jul 2002
Posts: 19
Default

I think the up means up to version 8.0

anyway, just ignore it and choose the one that suits your system

You can also download the source rpm and do a
rpm --rebuild filename
(it might also be rpmbuild)

and install the newly compiled file (found in /usr/src/redhat/$(uname -r)/filename

the NVdriver kernel module is part of the NVIDIA_kernel package. In fact, that's all the package contains

The NVIDIA_GLX package contains the libraries needed by opengl-programs (comprable to dll files in windows)

so if you want it to work you MUST install both packages


have used the nvidia driver before ?!?

if not, you are very likely still using the standard XFree driver (I would guess)

once it says it's respawning too fast, press
CTRL+ALT+F1
if you do not change the terminal (a different window shoudl appear) try F2 to F9 or so instead of F1

If it works, you should see something like
... login:

type in your username (case sensitive)
and when prompted the password

now you should have a shell

now, you can install the packages just as if using a xterm

choose a texteditor (I prefer joe) and edit your
"XF86Config" found in either
/etc
/etc/X11
usr/X11R6/lib/X11/

go thorugh it from to to bottom and DO NOT try to understand, if you have not done this before or read the manual, just go through it

in section "Module"
disable dri (just write a # in front of the whole line)
disable GLcore

in section "Device"
change nv/vesa or whatever there is specified as Driver, change it to nvidia

save the file (in joe CTRL+k d)

if you installed BOTH packages and optimized your XFreeConfig, the X-server should start the next time (after 5min of after reboot)

If not, change to a console, start x manually (startx) and log the output (startx 2> filename) to file, copy the file to disk or a windows partition
(cp src dest) and attach it so we can help ypu better
__________________
DarkLLord
DarkLLord is offline   Reply With Quote
Old 12-14-02, 06:23 PM   #4
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Quote:
Originally posted by DarkLLord
If not, change to a console, start x manually (startx) and log the output (startx 2> filename) to file, copy the file to disk or a windows partition (cp src dest) and attach it so we can help ypu better
You can do that, but anything that will be logged to "filename" using that method will also be logged to /var/log/XFree86.0.log. And sometimes, stuff gets into XFree86.0.log tht doesn't get printed out, but is still important. So copying /var/log/XFree86.0.log to a disk or Win partition would work at least as well, and might be better.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 12-15-02, 10:11 AM   #5
DarkLLord
Registered User
 
Join Date: Jul 2002
Posts: 19
Default

Did know that

Thanks
__________________
DarkLLord
DarkLLord is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Creative drivers ? SparrowHawk General Hardware 39 11-18-02 09:03 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 10:31 PM
NVidia Drivers HowTo for RedHat 8.0 needed eduardp NVIDIA Linux 10 10-04-02 04:59 AM
Redhat 7.3 + Nvidia drivers 3123 = troubles e-r-a-n NVIDIA Linux 4 09-17-02 01:26 PM
2960 drivers, redhat 7.3, kernel normanpang NVIDIA Linux 6 08-03-02 01:11 AM

All times are GMT -5. The time now is 06:40 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.