Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-23-04, 10:15 AM   #1
Demolution
Registered User
 
Join Date: Dec 2004
Posts: 3
Default GeForce FX 5200 under Redhat Linux 9.0

Hello all,

I'm very new here and new to linux, so bare with me as I go through my problems...

My computer specs are

ASUS A7N8X-X
AMD Athlon 1800 XP+
ASUS GeForce FX 5200 (9520 Magic series)
512 DDR


Ever since I installed Redhat Linux 9.0, i've been through hell trying to set it up... mainly the video side of things.

I used the NVChooser.sh script and it told me to get the two files:
NVIDIA_GLX-1.0-3123.i386.rpm
NVIDIA_kernel-1.0-3123.src.rpm

I tried to install the NVIDIA_GLX one and the error came up with "need NVIDIA_kernel installed" or something like that, then I tried to setup the NVIDIA kernel one and the kernel one just came up with:

rpm -Uvh NVIDIA_kernel-1.0-3123.src.rpm
1:NVIDIA_kernel ########################################### [100%]

Before that it asked for a user and group called "buildmeister" I added that in and still nothing, tried to install the NVIDIA_GLX still asked for the kernel thing.

Any suggestions or know what I'm doing wrong... please reply, thanks i'm really stuck here.
Demolution is offline   Reply With Quote
Old 12-23-04, 10:24 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: GeForce FX 5200 under Redhat Linux 9.0

The 1.0-3123 driver release is ancient, please try installing 1.0-6629 (for download and installation instructions, please see http://www.nvidia.com/object/linux_d..._1.0-6629.html).
zander is offline   Reply With Quote
Old 12-23-04, 10:30 AM   #3
Demolution
Registered User
 
Join Date: Dec 2004
Posts: 3
Default Re: GeForce FX 5200 under Redhat Linux 9.0

yeah, i tried that driver... installed properly but i tried to run a game which needed at least a 3D card to play properly under linux (game was called Tux Racer) and whenever i run the game, i just doesn't run at all.
Demolution is offline   Reply With Quote
Old 12-24-04, 01:42 AM   #4
DaveH
Registered User
 
Join Date: Dec 2004
Location: Highlands Ranch, Colorado
Posts: 1
Wink Re: GeForce FX 5200 under Redhat Linux 9.0

It took some struggling to get it working on my laptop but here's how I did it. My relevant system details first:

Redhat Linux 9.0
hp pavilion zd7000 portable
3.2GHz P4 CPU with SMP/Hyperthreading
nVidia GeForce FX Go5200 on-board GPU
1440x900 resolution screen

Start by installing Red Hat Linux 9.0. For me, the only built-in RedHat driver that worked out of the box was Generic VESA. I've decided to never try second-guessing the installer again, even though I knew I had an nVidia chip. Choosing the nVidia driver over its recommendation almost caused an overwhelming energy to draw my chair forcefully through the display screen. In short, accept the one the installer picks for you. It's going to change anyway.

After getting your new system up and running, edit the /etc/inittab file and comment out the last line that runs the X server. Don't put this back until everything works perfectly or you can find yourself unable to login. If that does happen, just get out your Linux CD and start over.

After rebooting, you will be prompted with a good ol' reliable text login prompt. Login as root and install the nVidia driver per their instructions.

After the nVidia driver is installed, try running 'startx'. This will start up X windows. It might work or, as in my case, it quickly crashed.

Study your /var/log/XFree86.0.log file. It contains many clues and tidbits of information that can help. In my case it appeared that something called GLX was starting up and then generating a message like, "Caught signal 11. Server terminating".

If you don't want OpenGL or hardware accelerated graphics, you can overcome this problem simply by commenting out the line that loads glx in your /etc/X11/XF86Config file. Few sane people will choose this option.

If you want the good stuff to work (you know you do), you've got your work cut out for you. Go get the source code for the 2.4.27 linux kernel off the web. Configure it, build it and get it running on your computer (that's all ). Be prepared to spend a few days doing this if you've never done it before. Don't be surprised if you find yourself drinking a lot and smoking like a chimney.

What? Quit whining and suck it up. I had to do it too. Consider it a rite of passage. You aren't **** until you can build your own kernel. The reek of bourbon, tobacco, hemp, and perspiration goes with the territory; get used to it. By the way, after your new kernel is running you will need to reinstall the nVidia driver before continuing.

I needed to create a custom monitor configuration in my /etc/X11/XF86Config file. The log showed me a long list of failed video modes and none of them included 1440x900. Most of the ones that were listed complained about hsync or vsync frequencies being out of range. After writing a few video drivers, these numbers actually start making a little sense. However, all you want is a working computer so you don't care. It turns out you don't have to. There's a handy command called 'gtf' that will do the work for you.

I could tell from the XFree86.0.log file that the nVidia driver detected a vertical refresh frequency of 0-60 reported by my system. With this and the resolution of my screen, gtf created the Modeinfo section for my /etc/X11/XF86Config file for me. For example:

% gtf 1440 900 60

Produced this really nice output...

# 1440x900 @ 60.00 Hz (GTF) hsync: 55.92 kHz; pclk: 106.47 MHz
Modeline "1440x900_60.00" 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync

Try it on your own computer just to see if the output is any different. Plug the output of gtf into the Monitor section of your XF86Config file. You'll also need to edit the Screen section and insert "1440x900_60.00" into the list of 24 bit Modes.

The Modeline reveals that this mode requires 55.92kHz hsync freq. So, edit the sync frequency ranges in the Monitor section to match. e.g.
HorizSync 30.0 - 56.0 # This will make X happy horizontally.
VertRefresh 0.0 - 60.0 # This will get you there vertically.

Now that the XF86Config file is properly configured for our exact display, we must disable the automatic attempts by the nVidia driver to second guess our decisions. Here we finally get to use a few of those tantalizing magic words a few others have posted. Thanks...whoever that was. It helped me to get through this, though there was a lot more that had to be done first. To force the driver to accept your settings, make the following Option entries in the Device section of the XF86Config file.

Option "IgnoreEDID" "1"
Option "UseEdidFreqs" "0"

Now, if you've got those few details out of the way, you are ready to try running 'startx' again. For me, that's pretty much all it took. My system worked quite well at this point and I was able to edit my /etc/inittab file to restore the line that starts X. After a reboot, everything worked great, including hardware accelerated 3D graphics.

Of course, this discourse is being dredged up from dazed relentless hours of frustration punctuated with tiny glimmers of hope. I may have missed a detail here or there. Just remember, Unix is a journey, not a destination!

Good luck. Have fun! Never give up and certainly don't give-in to those ATI guys.

}{oeft

)
DaveH is offline   Reply With Quote
Old 12-24-04, 10:10 AM   #5
Demolution
Registered User
 
Join Date: Dec 2004
Posts: 3
Default Re: GeForce FX 5200 under Redhat Linux 9.0

LOL you're one funny guy.

But thanks, that really helped me.
Demolution is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
302.17 for Linux x86/x86_64 released AaronP NVIDIA Linux 0 06-16-12 05:12 PM
295.59 (long-lived branch release) for Linux x86/x86_64 released artem NVIDIA Linux 0 06-11-12 12:25 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 10:28 AM
Mandrake Linux 9.0 (Dolphin) now available | comments? volt General Linux 10 10-19-02 11:13 PM
Geforce 4 on Redhat 7.0 Ali Ra NVIDIA Linux 1 08-09-02 04:22 AM

All times are GMT -5. The time now is 07:30 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.