Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-25-04, 11:43 PM   #1
trey85stang
Registered User
 
Join Date: Aug 2004
Posts: 3
Default FC3 glibc updates libGL.so.1 errors

I recenetly (12/24) installed all the updates for FC3, afterwards I had no libGL.so.1 library... and got segmentation faults when trying to run glxgears or glxinfo.

I uninstalled the nvidia module and went through witha reinstall.. but it seems to fail everytime.. with the following showing up in the log file.

Code:
-> Kernel module compilation complete.
-> Installing both new and classic TLS OpenGL libraries.
-> Installing 'NVIDIA Accelerated Graphics Driver for Linux-x86' (1.0-6629):
   executing: './usr/src/nv/makedevices.sh'...
   executing: '/sbin/ldconfig'...
   /sbin/ldconfig: Input file /usr/X11R6/lib/libXvMCNVIDIA.so.1.0.6629 not foun
   d.
   
   /sbin/ldconfig: Input file /usr/local/lib/libxvidcore.so.4.0 not found.
   
   /sbin/ldconfig: Input file /usr/local/lib/libdivxdecore.so not found.
   
   /sbin/ldconfig: Input file /usr/local/lib/libmp3lame.so.0.0.0 not found.
   
   /sbin/ldconfig: Input file /usr/local/lib/libdha.so.1.0 not found.
   
   /sbin/ldconfig: Input file /usr/local/lib/libdivxencore.so not found.
   
   /sbin/ldconfig: Input file /usr/lib/libnvidia-tls.so.1.0.6629 not found.
   
   /sbin/ldconfig: Input file /usr/lib/libGLcore.so.1.0.6629 not found.
   
   /sbin/ldconfig: Input file /usr/lib/libGL.so.1.0.6629 not found.
   
   /sbin/ldconfig: Input file /usr/lib/tls/libnvidia-tls.so.1.0.6629 not found.
   
   executing: '/sbin/depmod -aq'...
-> done.
-> Driver file installation is complete.
-> Running post-install sanity check:
ERROR: Unable to get file properties for '/usr/lib/libGL.so.1' (No such file or
       directory).
WARNING: The symbolic link '/usr/lib/libGL.so.1' does not exist.  This is
         necessary for correct operation of the NVIDIA Accelerated Graphics
         Driver for Linux-x86.  You can create this symbolic link manually by
         executing `ln -sf libGL.so.1.0.6629 /usr/lib/libGL.so.1`.
ERROR: Unable to get file properties for '/usr/lib/libGLcore.so.1' (No such
       file or directory).
WARNING: The symbolic link '/usr/lib/libGLcore.so.1' does not exist.  This is
         necessary for correct operation of the NVIDIA Accelerated Graphics
         Driver for Linux-x86.  You can create this symbolic link manually by
         executing `ln -sf libGLcore.so.1.0.6629 /usr/lib/libGLcore.so.1`.
ERROR: Unable to get file properties for '/usr/lib/libnvidia-tls.so.1' (No such
       file or directory).
WARNING: The symbolic link '/usr/lib/libnvidia-tls.so.1' does not exist.  This
         is necessary for correct operation of the NVIDIA Accelerated Graphics
         Driver for Linux-x86.  You can create this symbolic link manually by
         executing `ln -sf libnvidia-tls.so.1.0.6629
         /usr/lib/libnvidia-tls.so.1`.
ERROR: Unable to get file properties for '/usr/lib/tls/libnvidia-tls.so.1' (No
       such file or directory).
WARNING: The symbolic link '/usr/lib/tls/libnvidia-tls.so.1' does not exist. 
         This is necessary for correct operation of the NVIDIA Accelerated
         Graphics Driver for Linux-x86.  You can create this symbolic link
         manually by executing `ln -sf libnvidia-tls.so.1.0.6629
         /usr/lib/tls/libnvidia-tls.so.1`.
ERROR: Unable to get file properties for
       '/usr/X11R6/lib/libXvMCNVIDIA_dynamic.so.1' (No such file or
       directory).
WARNING: The symbolic link '/usr/X11R6/lib/libXvMCNVIDIA_dynamic.so.1' does not
         exist.  This is necessary for correct operation of the NVIDIA
         Accelerated Graphics Driver for Linux-x86.  You can create this
         symbolic link manually by executing `ln -sf libXvMCNVIDIA.so.1.0.6629
         /usr/X11R6/lib/libXvMCNVIDIA_dynamic.so.1`.
-> done.
-> Post-install sanity check failed.
-> Shared memory test passed.
-> Running runtime sanity check:
ERROR: The runtime configuration check failed for library 'libGL.so.1.0.6629'
       (expected: '/usr/lib/libGL.so.1', found: 'not').  The most likely reason
       for this is that conflicting OpenGL libraries are installed in a
       location not inspected by nvidia-installer.  Please be sure you have
       uninstalled any third-party OpenGL and third-party graphics driver
       packages.
-> done.
-> Runtime sanity check failed.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at www.nvidia.com.
I can get libGL.so.1 back onlyby uninstalling the nvidia driver.. and reinstalling xorg-x11-Mesa-libGL*.rpm.

Anyone have any idea what I can try to get this thing installed?? I have checked online and I cannot determine if anyone else is having any problems after appling this update.. a few claim that x would not start after the glibc updates are installed... so I am not sure what to check for next, i did everything that the log file stated that should be done.. but it leads to the same segmentation fualts.

\thanks
trey
trey85stang is offline   Reply With Quote
Old 12-26-04, 07:24 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: FC3 glibc updates libGL.so.1 errors

Until this has been investigated and resolved, this thread might help: https://www.redhat.com/archives/fedo.../msg06038.html.
zander is offline   Reply With Quote
Old 12-26-04, 11:13 AM   #3
trey85stang
Registered User
 
Join Date: Aug 2004
Posts: 3
Default Re: FC3 glibc updates libGL.so.1 errors

Quote:
Originally Posted by zander
Until this has been investigated and resolved, this thread might help: https://www.redhat.com/archives/fedo.../msg06038.html.

thanks for the link! disabling selinux took care of the problem.. hopefully it gets resolved soon
trey85stang is offline   Reply With Quote
Old 12-26-04, 01:56 PM   #4
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: FC3 glibc updates libGL.so.1 errors

FWIW, I installed 1.0-6629 on a fully updated (as of today) Fedora Core 3 system and did not encounter this problem; maybe it's already been fixed/worked around?
zander is offline   Reply With Quote
Old 12-26-04, 05:52 PM   #5
toracat
Registered User
 
Join Date: Apr 2003
Posts: 16
Default Re: FC3 glibc updates libGL.so.1 errors

Hmm...the original poster installed all updates on 12/24. There has been no new update to FC3 between 12/24 and today (12/26). I do not have this problem but that's because my selinux is disabled...

toracat
toracat is offline   Reply With Quote
Old 12-26-04, 11:06 PM   #6
trey85stang
Registered User
 
Join Date: Aug 2004
Posts: 3
Default Re: FC3 glibc updates libGL.so.1 errors

Quote:
Originally Posted by zander
FWIW, I installed 1.0-6629 on a fully updated (as of today) Fedora Core 3 system and did not encounter this problem; maybe it's already been fixed/worked around?

i do not know if it was fixed or not.. but there have been no new updates since I last updated... doesn't actually seem like too many people expierenced this issue.. but I really dont need selinux.. so I will leave it disabled and stick with my 3d accell
trey85stang is offline   Reply With Quote
Old 12-27-04, 05:06 AM   #7
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: FC3 glibc updates libGL.so.1 errors

@toracat: I had made sure that SELinux was enabled; strange...
zander is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:14 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.