Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-04-05, 12:45 PM   #1
supercompman
Registered User
 
Join Date: Jan 2005
Posts: 3
Default NVidia driver 6629, FC3, and nforce....

I have read all of the previous threads about problems installing the NVidia drivers on FC3 and I have tried all of the suggestions... "modprobe nvidia" in rc.local and "cp -a /dev/nvidia* /etc/udev/devices" then "chown root.root /etc/udev/devices/nvidia*", and I always get the same problem, when I try to start X, the screen goes black and the system hard locks. Nothing even gets written to the Xorg.0.log. I have a nforce motherboard, 256 Meg of RAM, Duron 1.3 Ghz, kernel 2.6.9-1.724_FC3 (although I have tried earlier kernel releases). All of the software packages are up to date.

My xorg.conf file is listed below:

# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
# Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "ViewSonic A70"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 180.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
# Option "NvAgp" "1"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 MX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

#Section "DRI"
# Group 0
# Mode 0666
#EndSection
supercompman is offline   Reply With Quote
Old 01-05-05, 04:16 PM   #2
supercompman
Registered User
 
Join Date: Jan 2005
Posts: 3
Default Re: NVidia driver 6629, FC3, and nforce....

Is there any other information I could provide that would assist in determining the problem?
supercompman is offline   Reply With Quote
Old 01-05-05, 05:13 PM   #3
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: NVidia driver 6629, FC3, and nforce....

AFAIK, 6629 have some problems with older cards... so please check if 6111, or 6106 works...
chunkey is offline   Reply With Quote
Old 01-07-05, 09:46 AM   #4
supercompman
Registered User
 
Join Date: Jan 2005
Posts: 3
Default Re: NVidia driver 6629, FC3, and nforce....

I recently tried the 6111 and 6106 drivers, and the installers for both fail after building the kernel module. When the installer tries to load the module, it returns the error of "unknowen symbol in module". I know that the kernel source that the installer is looking at is the correct source for my kernel, and that agpgart support (compiled as a module) is loaded.
supercompman is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:25 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.