Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-13-02, 05:24 AM   #1
petrh
Registered User
 
Join Date: Dec 2002
Location: Czech Rep.
Posts: 6
Default dell c840 and 4191 drivers

hello ,

i have installed 4191 drivers on my dell c840 with GeForce4 Go and now I cannot get 1600x1200 res. working. It did work fine before with 3123 drivers. Now it says 1600x1200 exceeds bandwith limitations. Did anybody encountered similar problem? Is there a solution? See attached log file.
Attached Files
File Type: zip nv.zip (6.3 KB, 217 views)
petrh is offline   Reply With Quote
Old 12-13-02, 10:47 AM   #2
petrh
Registered User
 
Join Date: Dec 2002
Location: Czech Rep.
Posts: 6
Default more details

I worked around this problem by setting NoBandWidthTest option. Funny thing is that my other linux machine has GF2MX and it works fine, but slower. I would if ever this problem should have occured on GF2MX before GF4Go.
petrh is offline   Reply With Quote
Old 12-14-02, 06:36 PM   #3
RH8C840
Registered User
 
Join Date: Dec 2002
Posts: 7
Unhappy C840 Geforce 440 Go

I have been trying to get the new Nvidia 3123 and the new 4191 driver to work on my C840 Bios A07 with no luck. The system is running RH8 with kernel 1.4.18-18.0. I downloaded and rebuilt both the kernel and GLX from src file, installed without any problem. However, it only work if external monitor is pluggin to my notebook. I also added this on my modules.config for 3123
options NVdriver NVreg_SoftEDIDs=0 NVreg_Mobile=1
This didn't make any different.
The log file show that no monitor is connected.

Anyone had any idea how can I get the driver to display on the built in LCD?

Thanks,
Attached Files
File Type: zip xconfig.zip (7.0 KB, 195 views)
RH8C840 is offline   Reply With Quote
Old 12-16-02, 03:15 AM   #4
petrh
Registered User
 
Join Date: Dec 2002
Location: Czech Rep.
Posts: 6
Default 4191 driver

Hello,

make sure you have nvidia.o in place. The new driver used module named nvidia.o so modprobe nvidia should work. It does for me. Otherwise meake sure you have installed correct nvidia_kernel package for your linux kernel.
petrh is offline   Reply With Quote
Old 12-16-02, 12:01 PM   #5
RH8C840
Registered User
 
Join Date: Dec 2002
Posts: 7
Default

Thanks for all the replies from you guys. I am currently working with Nvidia's tech to resolve this problem. The problems with 3123 and 4191 is that the driver can't detect the built in LCD. The installation is fine and driver loaded correctly, and it does work with externel monitor attached. Right now, as for work around solution I am using 2960 driver. I added to a script to force load the kernel driver

in rc.local
insmod -f Nvdriver

This is for driver 2960 and 3123 on modules.conf
alias char-major-195 Nvdriver
options Nvdriver Nvreg_SoftEDIDs=0 Nvreg_Mobile=1

As for 4191
alias char-major-195 nvidia
options nvidia Nvreg_SoftEDIDs=0 Nvreg_Mobile=1

By the way what version BIOS are you running? I have tried A07 and A03 with 3123 and 4191..They both didn't work.
RH8C840 is offline   Reply With Quote
Old 12-17-02, 03:46 AM   #6
petrh
Registered User
 
Join Date: Dec 2002
Location: Czech Rep.
Posts: 6
Default bios a07

I run a07 bios, previously a02 (a03? ). Never had this problem. I have c840 since may.
petrh is offline   Reply With Quote
Old 12-17-02, 10:00 AM   #7
RH8C840
Registered User
 
Join Date: Dec 2002
Posts: 7
Default petrh

This is why I hated Dell for. They can have the same model number but differ firmware. Depends when you buy them. Same thing goes with the servers. Ghost may not work, although they are the same specs and model (Perc SCSI had many different versions of firware). We have had a lot of problems in this regard.

Here is the hardware spec of my C840.
1 0120C Insert,Blank,PC Memory Card Intl. Assoc.,CP/CPX
1 0J747 Processor,80532,1.6GHZ,512K,Pentium 4,UPGA
1 433MR Assembly,Cover,Hinge,Plastic,Lonsdale
1 4M778 Battery,Primary,14.8V,8C,Malaysia Direct Ship,SANYO
1 6G141 Pipe,Height,Thin,FINS,Comaneci and Avanti (shared parts),Pong Adds/Cohiba
1 146CM Assembly,Cable,FLX,15,SXGA+-UXGA,Lonsdale/Lavaca
1 3J010 Assembly,Base (Assembly or Group),Bottom,C840,Compal,PCTel
1 3K552 Liquid Crystal Display,Ultra Extended Graphics Array,Standard Panels Working Group,BMV,15,IBM
1 4C895 Assembly,Bezel,Liquid Crystal Display,15.0,Lonsdale,Ultra Extended Graphics Array
1 7R055 Assembly,Cover,TOP,Liquid Crystal Display,15,C840/M50
1 3G859 Assembly,Cable,Bay (Drive Bay),C810,United States
1 3G939 Assembly,Floppy Drive,1.44M,3.5" Form Factor,Controller/No Cable,TEAC,Notebook
1 6G356 Adapter,Alternating Current,External,20V,90W,3W,Power Factor Correction
1 3J247 Keyboard,87,United States,Comaneci and Avanti (shared parts),United States
1 0F452 Case,Carrying,Leather,Notebook,CLASSIC
2 4K122 Dual In-Line Memory Module,128,266,16X64,8K,200
1 3R091 Subassembly,Compact Disk Drive,24X,IDE (Integrated Drive Electronics),Samsung,SIDE,V4
1 7J239 Card (Circuit),GRPHC,Video,32MB,NV17,MICRO STAR INTERNATIONAL CO LTD
1 48CVX Assembly,Carrier,Hard Drive,Lonsdale/Lavaca
1 6J987 Hard Drive,20GB,IDE (Integrated Drive Electronics),2.5" Form Factor,9.5MM,IBM-CSD
1 8267R Connector,Header,2X22,Female,2,S,Gold,35K,Third Height,Chip Set
1 1F756 Kit,Software,Overpack,Windows 2000 Professional,SP2,5.25" Form Factor,England/English
RH8C840 is offline   Reply With Quote
Old 12-17-02, 10:30 AM   #8
w3a5e1
Registered User
 
Join Date: Sep 2002
Posts: 8
Default

Im having the same problem with the latest drivers and my dell. I have a dell inspiron 8100 with a 64mb GF4 go. And an IBM SXGA+ LCD. I would like to know how to send bug reports to NVIDIA.
I am having the same problem with windows drivers after the 2xxx series.
w3a5e1 is offline   Reply With Quote

Old 12-18-02, 08:49 AM   #9
RH8C840
Registered User
 
Join Date: Dec 2002
Posts: 7
Default

As for Windows, I believed you can contact Dell. Here is the email to nivida for linux bugs.

linux-bugs@nvidia.com
RH8C840 is offline   Reply With Quote
Old 12-20-02, 06:12 PM   #10
w3a5e1
Registered User
 
Join Date: Sep 2002
Posts: 8
Default

Thanks for the address. As far as dell goes the last official gforce drivers from them were in the early 2xxx series. They wouldn't help anyway because my laptop is a 8100 with a gf4. I upgraded it, it was never sold that way.
w3a5e1 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:06 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.