Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-13-03, 09:28 AM   #1
segfault
Registered User
 
Join Date: Aug 2003
Location: Germany
Posts: 5
Send a message via ICQ to segfault Send a message via AIM to segfault
Default wake on lan (WOL) under linux

Hello!

I have a shuttle barebone system SN41G2 with the nforce chipset. everything works fine (network, audio, usb, ide, firewire etc.). what i need is wake on lan under linux (which works under windows 2k). i?m using the current driver version, my distribution is suse 8.2.
my first try was this:

Code:
metalu:~ # ethtool -s eth0 wol g
Cannot get current wake-on-lan settings: Operation not supported
  not setting wol
so it seems that ethtool cannot handle the device (unsupported?). so: is there a way to use wol under linux with my chipset??

greets,
segfault
segfault is offline   Reply With Quote
Old 01-09-04, 05:05 AM   #2
cglinux
Registered User
 
Join Date: Jan 2004
Posts: 6
Angry

I would just like to vote for this feature.

I really, really want WOL on linux.

I used to have it before I updated my mobo to an nForce2 one. I stupidly thought that when the specs said WOL that it would actually work!

I would happily plug another NIC into my machine and use it in place of the NVNet one, but the mobo doesn't have a WOL header, so WOL is supported with the built in NIC ONLY!!!!

How annoyed am I??

I used to dual boot Win XP and after shutting down from it, WOL worked, but now I've ditched Windo'h zzzzz 100%, this doesn't work.

I'm sure it's just a matter of tweaking a couple of registers here and there on the driver initialisation/shutdown code (although I'm far from educated in this matter).

Please, someone take note!!!!
cglinux is offline   Reply With Quote
Old 01-09-04, 08:15 AM   #3
Worf
Registered User
 
Join Date: Jul 2003
Posts: 10
Default

I absolutely agree.
Activating wake on lan in the bios doesn't seem to do anything.
While on a old PII board, where i have a wake on lan cable from Mainboard to the network card, this works great.

I could activate wake on lan in Windows and then wake the box.
But somehow the network card forgets the setting after the first usage.

I have a A7N8X, and i tried to wake by using the 3c59x card
Worf is offline   Reply With Quote
Old 01-09-04, 10:07 AM   #4
TheOneKEA
Fifteen-K Saiyan Bastard
 
TheOneKEA's Avatar
 
Join Date: Aug 2002
Location: Somewhere in England, waiting for ROTK and drooling over the A64 3000+
Posts: 417
Send a message via ICQ to TheOneKEA Send a message via AIM to TheOneKEA Send a message via Yahoo to TheOneKEA
Arrow Some information

http://www.scyld.com/expert/wake-on-lan.html
__________________
/me \/\/@|\|t5 $$$$$ F0r @|\| u65r 3|33t G@/\/\1|\|G r1G

SCREW THE ADS! http://adblock.mozdev.org/
Proud user of teh Fox of Fire - Mozilla Firefox 0.8

Registered Linux User #289618
TheOneKEA is offline   Reply With Quote
Old 02-17-04, 08:21 AM   #5
cglinux
Registered User
 
Join Date: Jan 2004
Posts: 6
Default

http://atlas.et.tudelft.nl/verwei90/.../solution.html

Quote:
On a positive note, Wake-on-LAN functionality has been enabled on this box, by using pci-config from Donald Becker at scyld. Stay tuned for more information on this matter.
Fingers crossed this will provide some positive light on this matter. Have to wait and see.

NVidia you're really dragging your feet on this on.

Col.
cglinux is offline   Reply With Quote
Old 02-20-04, 06:43 PM   #6
sphere
Registered User
 
Join Date: Jul 2003
Posts: 20
Default

Hi,

Please read this bugreport:

http://bugzilla.kernel.org/show_bug.cgi?id=1636

It contains a dirty solution that works with forcedeth v18 (but not with v.20 or higher). The forcedeth crew is currently too busy with RL stuff, but may code this in their driver yet.

I have emailed NVIDIA about this, two seperate engineers replied a few times, but really didn't have anything useful to add. At first the linux driver didn't contain WOL functionality, later on they reversed that statement.

However, it doesn't work. I still have to try to take a new kernel, rip out forcedeth, and patch it with forcedeth v.18 so I can upgrade my kernel, but still use WOL.

If you are wanting to use WOL, make sure your box is stable. Use a kernel without local-APIC, or turn off the CPU disconnect in the BIOS or just fix the problem with Ross Dickson's patches.

My page about broken stuff:

http://atlas.et.tudelft.nl/verwei90/nforce2/index.html

Please let me know how you get along.
sphere is offline   Reply With Quote
Old 05-19-04, 10:41 PM   #7
gen
Registered User
 
Join Date: Aug 2003
Posts: 2
Default Re: wake on lan (WOL) under linux

After reading other posts in this forum, I've written a patch to the nforce-1.0-0256 driver that enables WOL on my system (Chaintech 7NIF2). The patch simply adds a reboot notifier that puts the network adapter in the D3 power state at shutdown. Hopefully, NVIDIA won't mind if I attach the patch here? The License doesn't really mention anything about patches to the source. It's mostly added code so only a few lines of the original source appear in the patch.

Some notes:
(1) The patch is relative to the 0256 release, *not* the 0261 release which is the latest. I haven't had problems with the 0256 release, but I've heard about some problems involving 0261, so I haven't upgraded.
(2) I don't use forcedeth yet... I'd prefer an open driver, but I'll wait a bit for it to mature before switching since 0256 is working for me.
(3) I'm using kernel 2.4.25 with ACPI/IO-APIC enabled. This patch probably won't help people running the 2.6 series kernel.
(4) Make sure to enable WOL in the BIOS.
(5) The patch won't work if your system shutdown scripts disable network interfaces during the halt sequence.
e.g. halt -d -f -i -p
You'll need to remove the '-i' option... I haven't investigated whether this is because the call to pfnSetPowerState doesn't work if called after pfnDeinit or if some other hardware setting disables WOL when the interface is closed. (MAC address reset?)
Attached Files
File Type: txt nforce-1.0-0256-wol-patch.txt (2.5 KB, 265 views)
gen is offline   Reply With Quote
Old 06-02-04, 04:55 AM   #8
gen
Registered User
 
Join Date: Aug 2003
Posts: 2
Default Re: wake on lan (WOL) under linux

The recently released nvnet driver in nforce-1.0-0274 is working nicely on my system (Chaintech 7NIF2). Wake-on-Lan works out of the box, and is better than the patch I posted for 0256, since it functions whether or not the shutdown scripts disable the network interface. People interested in WOL should definitely try this version.
gen is offline   Reply With Quote

Old 11-20-04, 06:50 AM   #9
sphere
Registered User
 
Join Date: Jul 2003
Posts: 20
Default Re: wake on lan (WOL) under linux

Quote:
Originally Posted by gen
The recently released nvnet driver in nforce-1.0-0274 is working nicely on my system (Chaintech 7NIF2). Wake-on-Lan works out of the box, and is better than the patch I posted for 0256, since it functions whether or not the shutdown scripts disable the network interface. People interested in WOL should definitely try this version.
I've tried with NFORCE-Linux-x86-1.0-0292-pkg1.run, but this certainly does not work "out of the box" on my Abit NF7-S rev. 2.0. I'm really curious how this works with your Chaintech.

Is there anyone else that has successfully enabled WOL with the nvnet driver? For now, I think I will stick with forcedeth. Even if WOL is possible with nvnet it is a pain to get networking back, when you install a new kernel.

Unfortunately, the forcedeth team remains tacent for now, I guess they are busy.

My specs:
Abit nf7-s
2.6.8.1 kernel
0292 nvnet revision
Debian sid
sphere is offline   Reply With Quote
Old 11-21-04, 07:14 AM   #10
sphere
Registered User
 
Join Date: Jul 2003
Posts: 20
Default Re: wake on lan (WOL) under linux

Well, I found the version gen is using:

http://download.nvidia.com/XFree86/n....0-0274.tar.gz

And indeed in the nvenet.c source there is a function that governs power management (nvenet_suspend), and mentions wake on lan, but I don't think this compiles for 2.6? I'll see if I can find some more on this.
sphere is offline   Reply With Quote
Old 01-29-05, 12:28 AM   #11
sunset
light of day
 
Join Date: Aug 2004
Location: australia
Posts: 1
Cool Re: wake on lan (WOL) under linux

I have had some success using a tip from:
http://frequal.com:8080/linux/AsusWakeOnLan.html
ie: turn the PC on, then within a few seconds press the power button again. Wake On Lan then works (once).
asus a7n8x motherboard, fedora core 3 + up2date.
Sort of OK, if I remember to do it before actually wanting to WOL ; -)

But if I initiate shutdown via gui (logout|shutdown), or halt / shutdown, then wake on Lan doesn't get enabled, and the machine fails to respond.

I have noticed on a HP compaq nx9000 that during shutdown a log line is emitted similar to: eth0 staying awake for wake on LAN, but this doesn't happen with the a7n8x.

Last edited by sunset; 01-29-05 at 08:10 AM.
sunset is offline   Reply With Quote
Old 01-29-05, 06:19 AM   #12
sphere
Registered User
 
Join Date: Jul 2003
Posts: 20
Default Re: wake on lan (WOL) under linux

I wonder if this holds for both the 3com port as the nvidia port.
sphere is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux GTX 675M support geophph NVIDIA Linux 37 06-13-12 07:40 PM
Samsung becomes Linux Foundation platinum member, takes a seat on board News Archived News Items 0 06-05-12 06:10 PM
nVidia Linux drivers with Linux on Mac, help? Thetargos NVIDIA Linux 0 05-13-12 12:52 PM
Mandrake Linux 9.0 (Dolphin) now available | comments? volt General Linux 10 10-19-02 10:13 PM
Linux VS. Windows XP! XP wins! dostler NVIDIA Linux 20 09-15-02 03:47 PM

All times are GMT -5. The time now is 11:17 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.