Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-20-04, 11:35 PM   #1
jlacroix
Registered User
 
Join Date: Jun 2004
Posts: 57
Default Driver Needs to be reinstalled, after EVERY boot.

Hello all I have a wierd problem, when I first install the Nvidia driver (6111) and then "startx" the driver runs the desktop, but when I reboot, I get X errors. When I am back to the prompt, I uninstall, then reinstall the nvidia driver. On the reinstall it works, but when I reboot, gone again.

Further more, when I try to play Tuxracer (after the driver is reinstalled) the screen gets too huge for the display and very huge, and stays there. The game crashes.

This is Fedora Core 3 Test 2. When I upgraded from Fedora Core 2 Final, the nvidia driver worked beautifully. On a fresh install, I have this mess to contend with.

OS: FC3T2
Card: Geforce FX 5200 128MB
RAM: 768MB
Process. PIII 500mhz

Attached please find the xorg.conf and xorg log files, hopefully those will help. I know you all are about to say not to use a test release, but my first install of Test 2 was flawless, and I need to have updated software, since upgrading gnome to 2.8 and KDE3.3 is not possible on FC2Final.
Attached Files
File Type: txt Xorg.0.log.txt (26.0 KB, 176 views)
File Type: txt xorg.conf.txt (2.7 KB, 133 views)
jlacroix is offline   Reply With Quote
Old 09-20-04, 11:36 PM   #2
jlacroix
Registered User
 
Join Date: Jun 2004
Posts: 57
Default Re: Driver Needs to be reinstalled, after EVERY boot.

Forgot to mention I tried with selinux off, and I tried with selinux on.
jlacroix is offline   Reply With Quote
Old 09-21-04, 12:36 PM   #3
Antti
Registered User
 
Join Date: Aug 2004
Posts: 45
Default Re: Driver Needs to be reinstalled, after EVERY boot.

Instead of re-installing, try running a simple command as root:

modprobe nvidia

Does it now work without re-installing the driver? I have this problem on one computer running Mandrake 10: the driver nvidia does not load in boot! Need to load it manually every time! So I made a script to do that and added it to /etc/rc5.d. The script just has that modprobe-line.
Antti is offline   Reply With Quote
Old 09-21-04, 03:44 PM   #4
jlacroix
Registered User
 
Join Date: Jun 2004
Posts: 57
Default Re: Driver Needs to be reinstalled, after EVERY boot.

First of all, doing modprove nvidia as root loads the nvidia module and all is well there.
However, I created a file called "nvidia" with the modprobe nvidia line in it, saved it where you said to and nothing happens, I still have to do it manually. It's a start, though.

Now, when I play tuxracer the screen still goes huge and then it crashes so I don't know what is wrong there, if I run tux racer with the command window, I get:
Code:
[jeremy@localhost ~]$ tuxracer
Tux Racer 0.61 -- a Sunspire Studios Production (http://www.sunspirestudios.com)
(c) 1999-2000 Jasmin F. Patry <jfpatry@sunspirestudios.com>
"Tux Racer" is a trademark of Jasmin F. Patry
Tux Racer comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to redistribute it under certain conditions.
See http://www.gnu.org/copyleft/gpl.html for details.

Error: Could not open /dev/nvidiactl because the permissions
are too resticitive.  Please see the FREQUENTLY ASKED QUESTIONS
section of /usr/share/doc/NVIDIA_GLX-1.0/README for steps
to correct.
[jeremy@localhost ~]$
Does that maybe help?
jlacroix is offline   Reply With Quote
Old 09-21-04, 04:01 PM   #5
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: Driver Needs to be reinstalled, after EVERY boot.

Although the "solutions" you guys tried work the better way on most distributions is to add some line to /etc/modules.conf or the file your distribution uses to automaticly load modules on startup.
Thunderbird is offline   Reply With Quote
Old 09-21-04, 04:07 PM   #6
jlacroix
Registered User
 
Join Date: Jun 2004
Posts: 57
Default Re: Driver Needs to be reinstalled, after EVERY boot.

by the way, I chmodded my /dev/nvidia directory and it got rid of that problem, now I get this when trying tux racer (And the same screen problem):
Code:
*** glibc detected *** double free or corruption: 0x08375430
jlacroix is offline   Reply With Quote
Old 09-21-04, 10:54 PM   #7
Compholio
Registered User
 
Join Date: Jul 2004
Posts: 66
Default Re: Driver Needs to be reinstalled, after EVERY boot.

tux racer is broken for a lot of FC people, check bugzilla.
Compholio is offline   Reply With Quote
Old 09-22-04, 09:20 AM   #8
Antti
Registered User
 
Join Date: Aug 2004
Posts: 45
Default Re: Driver Needs to be reinstalled, after EVERY boot.

Quote:
Originally Posted by Thunderbird
Although the "solutions" you guys tried work the better way on most distributions is to add some line to /etc/modules.conf or the file your distribution uses to automaticly load modules on startup.
I know. But this way it seems to work the best, didn't get modules.conf or other workarounds working...


jlacroix, name the file in your /etc/rc5.d-folder to something like S20nvidia and remember to make it executable (chmod +x S20nvidia). Also make sure you are actually booting to the runlevel you are editing, in this case runlevel 5.
Antti is offline   Reply With Quote

Old 03-04-05, 04:05 PM   #9
gaspar
Registered User
 
Join Date: Mar 2005
Posts: 8
Default Re: Driver Needs to be reinstalled, after EVERY boot.

i'm having the same issues as well. i'm not sure why nvidia isn't modprobing correctly. any ideas on a fix is appreciated.
gaspar is offline   Reply With Quote
Old 03-10-05, 10:17 AM   #10
zarlat
Registered User
 
Join Date: Mar 2005
Posts: 1
Default Re: Driver Needs to be reinstalled, after EVERY boot.

Quote:
Originally Posted by jlacroix
Hello all I have a wierd problem, when I first install the Nvidia driver (6111) and then "startx" the driver runs the desktop, but when I reboot, I get X errors. When I am back to the prompt, I uninstall, then reinstall the nvidia driver. On the reinstall it works, but when I reboot, gone again.
I have the same problem. This NVIDIA drive and Fedora 3 problems are a mess. Anyone know what is really going on? I jury rigged the system by adding a file called nvidia to rc3.d containing the line modprobe nvidia and linking it to S20nvida in rc3.d. It should work from modprobe.conf.
zarlat is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia driver stopped working after X restart and Kernel taint msgs during boot mikejuni NVIDIA Linux 10 05-21-12 08:30 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
failing to initialize NV driver PsyShook NVIDIA Linux 10 09-19-02 12:41 PM
Nvidia Driver causes crash on Standby/Suspend dasher NVIDIA Linux 5 09-16-02 05:57 PM

All times are GMT -5. The time now is 01:25 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.