Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-24-02, 11:28 AM   #1
ceddy
Registered User
 
Join Date: Nov 2002
Posts: 5
Send a message via ICQ to ceddy
Default 30 seconds delay to start X

Ok,

let's discuss about that 30 seconds delay to start X many people (me included) seem to suffer of.

It doesn't seem to be related to a specific CPU, mainboard chipset or even a specific Nvidia card as I read people got that delay on hardware ranging from AMD to Intel and from GeForce to TNT gfx cards.

Drivers version 2960 and 3123 are affected. I'm unsure of previous version though I think delay became much higher with driver around version 2880/2960.

Does anyone know what cause that awfully long delay to start X ?

Thanks
ceddy is offline   Reply With Quote
Old 11-24-02, 01:27 PM   #2
BrianzaMan
Dragon Flame
 
Join Date: Nov 2002
Posts: 51
Default Re: 30 seconds delay to start X

Quote:
Originally posted by ceddy
Ok,

let's discuss about that 30 seconds delay to start X many people (me included) seem to suffer of.

It doesn't seem to be related to a specific CPU, mainboard chipset or even a specific Nvidia card as I read people got that delay on hardware ranging from AMD to Intel and from GeForce to TNT gfx cards.

Drivers version 2960 and 3123 are affected. I'm unsure of previous version though I think delay became much higher with driver around version 2880/2960.

Does anyone know what cause that awfully long delay to start X ?

Thanks
In Linux I have a little longer delay too compared to XFree "nv" drivers, but I think that is normal, but I don't think that is 30 seconds.U have any options enable ?(DigitalVibrance , ShadowCursor ...) U use AGPGART or NVAGP??

Byez
BrianzaMan is offline   Reply With Quote
Old 11-25-02, 09:39 AM   #3
ceddy
Registered User
 
Join Date: Nov 2002
Posts: 5
Send a message via ICQ to ceddy
Default

In Linux I have a little longer delay too compared to XFree "nv" drivers, but I think that is normal, but I don't think that is 30 seconds.

With the default NV driver of XFree, X starts in less than 5 seconds. With Nvidia official driver, it takes more than 30 seconds. That's a huge difference.

U have any options enable ?(DigitalVibrance , ShadowCursor ...) U use AGPGART or NVAGP??

Nothing special. Just default options. NoLogo is On but it doesn't change anything.

My card is a Diamond Viper 550 (so, TNT 16Mb thru PCI bus) on a Intel 440BX mainboard PII CPU and Debian Sarge. But for what I read of other persons having similar start up delays, PCI or AGP, Pentium or AMD, or whatever isn't the cause of the problem.

That's why I wrote a new threat as nobody seems to know where the problem lies...
ceddy is offline   Reply With Quote
Old 11-25-02, 02:03 PM   #4
tuzok
Guest
 
Posts: n/a
Default

I had similar problem with my S3 ViRGE card. I found that it was caused by waiting for EDID-DDC information from my monitor. But my monitor didīt support DDC. It has waited for about 60 second.
After a minute X server displayed on screen ( system was frezzed until that).
I donīt know if it help you, but would recommend you to search /var/log/XFree86.0.log for errors or warnings related to DDC).
  Reply With Quote
Old 11-26-02, 12:14 PM   #5
AlphaChild
Registered User
 
Join Date: Nov 2002
Posts: 9
Default

its really freaky that this thread started up, because i have this exact problem under FreeBSD 4.7 with the new nvidia drivers (3203). i have a Pentium II 350/Riva TNT combo. the thing is tho, that i am using the Intel SR440BX board, and this has the TNT built in. whenever i start up the X server, i have a 1/2-second window every 30 seconds to press Ctrl+Alt+Bkspc on the keyboard. if i get it right, i get into the GUI, otherwise i have to wait another 30 seconds. i have no idea why this is happening, but i dont particularly like playing "fastest finger first", just to get into a GUI

the /var/log/XFree86.0.log file shows no errors or warnings, so there must be something else in the drivers
AlphaChild is offline   Reply With Quote
Old 11-26-02, 08:26 PM   #6
Acidcrawl
Guest
 
Posts: n/a
Default Same problem

I am having the exact same problem ever since I installed the Official freeBSD drivers. I am running freeBSD 4.7 stable and the current stable version of Xfree86. When I use the supplied "nv" driver X starts immediatly. I am also having another problem, if I have the GLX line uncommented in the X config file I get the Nvidia splash screen and it just freezes at that point and I have to press ctrl-alt-delete which reboots the computer. Also when I do manage to get into X with the official driver and I try to switch to a console it locks everything up. Any help on this would be much appreciated.

System Info
-------------
Asus A7V-133
1.2 ghz Duron
Nvidia Gforce4 MX 440
  Reply With Quote
Old 11-30-02, 11:14 AM   #7
majtaylor
Guest
 
Posts: n/a
Default

I also have the same problem. I have a Geoforce 4 440MX card and it takes at least 30 seconds for X to start. If I use the nv drivers X starts immediately. I have a Linux from Scratch system, so it seems that this problem is operating system independent.

I also try going with either 1.0-3123 or 1.0-2960 and that made no difference.

I have looked for errors in Xfree86.0.log and there isn't any in there. There is alot of stuff about testing various modes with my monitor and I wondered if that might be what was slowing the start up down.
  Reply With Quote
Old 11-30-02, 02:04 PM   #8
IKARI
Guest
 
Posts: n/a
Default

Quote:
There is alot of stuff about testing various modes with my monitor and I wondered if that might be what was slowing the start up down.
Me too:

(II) NVIDIA(0): Not using default mode "1024x768" (bad mode clock/interlace/doublescan)
(II) NVIDIA(0): Not using default mode "512x384" (bad mode clock/interlace/doublescan)
(II) NVIDIA(0): Not using default mode "1280x960" (hsync out of range)
(II) NVIDIA(0): Not using default mode "640x480" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1280x1024" (hsync out of range)
(II) NVIDIA(0): Not using default mode "640x512" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1280x1024" (hsync out of range)
(II) NVIDIA(0): Not using default mode "640x512" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1792x1344" (hsync out of range)
(II) NVIDIA(0): Not using default mode "896x672" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1792x1344" (hsync out of range)
(II) NVIDIA(0): Not using default mode "896x672" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1856x1392" (hsync out of range)
(II) NVIDIA(0): Not using default mode "928x696" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1856x1392" (hsync out of range)
(II) NVIDIA(0): Not using default mode "928x696" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1920x1440" (hsync out of range)
(II) NVIDIA(0): Not using default mode "960x720" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1920x1440" (hsync out of range)
(II) NVIDIA(0): Not using default mode "960x720" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1152x864" (hsync out of range)
(II) NVIDIA(0): Not using default mode "576x432" (hsync out of range)
(WW) (1400x1050,Monitor0) mode clock 122MHz exceeds DDC maximum 110MHz
(II) NVIDIA(0): Not using default mode "1400x1050" (hsync out of range)
(II) NVIDIA(0): Not using default mode "700x525" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1400x1050" (hsync out of range)
(II) NVIDIA(0): Not using default mode "700x525" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1400x1050" (hsync out of range)
(II) NVIDIA(0): Not using default mode "700x525" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1920x1200" (hsync out of range)
(II) NVIDIA(0): Not using default mode "960x600" (hsync out of range)
(**) NVIDIA(0): Validated modes for Display Device 0:
(**) NVIDIA(0): Default mode "1024x768": 94.5 MHz, 68.7 kHz, 85.0 Hz
(**) NVIDIA(0): Default mode "800x600": 56.3 MHz, 53.7 kHz, 85.1 Hz
(**) NVIDIA(0): Default mode "640x480": 36.0 MHz, 43.3 kHz, 85.0 Hz
(II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
  Reply With Quote

Old 11-30-02, 03:19 PM   #9
ceddy
Registered User
 
Join Date: Nov 2002
Posts: 5
Send a message via ICQ to ceddy
Default

Quote:
There is alot of stuff about testing various modes with my monitor and I wondered if that might be what was slowing the start up down
Interesting.... Is there a way to prevent the screen resolution checking?
ceddy is offline   Reply With Quote
Old 12-19-02, 05:41 PM   #10
david
Registered User
 
Join Date: Nov 2002
Posts: 17
Send a message via ICQ to david
Default

as an experiment, you could try to limit the number of screen reos just to the ones that you most use, e.g. just use 1024x768, in the xFree86config-4.

If the computer believes there to be only one resolution, then it won't bother checking the rest...

I don't think this is going to work though I've got the same problem and my monitor only goes up to 1027x768 @60hz, so there aren't that many permutations to make for it to make (if that's the right word^^)
david is offline   Reply With Quote
Old 01-02-03, 02:52 PM   #11
cReat0r
Registered User
 
Join Date: Jan 2003
Location: Grenaa, Denmark
Posts: 3
Default

I have the same problem with the freezing splash screen, when i remove Load "glx" from my XF86Config it starts normally but then i cant play any games, someone who knows whats wrong with the freezing splash screen?
cReat0r is offline   Reply With Quote
Old 01-03-03, 02:45 PM   #12
mam26
Registered User
 
Join Date: Jan 2003
Posts: 1
Talking

goto to arts soundserver settings and change the delay to 1 second. your problems will go away.
mam26 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
PC turns off after few seconds after on button JediKnight General Hardware 3 09-18-13 04:58 PM
302.17 nvidiaXineramaInfoOverride not working properly hlandgar NVIDIA Linux 11 01-21-13 08:53 AM
Microsoft explained why they killed start button AthlonXP1800 Microsoft Windows 8 19 10-28-12 09:07 AM
Base mosaic and rotation? happyfunbot NVIDIA Linux 5 07-13-12 12:23 PM
NVIDIA 3123 driver on SuSE 8.0 Ok , but slow to start X Gabolander NVIDIA Linux 3 09-27-02 07:41 AM

All times are GMT -5. The time now is 08:53 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Đ1998 - 2014, nV News.