Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-14-05, 04:19 PM   #1
jang
Registered User
 
Join Date: Feb 2005
Posts: 3
Default Complete system crash / hang / freeze / lockup on closing OpenGL app

I'm having a problem where my whole system hangs when I close OpenGL apps. This doesn't happen all the time. I've created a simple app using GLUT to open a window, clear the screen, and draw a quad. The number of times I've to open and close the app before the sytem hangs is random. Sometimes I can do this for a long time before the system hangs. The window usually clears to the default window background colour (not the GL clear colour) before the system hangs.

Anyone experienced similar problems? Any pointers appreciated. Developing with this problem is a real pain.

Details:
Driver versions: 6629, 7162, 7167
Card: Quadro FX 4000 AGP8x

I've NVreg_EnableAGPSBA=0 and NVreg_EnableAGPFW=0.
However, cat /proc/driver/nvidia/agp/status reports
Fast Writes: Disabled
SBA: Enabled
This is weird because I didn't force SBA on in the os-registry.c
jang is offline   Reply With Quote
Old 03-15-05, 02:08 AM   #2
locutus
Registered User
 
Join Date: Dec 2004
Posts: 8
Default Re: Complete system crash / hang / freeze / lockup on closing OpenGL app

I had the same problems with a 2.6.10 kernel on a dual Opteron. 32 Bit
Systems didn't show these crashes. Kernel 2.6.11 fixed this problem.
locutus is offline   Reply With Quote
Old 03-15-05, 04:27 AM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Complete system crash / hang / freeze / lockup on closing OpenGL app

Most x86-64 Linux 2.6 kernels have accounting problems in their implementation of change_page_attr() that may result in symptoms such as these, please see the README for additional information. On affected systems (i.e. Linux/x86-64 < 2.6.11), the NVIDIA driver prints a warning message when the module is loaded - please upgrade to the latest stable Linux 2.6 kernel (e.g. Linux 2.6.11.3) if this is the case on your system.
zander is offline   Reply With Quote
Old 03-15-05, 09:33 AM   #4
jang
Registered User
 
Join Date: Feb 2005
Posts: 3
Default Re: Complete system crash / hang / freeze / lockup on closing OpenGL app

I'm running on a 32-bit system: dual Xeon 2.8GHz (hyperthreading disabled) with 2.4.26-lck1 (RedHat 7.3). Are there any other possibilities?

Upgrading the kernel on my machine is not a problem (although you mention that only 64-bit systems are affected), but if we're going to get this card for a whole bunch of machines currently used in production, then this could be an issue.
jang is offline   Reply With Quote
Old 03-18-05, 01:39 PM   #5
jang
Registered User
 
Join Date: Feb 2005
Posts: 3
Default Re: Complete system crash / hang / freeze / lockup on closing OpenGL app

I've downgraded to 2.4.18-4 (from 2.4.26-lck1) for the dual Xeon and it seems to be doing fine now. Fingers crossed this solves the problem.
jang is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg crash and system freeze l_r_mcglashan NVIDIA Linux 0 05-17-12 04:01 AM

All times are GMT -5. The time now is 12:31 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.