Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-16-05, 02:09 PM   #1
Eversor
Registered User
 
Join Date: Mar 2005
Posts: 19
Default can't use nvnet module

Hi.
I'm using suse 9.2 pro, and i'm having troubles running the most recent nvnet compiled from 0301 drivers release this week.

I'm using a 2.6.9 kernel i compiled, and it brings forcedeth along. So i have ethernet working pretty fine. But since nVidia drivers should be better i installed them.

The problem is i load the module fine, and using Yast i choose nvnet, tried nvnet.ko, modules, but it also loads, and uses forcedeth instead.

After reboot it never loads the nvnet module.

Also did the "alias eth0 nvnet" in /etc/modules.conf, it's the same.

Any ideas?

Regards.
Eversor is offline   Reply With Quote
Old 03-16-05, 04:53 PM   #2
lightsout
Registered User
 
Join Date: Mar 2005
Posts: 28
Default Re: can't use nvnet module

Personally, I don't see much difference between the two. As nvnet taints the kernel, I'd use forcedeth. I believe these days the forcedeth module is actually maintained and is getting patched by nvidia as the "cat is out of the bag"!
lightsout is offline   Reply With Quote
Old 03-16-05, 06:02 PM   #3
Eversor
Registered User
 
Join Date: Mar 2005
Posts: 19
Default Re: can't use nvnet module

Quote:
Originally Posted by lightsout
Personally, I don't see much difference between the two. As nvnet taints the kernel, I'd use forcedeth. I believe these days the forcedeth module is actually maintained and is getting patched by nvidia as the "cat is out of the bag"!
If it's written to support even 2.6.11, why do you say it taints the kernel?

I'd prefer to use it, it surelly should be alot more optimized.
Eversor is offline   Reply With Quote
Old 03-19-05, 01:42 PM   #4
Eversor
Registered User
 
Join Date: Mar 2005
Posts: 19
Default Re: can't use nvnet module

anyone?
Eversor is offline   Reply With Quote
Old 03-20-05, 12:54 AM   #5
Thoreau
Registered User
 
Join Date: Dec 2002
Posts: 95
Default Re: can't use nvnet module

Tainting the GPL'ed kernel is done by installing proprietary guarenteed to break crap drivers. Which is what the guy before me was intimating.

Which is why using forcedeth is a better longterm solution, so none of us need to ever talk about installing broke ass drivers again. How that be? Clear as glass?
Thoreau is offline   Reply With Quote
Old 03-20-05, 01:40 AM   #6
blueworm
[DEADAGAIN]blueworm
 
blueworm's Avatar
 
Join Date: Mar 2003
Posts: 416
Default Re: can't use nvnet module

ROFLMAO
forcedeth is a better driver.
__________________
Registered linux user #271604 Get Counted! http://counter.li.org/
lianLi PC60, OCZ powerStream 520W PSU, Asus P5N-E SLI, Core 2 duo E6550, 2Gb GEIL, XFX 8800GT, TB SantaCruz
blueworm is offline   Reply With Quote
Old 03-20-05, 06:25 AM   #7
lightsout
Registered User
 
Join Date: Mar 2005
Posts: 28
Default Re: can't use nvnet module

Its only an ethernet driver, I'm sure it doesn't make that much difference.

By tainting the kernel, it means that a binary driver has been loaded. Therefore no-one will touch any kernel crashes you've got.

As I said NVIDIA maintain the forcedeth driver these days anyway and submit patches against it. It'll be fine, and less pain.
lightsout is offline   Reply With Quote
Old 03-20-05, 09:34 AM   #8
Eversor
Registered User
 
Join Date: Mar 2005
Posts: 19
Default Re: can't use nvnet module

tks lightsout, i was more curious wtf the driver isn't running than anything else, it's forcedeth then.

@ Thoreau
It's always nice to criticize maybe the only company that has got a decent driver support for linux.
Eversor is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-02-02 12:58 AM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 02:44 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 11:46 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 09:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 11:16 PM

All times are GMT -5. The time now is 11:35 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.