Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-01-05, 02:39 AM   #1
sherw1d
Registered User
 
Join Date: Mar 2005
Posts: 4
Default Xvideo is displayed incorerctly on FX5200 PCI

Hi

I am using a FX5200 PCI card in an old I810 based system to drive an RBG scart TV directly from the VGA connector (couldn't use the integrated I810 graphics card as it didn't support interlacing).

Running X and Myth TV generally behaves fine and even watching TV is fine provided the vertical scaling is set such that the whole of the video stream is displayed on the whole of the display. However if I use the 'letterbox' modes to remove the horizontal bars from the top and bottom (I'm using a 16:9 TV), then the displayed image is offset vertically (off the top of the screen) and the bottom of the image is dispalyed once and then doesn't change. The magnitude of both of these effects depends on scaling factor.

Looking at the Myth TV code, it appears to do scaling by drawing onto a larger display area (starting at -ve y coordinates). This works fine on one of my PCs (with a Radeon chipset), but not with this system.

I have modiied the MythTV code to produce more debugging and all the src and dest co-ordinates look fine. I have even modified it to apply the letterboxing by reducing the area of the video to copy rather than expanding the display area and the results are the same.

Any thoughts?

Daniel
sherw1d is offline   Reply With Quote
Old 04-01-05, 01:44 PM   #2
sherw1d
Registered User
 
Join Date: Mar 2005
Posts: 4
Default Re: Xvideo is displayed incorerctly on FX5200 PCI

Hi

I have fiddled a bit more and discovered that this problem only occurs when interlacing is enabled. Anyone have any ideas.

I've also looked through the X-windows Xv source and this behaves identically whether or not the display is set for interlacing right down to a call to
pPort->pAdaptor->ddPutImage() in xvmain.c. Therefore as I assume that this is a call to the driver, I can only assume the fault lies in the driver itself.

Daniel

Last edited by sherw1d; 04-01-05 at 02:02 PM.
sherw1d is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM

All times are GMT -5. The time now is 11:38 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.