Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-17-05, 03:59 PM   #1
OrcLex
Registered User
 
Join Date: Apr 2005
Posts: 11
Question Geforce 6600GT does not run with driver 7174 and debian for amd64

Hello,

I've got a pentium 4 630 with em64t and debian pure64. My nvidia Geforce 6600GT PCI Express card does only work in vesa mode. The latest nvidia driver (x86_64-1.0-7174) does not run.
I've installed the latest version of Xorg (X11R6.8.2-src.tar.bz2) and build the nvidia driver with 'make-kpkg --arch amd64 modules_image' and installed the resulting deb file:

root@orclex:/usr/src# uname -r
2.6.8-11-em64t-p4-smp

root@orclex:/usr/src# dpkg -L nvidia-kernel-2.6.8-11-em64t-p4-smp
/.
/lib
/lib/modules
/lib/modules/2.6.8-11-em64t-p4-smp
/lib/modules/2.6.8-11-em64t-p4-smp/nvidia
/lib/modules/2.6.8-11-em64t-p4-smp/nvidia/nvidia.ko
/usr
/usr/share
/usr/share/lintian
/usr/share/lintian/overrides
/usr/share/lintian/overrides/nvidia-kernel-2.6.8-11-em64t-p4-smp
/usr/share/doc
/usr/share/doc/nvidia-kernel-2.6.8-11-em64t-p4-smp
/usr/share/doc/nvidia-kernel-2.6.8-11-em64t-p4-smp/README.Debian
/usr/share/doc/nvidia-kernel-2.6.8-11-em64t-p4-smp/copyright
/usr/share/doc/nvidia-kernel-2.6.8-11-em64t-p4-smp/changelog.Debian.gz

I can load the nvidia module with modprobe without any problems (lsmod shows that nvidia is loaded), but starting X with the nvidia driver fails with following error:


X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.11-9-em64t-p4-smp x86_64 [ELF]
Current Operating System: Linux orclex 2.6.8-11-em64t-p4-smp #1 SMP Sat Mar 26 04:28:35 CET 2005 x86_64
Build Date: 16 April 2005
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Apr 17 22:04:04 2005
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Screen" (0)
(**) | |-->Monitor "21 Monitor"
(**) | |-->Device "GeForce 6600GT"
(**) |-->Input Device "Generic Keyboard"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc105"
(**) XKB: model: "pc105"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "Configured Mouse"
[...]
(II) LoadModule: "bitmap"
(II) Reloading /usr/X11R6/lib64/modules/fonts/libbitmap.a
(II) Loading font Bitmap
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib64/modules/extensions/libdbe.a
(II) Module dbe: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "ddc"
(II) Loading /usr/X11R6/lib64/modules/libddc.a
(II) Module ddc: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.0.0
ABI class: X.Org Video Driver, version 0.7
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib64/modules/extensions/libextmod.a
(II) Module extmod: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib64/modules/fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
compiled for 6.8.2, module version = 2.1.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.4
(II) Loading font FreeType
(II) LoadModule: "xtt"
(WW) Warning, couldn't open module xtt
(II) UnloadModule: "xtt"
(EE) Failed to load module "xtt" (module does not exist, 0)
(II) LoadModule: "record"
(II) Loading /usr/X11R6/lib64/modules/extensions/librecord.a
(II) Module record: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.13.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.2
(II) Loading extension RECORD
(II) LoadModule: "speedo"
(WW) Warning, couldn't open module speedo
(II) UnloadModule: "speedo"
(EE) Failed to load module "speedo" (module does not exist, 0)
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib64/modules/fonts/libtype1.a
(II) Module type1: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.0.2
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib64/modules/extensions/libglx.a
(II) Module glx: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.2
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/X11R6/lib64/modules/extensions/libGLcore.a
(II) Module GLcore: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.2
(II) Loading extension GLX
(II) LoadModule: "xtrap"
(II) Loading /usr/X11R6/lib64/modules/extensions/libxtrap.a
(II) Module xtrap: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.2
(II) Loading extension DEC-XTRAP
(II) LoadModule: "nvidia"
(WW) Warning, couldn't open module nvidia
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (module does not exist, 0)
(II) LoadModule: "keyboard"
(II) Loading /usr/X11R6/lib64/modules/input/keyboard_drv.o
(II) Module keyboard: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.0.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.4
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib64/modules/input/mouse_drv.o
(II) Module mouse: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.0.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.4
(EE) No drivers available.

Fatal server error:
no screens found




So what's wrong?

Thanks in advance,
Alex
OrcLex is offline   Reply With Quote
Old 04-17-05, 05:19 PM   #2
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: Geforce 6600GT does not run with driver 7174 and debian for amd64

The kernel module is one thing. What you need now is install the driver for X aswell....
Lithorus is offline   Reply With Quote
Old 04-18-05, 12:15 AM   #3
OrcLex
Registered User
 
Join Date: Apr 2005
Posts: 11
Default Re: Geforce 6600GT does not run with driver 7174 and debian for amd64

Ok and where can I get the driver? I thought it should be in Xorg and so I have installed the latest version of xorg...
OrcLex is offline   Reply With Quote
Old 04-19-05, 09:50 AM   #4
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: Geforce 6600GT does not run with driver 7174 and debian for amd64

X is saying that it can't load the X driver module "nvidia" which should be located in /usr/X11R6/lib64/modules/drivers/. It would be better if you post the log generated by the nvidia-bugreport script. Please see the "If you have a problem, PLEASE read this first" for info about that.
And btw. the "nv" driver have no relation to the binary "nvidia" driver whatsoever other than they both support cards from nvidia.
Lithorus is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:10 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.