Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-21-04, 07:41 PM   #1
vputz
Registered User
 
Join Date: Jul 2004
Posts: 23
Default debian and 6106, sig11 fixed.

I'd been having considerable trouble with a debian (mixed unstable) installation and signal 11 errors, using the NVIDIA installer.

Uninstalling the old .debs didn't help; purging their configurations didn't help; NOTHING seemed to help. Happily, some threads on this forum pointed me toward TLS problems, so I went searching for the libnvidia-tls libraries:

Quote:
vputz@yakvid:~$ locate libnvidia | xargs ls -l
lrwxrwxrwx 1 root root 25 Jul 21 17:21 /usr/lib/libnvidia-tls.so.1 -> libnvidia-tls.so.1.0.6106
-rwxr-xr-x 1 root root 2352 Jul 21 17:21 /usr/lib/libnvidia-tls.so.1.0.6106
lrwxrwxrwx 1 root root 25 Jul 21 17:21 /usr/lib/tls/libnvidia-tls.so.1 -> libnvidia-tls.so.1.0.6106
-rwxr-xr-x 1 root root 2004 Jul 21 17:21 /usr/lib/tls/libnvidia-tls.so.1.0.6106
I don't know much about TLS, so naively I assumed that one library was being loaded instead of the other. So, again naively, I redirected:

Quote:
vputz@yakvid:~$ su
Password:
yakvid:/home/vputz# ln -s /usr/lib/libnvidia-tls.so.1.0.6106 /usr/lib/tls/libnvidia-tls.so.1
yakvid:/home/vputz# exit
...and X started right up. So while this seems like a peculiar way to "fix" things, at least my X server loads with GLX under 6106 now.

Pointers as to WHY this worked would be appreciated, but for those of you struggling with it, maybe it'll help.

Very positive about the nvidia-settings utility; may actually get my HTPC colors looking normal after a fashion.

-->VPutz
vputz is offline   Reply With Quote
Old 07-26-04, 09:54 AM   #2
mst3kroqs
Registered User
 
Join Date: Jul 2004
Posts: 2
Default Re: debian and 6106, sig11 fixed.

vputz:

Confirming - I was seeing the same thing on GeForce4 MX440 w/AGP8x, when trying to run TwinView or dual head mode (only). Standard modes didn't seem to bother it.

Your suggestion worked great, this must be a bug in the installer, as there are two different libnvidia-tls.so.1.0.6106 files of different sizes created.

Thanks very much!

-m
mst3kroqs is offline   Reply With Quote
Old 07-26-04, 12:42 PM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: debian and 6106, sig11 fixed.

The installer intentionally installs two different TLS libraries, the correct one ought to be picked up at runtime; FWIW, this isn't generally broken on Debian GNU/Linux (unstable) systems...
zander is offline   Reply With Quote
Old 08-04-04, 07:32 AM   #4
Clontarf_X
Registered User
 
Join Date: Aug 2004
Posts: 8
Default Re: debian and 6106, sig11 fixed.

I am having (well, had... ) the same problem on Debian 3.1 Unstable, NVIDIA 6106, XFree86 4.3 and KDE3.2

Hail the good ol' fiddlers who delve into the mess of 0's and 1's to knock up some sort of fix!

(L) vputz
Clontarf_X is offline   Reply With Quote
Old 08-04-04, 09:26 AM   #5
fudd
Registered User
 
Join Date: Aug 2004
Posts: 9
Default Re: debian and 6106, sig11 fixed.

Sounds interesting. I'll try if this fixes my problems tonight.
I had it running pretty stable under xfree86 after removing the int10 module. At least the hagnups disapeared, but some sig11 started.
Now I've upgraded to the xorg server, and hangups have started again....
fudd is offline   Reply With Quote
Old 09-17-04, 04:43 AM   #6
TomFrey
Registered User
 
Join Date: Sep 2004
Posts: 4
Default Re: debian and 6106, sig11 fixed.

Hi there,

just a short note, that the same solution also works for the driver version 6111.

Tom
TomFrey is offline   Reply With Quote
Old 10-07-04, 07:56 AM   #7
bylander
Registered User
 
Join Date: Oct 2004
Posts: 1
Default Re: debian and 6106, sig11 fixed.

I'll add my vote, with an MX420 SuSE 9.0 (with mythtv, xine and other modifiications) SuSE kernel 2.4.21-243-smp4G, Chaintech 7kdd board 1G ram... I had to do the same tls modification. Without TV-out enabled, no problem, with it enabled I need the fix which works as well without TV-out. Given Zander's comments in this thread, either Nvidia's run-time tls checker doesn't always work and/or my installation is doing something the checker doesn't appreciate.
Marty
ps. I searched the web for a *long* time before seeing this, it's not well documented.
bylander is offline   Reply With Quote
Old 05-01-05, 08:30 AM   #8
gwalker
Registered User
 
Join Date: May 2005
Posts: 1
Default Re: debian and 6106, sig11 fixed.

I had a similar problem with a Sparkle GeForce FX5200 128MB

Everytime I forced two display devices using

Option "ConnectedMonitor" "CRT,TV"

the x server would crash with a SIG 11.

I used vputz's suggestion and hey presto everything works.

I am using NVIDIA-Linux-x86-1.0-7174-pkg1.run

Just thought I would post in case this is useful to anyone.

Regards,
George.
gwalker is offline   Reply With Quote

Old 05-01-05, 11:28 AM   #9
Gnu_Raiz
Registered User
 
Join Date: Dec 2004
Posts: 124
Default Re: debian and 6106, sig11 fixed.

This was a big deal about a year and a half ago, I remember seeing it on a lot of mailing lists. Their was a switch you could use for the installer to use old classic tls config or something.

http://people.debian.org/~rdonald/index.php

For those who are link weary.

{If you have found this page because you are having TLS problems on a 2.4 kernel using the NVIDIA installer. Try the --force-tls=classic option.}

I have not had any problems with the 2.6 kernels and nvidia graphics drivers, I still us the GF2 with dual monitors.

Gnu_Raiz
Gnu_Raiz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:25 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.