Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-16-03, 11:46 PM   #1
samandhi
Registered User
 
Join Date: Jan 2003
Posts: 5
Send a message via ICQ to samandhi Send a message via Yahoo to samandhi
Default FreeBSD installation problem. Please help?!

I am new to FreeBSD, but have everything up and running. Well, all exept the Nvidia driver.

I have compiled and installed my kernel using the USER_LDT and SYSVSHM options. I also made sure that device agp, was in there also. I then installed the driver, and when rebooting I get a system stop at the mounting blah blah. It totally locks up and all I can do is to push the reset button on the tower.

I am using a GeForce 2 GTS w/32 mb ram, on an K7S5A Elite MB w/SIS chipset.
I cant say for sure but I wouldnt think it is something misconfigured in XFree86, as it doesnt even get that far (I dont have it set to auto boot anyhow). Does anyone have any ideas?
samandhi is offline   Reply With Quote
Old 01-17-03, 08:52 AM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

"I get a system stop at the mounting blah blah"

What's the system mounting? The root filesystem, or other filesystems? Does this kernel that you compiled with USER_LDT and SYSVSHM (and AGP device support, I guess) enabled at least boot without the nVidia drivers?

I'm thinking it might be something like Mandrake 8's issues with reiserfs -- it didn't install an initrd, and it built reiserfs support as a module, so if you formatted / as reiserfs, there wasn't support in the kernel to mount it at boot time, and you'd get a "kernel panic: can't mount root device 03:05" on boot. But I don't know a ton about *BSD, so it may not be that -- indeed, that may not even be possible, I don't know.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 01-17-03, 11:27 AM   #3
samandhi
Registered User
 
Join Date: Jan 2003
Posts: 5
Send a message via ICQ to samandhi Send a message via Yahoo to samandhi
Default

Yeah, I dont think that is possible, but to answer your question, yes, it does boot just fine if I stop the boot, and unload the nvidia driver then boot with my regular kernel.


Everything runs just fine, I just have NO 3d support at all. I have made sure that the dri driver is not even present, just in case (as I have heard that this is not compatible with the nvidia driver). I have done everything else that I can think of, but as I am still very very new to FreeBSD, I might be missing something simple.
samandhi is offline   Reply With Quote
Old 01-17-03, 12:36 PM   #4
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Hmm, OK. Like I said, I don't know much about any BSD system, so I don't know of much else to try.

Maybe someone else does? *looks around*
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 01-18-03, 01:05 PM   #5
clay
Guest
 
Posts: n/a
Default

I had issues with the nv agp driver... so i edited the ~/src/nv-freebsd.h file... search for USE_OS_AGP_GART and change it to #define USE_OS_AGP_GART

also put the following in your /boot/loader.conf
linux_load="YES"
agp_load="YES"
nvidia_load="YES"


then change your X config file as suggested and all should work.
  Reply With Quote
Old 01-18-03, 09:58 PM   #6
samandhi
Registered User
 
Join Date: Jan 2003
Posts: 5
Send a message via ICQ to samandhi Send a message via Yahoo to samandhi
Default

Ok I will try that. I have the loader.conf and xconfig files saying that. just havent edited the .h file. Thanks, will let ya know if it works.

BTW it is locking up where it says Mounting drive as ufs:/dev/ad1s1a
samandhi is offline   Reply With Quote
Old 01-18-03, 10:30 PM   #7
samandhi
Registered User
 
Join Date: Jan 2003
Posts: 5
Send a message via ICQ to samandhi Send a message via Yahoo to samandhi
Default

Im sorry the message I am getting is mounting root as UFS:/dev/ad1s1a


And what you suggested didnt work either. It is still totally locking up with the message mounting root as etc. ... etc. ... Now what? hehe
samandhi is offline   Reply With Quote
Old 01-19-03, 02:25 AM   #8
aabram
Registered User
 
Join Date: Jan 2003
Posts: 2
Default you need ufs support

Quote:
Originally posted by samandhi
Im sorry the message I am getting is mounting root as UFS:/dev/ad1s1a
You need to enable

options FFS
options FFS_ROOT

in your custom kernel config file.

Generally safest way to make custom kernel config is to make a copy of GENERIC and only change the lines you need, leaving everything else intact. If this works then you can later on start stripping your custom config from unneccessary stuff.

Read LINT for all available options and explanations.
aabram is offline   Reply With Quote

Old 01-19-03, 09:41 AM   #9
samandhi
Registered User
 
Join Date: Jan 2003
Posts: 5
Send a message via ICQ to samandhi Send a message via Yahoo to samandhi
Default

Those are already enabled in my Kernel. They are by default anyhow, I just didnt disable them. Hmmm curious why it is doing this.
samandhi is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Graphics driver installation problem (your comments will be highly appreciated) apuurboo NVIDIA GeForce 400/500 Series 0 06-16-12 08:35 AM
Graphics driver installation problem (your comments will be highly appreciated) apuurboo NVIDIA GeForce 400/500 Series 0 06-13-12 08:58 AM
Another? installation problem on RH7.3 oddjob NVIDIA Linux 4 09-22-02 09:13 PM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 11:58 AM
download problem with linux NVIDIA driver packages Timo NVIDIA Linux 7 07-31-02 10:22 AM

All times are GMT -5. The time now is 05:59 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.